26

I've edited ~/.kde/share/config/kwalletrc and added

[Auto Deny]
kdewallet=Chromium

In the KDE Wallet Configuration in system settings I've unchecked "Enable the KDE wallet subsystem". This also seems to add:

[Auto Deny]
kdewallet[$d]

However I'm still getting a popup when I visit my first page in google chrome. How can I stop it?

I've noticed there are actually two locations for wallets. One in ~/.kde/share/apps/kwallet/ and one in ~/.local/share/kwalletd/. At one point when I changed the KDE colour theme I noticed the popup for chrome was different to the GUI I got through system settings. There's also a duplicate KDE Wallet Configuration I can get by running kwalletmanager->Settings->Configure Wallet where I get the same options but their own set of values. Even after unchecking "Enable the KDE wallet subsystem" here as well I still get a popup from chrome. What's going on with the mess of multiple config locations and settings pages?

  • You are using KDE 5 (Plasma 5) right? The ~/.kde/share/apps/kwallet/ location is the old one that is migrated to ~/.local/share/kwalletd/ and should not be in use. For the same reason, the setting in ~/.kde/` is not honored... and note that your system can have both KWallet for KDE 4 and KDE 5 installed, complicating things even further. – Lekensteyn Nov 3 '15 at 10:30
  • Yes, I'm running 5. Can I remove the old one and all its configs? I guess chrome is using that instead. – jozxyqk Nov 3 '15 at 10:36
  • It would not help I think, if you remove the old one it would appear as if no wallet has ever been made and then it would prompt you to create one. I think that @RobW's proposed solution works better (and is actually what you mean). – Lekensteyn Nov 3 '15 at 10:48
  • Ideally, I wouldn't have two version of the same thing, chrome would use the latest one and I could choose to disable it system wide the regular way (or for that matter, use it). – jozxyqk Nov 3 '15 at 11:04
  • kde5: look in ~/.config for kwalletrc – Tim Richardson Jan 4 at 9:31
25

You can completely disable the KWallet backend by adding the following command-line flag to Chrome: --password-store=basic

For instance (if you're using Ubuntu's Chromium build), edit /etc/chromium-browser/default (system-wide) or ~/.chromium-browser.init (per-user) and add the flag to CHROMIUM_FLAGS. E.g.:

# Default settings for chromium-browser. This file is sourced by /bin/sh from
# /usr/bin/chromium-browser

# Options to pass to chromium-browser
CHROMIUM_FLAGS="--password-store=basic"

If you're using ArchLinux's Chromium build, edit ~/.config/chromium-flags.conf and add:

--password-store=basic
  • 1
    Where would be a good place to put this (so that it works with KDE shortcuts, xdg-open, when I type google-chrome in the terminal, etc.)? Is there a config somewhere? – jozxyqk Nov 3 '15 at 11:01
  • @jozxyqk I've updated my answer. The answer applies ot Ubuntu and ArchLinux, if you use another OS, then the exact method might be different. – Rob W Nov 3 '15 at 11:06
  • 3
    I couldn't find a similar place on fedora, but I found /opt/google/chrome/google-chrome and added --password-store=basic to the exec command at the bottom of the script. Seems to work. Thanks very much! – jozxyqk Nov 3 '15 at 11:23
  • On Debian Jessie (8) I installed this file to /etc/chromium.d/no-kwallet – Daniel Böhmer Jan 13 '17 at 19:52
  • For vivaldi in /opt/vivaldi/vivaldi. – Zitrax May 3 at 9:52
13

No matter what distro you're on this might work.

Open "google-chrome" file with a text editor (I used kate <3)

kdesu kate /opt/google/chrome/google-chrome

Paste this at the end of file with quote sign

"--password-store=basic"

So it must look like this

else
  exec -a "$0" "$HERE/chrome"  "$@" "--password-store=basic"
fi

SAVE AND EXIT. DONE!

(I tried it on OpenSUSE Thumbleweed with success! :D)

  • This works on Ubuntu 16.04 too. You also need to set google on hold apt-mark hold google-chrome-stable, because any update will remove that setting. They are not a fair company. – Crouching Kitten Nov 26 '17 at 17:22
5

I found a simple solution, that works a 100% of the time, on any version of KDE:

I couldn't find any way to get kwallet off my system. There are some dependency issues and pacman won't let you remove the package. However I managed to avoid the irritating pop ups. First you need to remove any existing wallet. Delete the files under ~/.kde/share/apps/kwallet/.

Next time you do anything that interests Kwallet, it will pop up again. But this time it will ask you for an encryption method, blowfish or gpg. Select blowfish and when asked for a password, provide an empty password.

It won't ask for password anymore. This method worked for me on kwallet 5.13. Hopefully it will work for you too.

  • 2
    You found this solution where? You need to link to the source. – Stephen Rauch May 21 '17 at 3:18
  • no, it doesn't work, deleted ~/.kde/... as its written here, restarted chrome and it still start popup kwallet nightmare – stiv Sep 17 at 9:44
1

I solved this one out in the KWalletManager by creating a new wallet named test and replacing the .salt file from the existing wallet named kdewallet, with the .salt file of the newly created wallet test.

So

cd /home/'username'/.kde4/share/apps/kwallet 
mv kdewallet.salt .kdewallet.salt;cp test.salt kdewallet.salt

And now the existing wallet named kdewallet has the password for the newly created test wallet.

Distro: Mageia 5.

0

One way is just to give chrome a fake dbus socket (Also you will probably need to disable password manager... you can use Paster Password Manager as an alternative)

env DBUS_SESSION_BUS_ADDRESS=none chrome 
0

A quick solution is to just change KWallet's password to a blank one:

KDE's Application Menu (or Launcher, etc.) > System > KWalletManager > Change Password... > OK > Yes

This ends KWallet's password pop-ups when starting Chrome/Chromium.

  • There is no Change Password... menuitem there. – stiv Sep 17 at 9:42
0

The easiest solution to this Problem got served by the later KDE Plasma Versions. I currently use Version 5.12.7.

1. Go to: System Settings -> Account Details (Personalization) -> KDE Wallet

2. Uncheck the Box "Enable the KDE wallet subsystem"

3. Apply

  • it doesn't work, it says: the module Account details is not valid configuration module – stiv Sep 17 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.