1

I have two systems:

  1. Home desktop - Windows 10 PC - no domain (only WORKGROUP) - no homegroup created or joined - manually shared a particular folder with "Everyone"

  2. Work laptop - Windows 7 PC - connected to work domain - no homegroup created or joined - trying to access shared folder from Home desktop

When both the above devices are on the same network (my home wi-fi), I am unable to access the shared folder from #1 on #2 using \home-desktop\shared-folder addressing. I also noticed that I am unable to access \work-laptop on home-desktop.

What am I missing? Do I need to do anything extra?

2
  • Add the laptop to WORKGROUP. – DavidPostill Nov 1 '15 at 18:46
  • Adding laptop to WORKGROUP is not an option because it is part of my employer's domain and a device can only be in one domain/workgroup at a time. Replacing pcname with IP works! But it now asks me for domain\username and password. I know the username password, but my desktop does not belong to a "domain". It only belongs to the default workgroup called WORKGROUP. How do I give workgroup name while logging in from my laptop? – shikhanshu Nov 1 '15 at 22:49
1

ACCESS SHARED FOLDERS ON PCS IN THE SAME NETWORK

Short Answer Light Detail

You could also configure the desktop SHARE to have AUTHENTICATED USERS change and read permissions, and then set local desktop account to have folder NTFS ACL level permissions with READ and/or MODIFY at that level (the actual folder).

  • A1. From the laptop try mapping or getting to \\pcmname\sharename and if prompts type in pcname\username for the username, and then the password of that account (local desktop account) when prompted. You can replace pcname with the IP address of the machine you're connecting to or authenticating to.

  • A2. You will want to be sure to set the SHARE and NTFS folder permissions as I specified above first. Whatever LOCAL account you grant to the folder (on the desktop) with NTFS permissions, you'll type in IP Address\username and then it's password.

  • A3. The IP address part of the username is going to be that same as the IP address you use when you put it \\IPaddress\sharename that password for that account is the same password you use when you sign onto that PC with that account -- that's why you give it the NTFS permissions as listed above.

  • A4. I assume you can also try WorkgoupName\username and that password of that account as well. I assume the workgroup accounts are all local accounts on the machines though but start with that.


ADVANCED SETUP FOR WINDOWS SHARE AND NTFS PERMISSIONS

(HELPFUL SCREEN SHOTS AT BOTTOM)

At the folder location you are going to share, follow the below instructions. . .

SETTING UP THE SHARE LEVEL PERMISSIONS

  1. Right-click on the folder -> Select Properties --> Sharing tab -> click Advanced Sharingbutton.
  2. In the Advanced Sharing window, check the Share this folder option, type in the sharename (same as you'll us in the \\pcname\sharename), and then click the Permissions Button
  3. In the Permissions for <Sharename> window, you will want to highlight and then select remove on any accounts or groups already listed, and then you will want to select add and then type in Authenticated Users in the Enter the object names to select and then press Check Name (the entry should resolve and get an underline beneath it), press Ok.
  4. Check both Read and Change options for the highlighted Authenticated Users entry in the Permissions for Authenticated Users section, press Apply and then press Ok, press apply and/or ok all the way out those windows and properties.

SETTING UP THE NTFS LEVEL PERMISSIONS

  1. Right-click on the folder -> Select Properties --> Security tab -> select the Editbutton.
  2. In the Permissions for <Foldername> window, click Add
  3. In the Select Users or Groups window type in the username of the account you're signed on with now, which will be the same you type in when you access remotely, (unless you use some other local or workgroup account), and then press Check Name to make the entry resolve and get an underline beneath it, press Ok.
  4. In the Permissions for <Foldername> window, highlight the account you just added, and then beneath in the Permissions for Authenticated Users section, ensure the Modify permission is selected for that account, then press Apply, press Ok

THE REST

1. See A1., A2., A3, and A4 above for the rest of the steps once you get here.


HELPFUL SHARE LEVEL PERMISSIONS SCREEN PRINTS

enter image description here enter image description here enter image description here

HELPFUL NTFS LEVEL PERMISSIONS SCREEN PRINTS

enter image description here

2
  • 1
    Thanks for such detail! Logging in using pcname\username and ipaddress\username both worked! Thanks a lot for your help. – shikhanshu Nov 2 '15 at 14:27
  • Sorry i am a new user and didn't know how to do that. Is it done now? – shikhanshu Nov 2 '15 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.