4

Updated

I have an ASRock H55M-GE motherboard. Currently it has 2X2GB RAM, for a total of 4 GB RAM.

I thought I'd like to update the RAM, so, first I bought two new Kingston KVR16N11S8/4 4GB RAM sticks, to put into the two empty slots to get a total of 12GB RAM. But after many problems, similar to what's described below, they wouldn't work, so I returned them. I then recently bought two Team DDR3 1600MHz PC3-12800 4GB RAM sticks. But, I encountered the same problems.

When I install them in my computer, being careful to follow the motherboard's manual and place them in the correct slots, The BIOS recognizes them and seems to have no problem:

BIOS screen

But, Windows 10 refuses to boot, and instead gives me an error screen saying, "Your PC ran into a problem and needs to restart. We'll restart it for you." Usually, the error screen says IRQL_NOT_LESS_OR_EQUAL, but it sometimes says other things, like in this screen grab. I believe it's having some kind of freak out over hardware, and the specific error messages are probably not too revealing.

Windows 10 boot error

I have checked to make sure that all cards and RAM are seated correctly. I replaced the battery on the motherboard. I have tested the new RAM in a different computer where it seems to work.

I have booted using an Ubuntu live CD, and it boots fine, and in the Ubuntu interface, I can see that it recognizes the 12 GB RAM no problem:

Ubuntu liking the RAM

I'm willing to re-install Windows if that's what it takes, so I took one of the original Windows 7 install disks that came with my computer and tried to see if I can install a fresh version of Windows 7, but I get a similar hardware error as version 10:

Windows 7 install error

I have also removed all RAM and tried one stick of the new RAM, which is 4 GB, to test if there is some kind of memory cap at 4GB, but that also fails.

I have used Windows internal recovery program to return the system to a fresh install state, which I believe removes all drivers and apps. However, Windows will still not boot with the new RAM installed.

So, to recap, the BIOS recognizes the new RAM, Ubuntu recognizes the new RAM, another computer recognizes the new RAM, this is a second set of new RAM... this all strongly indicates to me that the problem is squarely on Windows, not the hardware. Why would Windows have such a problem handling a simple RAM upgrade?

More importantly, how do I get Windows to boot after installing my new RAM?

Here is some information about my current RAM (before installing new RAM):

CPU-Z output

  • 1
    I'm 99% certain the problem isn't the OS refusing to work with your new RAM. Have you tried removing the new RAM, only using the new RAM, or switching the slots between the new and old RAM? The error message indicates a driver error, which can be caused by faulty RAM. – Peter Nov 2 '15 at 14:11
  • @Peter, I have tried switching the slots, in every combination I can think of. I have tried using just the new RAM, just one of the new RAM. and put back the old RAM to make sure the old RAM still works fine. The new RAM works in another computer (an i5 with a different motherboard). – Questioner Nov 2 '15 at 14:47
  • 1
    Important trouble-shooting step at this point: use a boot CD (or USB) with Linux on it (Ubuntu Live would be fine) and make sure that Linux boots. That will confirm that it is Windows specifically that is having the problem, and not a hardware incompatibility. – Dane Nov 2 '15 at 15:27
  • 1
    I have checked at least 5 modules listed in the QVL list. They all were 1.65 V modules. Your new module is 1.5 V. What CPU do you have? "DDR3-2000, 2133, 2200 and 2600 are only optimized for Core i7 860 and i7 870" if it isn't an i7 that likely also is a problem. You should also verify you are using the most current firmware. – Ramhound Nov 2 '15 at 15:29
  • 3
    The fact the new memory won't by themselves indicates a hardware problem. You booted a 64-bit Linux environment not a 32-bit environment correct? – Ramhound Nov 2 '15 at 15:35
3
+100

First, some remarks :

  1. According to your motherboard manual, to install four DIMMs, all four need to be identical. So the most that is recommended with yours is to use the two 4GB sticks, while the 2GB ones are unusable together with the others.
  2. For using two DIMMs, they need to be installed in the white slots.
  3. Linux may be cleverer than Windows in forcing the usage of DIMM sticks that do not exactly conform to the specification.
  4. You have bought high-quality modern DIMMs for a motherboard dating apparently from 2010. They may just be too good for the motherboard.

Based on the above, I have the following suggestions :

  1. Restore the configuration of RAM to the one that worked, boot Windows 10, start Windows Update and fully patch the computer. Especially pay attention to device-driver updates that are usually found as Optional. There is no point in using the ASRock drivers, since they date from 2010.

  2. Download and install the Crucial System Scanner. Let it scan your computer and see which DIMMs it recommends and pay attention to their specs. Crucial is a RAM vendor, and their utility does an excellent job of analyzing the motherboard.

I believe that the results of the scan by Crucial will solve the problem. Their prices are also very reasonable and one can order from the scanner, whose results Crucial guarantees. You could post the scan results, if you wish us to have a look.

  • Thanks for this detailed response. I misread the manual, I thought it was only a requirement to have identical DIMMs in the same coloured slots. I will proceed with only the two new DIMMs in the white slots. I will also try your other recommendations and see how it goes. – Questioner Feb 12 '16 at 2:33
  • I used the Crucial System Scanner as you suggested, and it returned these results. I'm a little skeptical about them recommending their own brand, though, and also in light of your suggestion that my computer might have older specs, and they are recommending more modern RAM. – Questioner Feb 12 '16 at 4:07
  • There are some differences between Crucial and the ones you bought, for example 1.5V instead of the more economical 1.35V. I'm not enough of a technician to tell categorically that the DIMMs you bought are incompatible. The Crucial scanner always worked for me and was never wrong, so I suggest you follow its recommendations to the letter. The scanner is their tool for avoiding problems with their own clients buying the wrong RAM from them. You don't have to buy their brand, but I suggest following their specs. – harrymc Feb 12 '16 at 6:50
  • Thanks for your further insight. I'm wondering what the key difference I should be looking for is. is it the voltage? – Questioner Feb 12 '16 at 9:04
  • Only an electrical engineer can answer that. I myself have always played safe by ordering from either the computer manufacturer or from Crucial or others that supply a scanner that guarantees the RAM. This guarantee is not absolute, but it's better than guessing. – harrymc Feb 12 '16 at 9:24
4

You have ruled out direct hardware incompatibility by running 64-bit Linux successfully with the same configuration as your 64-bit Windows 10 install.

According to this MSDN article (https://msdn.microsoft.com/en-us/library/ms854226.aspx), "it might be caused by a device driver, a system service, a virus scanner, or a backup tool."

As such, I would suggest that you ensure that your device drivers are fully up-to-date (and uninstall any unnecessary ones). Also, as a test, disable/uninstall your virus scanner and backup tools.

You can use MS Config (Win + R to then run msconfig) to see what all you have running at startup. You can use the services snap (Win + R to then run services.msc) to review what services are running at startup. There is presumably a culprit in there.

  • Thanks for your suggestions. I've reviewed the programs and services running at startup, but there are dozens, maybe more than a hundred, with obscure names that I can't determine if they are relevant. I removed about 5 services I'm sure I don't need (when was the last time I got or sent a fax?), but I don't think I have the skills to determine if any of these programs are related to my RAM issues. – Questioner Nov 3 '15 at 4:40
  • +1. You are using more than 4GiB of memory, which means your address space no longer fits into a 32 bit long counter. If someone (erroniously) used sunch a counter in a driver and you exceed 4GiB then it will fail. – Hennes Feb 11 '16 at 14:51
  • @Hennes. Okay, but, if I took out the original RAM, and just put in one 4GB RAM stick, then shouldn't it work? I tried that, and it didn't. Also, why would installing from the Windows 7 install disk fail? By definition, it has no additional software installed yet. – Questioner Feb 11 '16 at 16:07
  • I've now run Windows built in recovery program to return to a fresh install state, where all installed apps and drivers are removed. However, Windows still will not boot. – Questioner Feb 11 '16 at 18:09
  • Thank you for your help. Your efforts were much appreciated. – Questioner Feb 13 '16 at 15:57
-7

More importantly, how do I get Windows to boot after installing my new RAM?

Potential solutions:

  1. Run memtest from grub. Why haven't you done this already?
  2. Try booting one hard disk at a time. You have only booted Ubuntu live, after all. I'm not sure what, if any, implications this has for swap space. Or if that even matters.
  3. Do not boot Windows.
  • 3
    "Do not boot windows" is not an answer to the question. – DavidPostill Feb 12 '16 at 12:20
  • It may not be an answer specific to this question, although as a "potential solution" (in third place) as posited it would solve an awful lot, unless the user has a specific reason other than habit for booting proprietary malware on a regular basis. – gtibicen Feb 12 '16 at 15:34

protected by Community Oct 6 '18 at 7:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.