2 Intel Macs; a brand-new MBP and a 1-year-old iMac. Both have good quality wired network connection to an Airport Extreme. I regularly copy a 25Gb+ file between them. The disks have plenty of space and the iMac was defragmented a little while ago too.

Most of the time it takes around 9-10 minutes to copy the file. Sometimes it takes 40+ minutes. I have no idea why. I thought that sometimes the MBP was perhaps transferring the file over the airport wireless connection rather than the wired one, but I've disabled the wireless connection on the laptop and it's made no difference.

I'm fairly sure it's nothing to do with the disks, because most days it transfers quickly and then suddenly one day it crawls along. The only other box on the network is a Dell server running Windows 2k3. None of the machines are under load when the transfer happens and there's nothing else of any significance happening on the network, as far as I can tell.

Where would I start trying to figure out what is causing the delays? My understanding is that the network should all be running at 1Gbit - how would I go about checking this out?


Make sure that time machine (or any other backup) is not active, then watch the network, cpu, and disk usage using "activity monitor". That should show you where the bottleneck is.

My guess would be disk, because a gbit network shouldn't ever be saturated on a local network like you describe.

  • Thanks for the suggestion - I'll try this tomorrow (hopefully things will be running at proper speed tomorrow) and get a feel for what it's supposed to look like, in readiness for the next time it's on a 'go slow'. – robsoft Jul 21 '09 at 14:10

Well, I don't know what is causing the problem (though I have suspicions it's to do with plugging the laptop into my home network in the evenings, then back into the office one in the mornings)...

...but I noticed that in the network settings on the laptop, under the wired ethernet connection, on the advanced page, on the 'ethernet' tab, the system was set to automatically detect the network settings, and it was sometimes switching to 100BaseTX - when this was the case, the transfer was on a go-slow. If I changed the settings to manual and switched the setting to 1000BaseT, the speed picked back up again. So, without knowing much about this kind of thing, I'm guessing that something causes the laptop to think it has to connect to the network at a slower speed than the max it can do. Manually changing this speed gets things working quickly again, so for the time being I've just left the laptop configured 'manually' to be 1000BaseT.

Interestingly this doesn't seem to be causing any problems with my home network either (which is another Airport Extreme and a little 5-port DLink autosensing switch).

So this isn't really an answer in the sense that it's an explanation, but as a work-around I'm happy. :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.