I'm unable to update my OpenGL version past v1.1 and am in need of help!

I'm running on Windows 7 and am trying to update my system's version of openGL. My graphics card is an NVDIA Gforce 960, and I have downloaded and installed the latest drivers from the Nvidia site.

Display Driver and OpenGL version

Despite trying numerous driver versions, full uninstalls, etc., my version of OpenGL remains v1.1. It is very much like this question here, however, I don't seem to have an "Nvidia Enhanced Display driver" which I can uninstall.


So, the question is, could this still be an issue with the default driver being used by the motherboard - or possibly some legacy OpenGLL DLLs that are being used before the system looks within the Nvidia Graphics location?

Any help would be greatly appreciated. Thanks!

  • "My question is, could this still be an issue with the default driver being used by the motherboard" - You replaced those when you installed the current Nvidia drivers. – Ramhound Nov 4 '15 at 16:37
  • You don't appear to be using the current Intel display drivers. I can't tell what program that is on the right, but the version displayed, is not the current version. So I suggest you download it. – Ramhound Nov 4 '15 at 16:47
  • Its possible the version I linked to won't work on Windows 7 per the documentation on the page. If that is the case then download the last version that does work on Windows 7 The version you have I determined before I edited my comment, was not the current version, based on the version being reported. The reason OpenGL is not working is because your using your iGPU not the dGPU, and currently, your drivers for the iGPU don't support anything except OpenGL 1.1 – Ramhound Nov 4 '15 at 17:01
  • Thanks for the info Ramhound. However I'm unable to install any Intel drivers - I'm getting the error "Your computer does not meet minimum requirements", even though I'm installing the driver for the correct (4th gen i7 4790k) processor. Based on the last post in this thread communities.intel.com/thread/43822?start=0&tstart=0 I may need to change some system settings to allow an install. If you have thoughts, I'd be interested in hearing them. – user3279773 Nov 4 '15 at 18:09
  • So what fixed your problem so I can submit an answer? – Ramhound Nov 4 '15 at 18:09

The issue was that I was logged into the PC with Windows Remote Desktop Client which does not support anything past OpenGL 1.1. The resolution was using a new Remote Desktop client like LogMeIn or Chrome's Remote Desktop Extension.

  • This would have been helpful information 6 months ago. – Ramhound Apr 5 '16 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.