0

Workstation: Windows 10 and Windows 7sp1

Server: 2008r2sp1 Standard Domain Controller.

I've created a GPO GPP to delete some files on the users desktop. The GPO is linked to the OU which contains all my users. Security Filtering is set to a group named "MasterCAM Users". The "MasterCAM Users" group contains my test user. The Preference is located in User Configuration\Preferences\Windows Settings\Files.

enter image description here enter image description here enter image description here

When I log into a Windows 7 member of the "MasterCAM Workstations" group with my test user the files are deleted as expected. I tested this on 3 different Windows 7 machines, all worked fine. When I log into a Windows 10 member of the "MasterCAM Workstations" group nothing is deleted. I also tested this on 2 other Windows 10 workstations.

If I remove Item Level Targeting and log into the Windows 10 machine with my test user the files are deleted. If I set Item Level Targeting to check the Computer Name instead of Security Group the files are deleted. But whether I check user or computer membership of a Security Group no files are deleted. I have also double and triple checked the membership of both "MasterCAM Users" and "MasterCAM Workstation.

Group Policy Modeling shows that the GPO should be applied for the Windows 10 machine and my test users. Group Policy Results for the Windows 10 workstation and my test user shows the GPO in question under Applied GPOs on the Summary Tab. The Settings tab of Group Policy Results shows nothing for User Configuration\Preferences\Windows Settings\Files. If I run the same Group Policy Results Query on a Windows 7 machine with my test user the delete operation shows up under User Configuration. If I query the results for the Windows 10 machine and my test user after removing Item Level Targeting I see results under User Configuration\Preferences...

Did something change in Windows 10 that isn't working with a Server 2008r2 GPP files delete operation? Is there a bug? Am I doing something wrong?

Thanks for taking the time to read my question!

0

Well, so far in my testing it seems like my problem is with the Security Group. After some serious searching I found this blog post. As soon as I removed the DOMAIN from the security group targeting logic everything started to work.

0

There is a big issue with group policy after an update of microsoft. You can solve installing a patch. Try installing Windows6.1-KB2904034-x64.msu or Windows6.1-KB2904034-x86.msu in base of your system.

https://support.microsoft.com/en-us/kb/2904034

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.