0

I have an early 2011 MBP 15" running El Capitan OS X.

Late last week I upgraded my ISP internet from 20 mbps to 40 mbps. I connected my laptop to the router with an ethernet cable and it was testing as it should. However, when I ran the test on speedtest.net over wifi it was only clocking 20 mbps. I found that strange. I ran the test over wifi on my iPhone and also on my wife's 2008 MB laptop. Both clocked at or over 40 mbps. At this point I ruled out any problems with the router/internet and started looking at my MBP. After some looking around I noticed that my wifi was connecting 802.11g mode and not n. My wife's MB was connected to n. I logged into the router and changed the broadcast mode from 802.11 a/g/n to just 802.11 n to see if I could force my MBP to connect on this mode. The wifi connection dropped and would not connect. I ran a diagnostic and it said wifi was not associated, or something like that. I have the report but don't know which part to paste on here. After this I tried changing the router channel, Tried several different channels and still connecting to 802.11g. I've searched this forum as well as others and have not been able to find a solution to this problem.

Any suggestions welcome.

Thanks.

MacBook Pro, OS X El Capitan (10.11.1)

EDIT: Router encryption is set to WPA2 AES.

  • Is the Wifi set to 20 or 40 MHz? Some older Apple devices don't like 40, so you need to either lock the router to 20, or some have the option of both. – Tetsujin Nov 5 '15 at 8:17
0

If your 802.11 network requires wireless encryption, make sure the MacBook Pro in question is configured to use WPA2 encryption. Go into its list of preferred networks, delete the entry for the network in question, save, and then re-join the network, specifying WPA2 encryption if asked.

802.11n requires that you use AES-CCMP encryption (also known as AES, CCMP, WPA2, WPA2-PSK, WPA2 Personal, WPA2 Enterprise) if you're going to use wireless encryption at all.

It may be possible to get into situations where your MBP is stuck using the wrong encryption type because you accidentally selected the wrong encryption type when joining the network (for example, when joining a "hidden"/non-broadcast-SSID network), or if you joined the network when it was configured for, say, only original WPA (TKIP).

You should also consider disabling original WPA (TKIP) on your wireless network. Set it to WPA2-only. There really isn't any reason to run WPA/TKIP on your network anymore, and it causes more harm than good. There were vanishingly few clients ever produced that supported WPA/TKIP but were never upgraded to support WPA2/AES, and they were all probably produced in late 2002 or early 2003, so they're probably all in a landfill by now.

Backstory: The earlier 802.11 encryption standards, WPA (TKIP) and WEP, were both built on top of the RC4 stream cipher, and the RC4 hardware engines in the 802.11 chipsets of those eras couldn't keep up with 802.11n data rates. By the time 802.11n was created, fast AES-CCMP (WPA2) hardware engines were already common in 802.11 chipset designs, so the IEEE specified 802.11n to require AES-CCMP if wireless encryption is used at all.

  • Thanks for the help. I went into the Wifi Network advanced settings. Under the network security for my network it said WPA2 Personal. I went into my routers settings and it was set to WPA2 AES encryption. I deleted it my network under network settings and readded it just to double check. Problem persists. – Thebb Nov 5 '15 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.