0

i try to install RHEL5 x64 rpm package( mochapro-4.1.2-9658.x86_64 ) on Fedora 22, but it wants libgdbm.so.2()(64bit) library which is absent in dnf. it gives following error:

Error: nothing provides libgdbm.so.2()(64bit) needed by mochapro-4.1.2-9658.x86_64

i tried using rpm search and it seems gdbm-1.8.0-38.el6.x86_64.rpm has the library, but when i try to install it, it won't. if i try to install it with --allowerasing, it wants to remove dnf altogether. i also tried unpacking rpm by converting rpm2cpio and passing it to cpio, which got me the library file, which i copied to /usr/lib64/ but the rpm package does not seem to see it. if i install with --nodeps, rpm installs does not launch.

is there a way i can manually resolve the dependency with liblibgdbm.so.2 i've extracted?


ended up creating dummy .rpm file, which helped bypass dependency issue, but i get segmentation fault 5337 error when i launch, i guess its due to fedora22/rhel5 differences

  • Wat gave you the idea that RHEL packages are compatible with Fedora? Sure, RHEL branches off (sort of) Fedora, but normally some 2 or 3 releases back... your Frankenstein monster will just call all pitchfork and torch bearing citizen... – vonbrand Nov 5 '15 at 2:13
  • sry i'm new to linux, as you probably can tell – unkind Nov 5 '15 at 13:56
0

It won't work. RHEL5 and RHEL6 have different libraries. You can spend days rebuilding the old libraries to fit your new Fedora 22... However it is much easier to start up virt-manager, create new virtual machine with CentOS 5 and install there mochapro-4.1.2-9658.x86_64.

  • thanks for suggestion. i didn't consider virtualization due to overhead, as stuff i do is intensive on ram/cpu/io – unkind Nov 5 '15 at 14:15
  • Today virtualization consume less then 1% of resources as overhead. – msuchy Nov 6 '15 at 15:42
  • i've thought more like 14-20%. do you have a link to a relative benchmark? – unkind Nov 6 '15 at 23:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.