3

I'm having the most annoying problem with Citrix Web Receiver. It seems to be configured by the company that I'm remoting into, to span every monitor on the client station.

Is there any way to simply disable screen spanning for all Citrix Receiver sessions? I'm hoping that it's as simple as an arcane registry key.

I've been googling for answers, but they all suggest hijacking the downloaded ICA somehow, and then modifying some content on it. It doesn't sound like a very permanent solution to me. Intellectually satisfying, perhaps, but I don't think I'd like to spend yet even more time to hijack this file, modify it, and then connect to the remote station - there must be a simpler, better way... (one hopes)

Background: The annoyance comes from the fact that I have a smaller monitor (19") and a larger monitor (30") and everytime I window from the full-screen, and then resize the Citrix session window that spans the 2 extremely different monitors, it staggers between the monitors (I'm guessing Citrix session is trying to figure out why the resolution goes from HD to WQHD) and sometimes the session just quits during the resize. I'm building up lots of hate for Citrix at this moment, LOL.

2

I was able to right-click on the "Application - Citrix Receiver" window title bar and use the "Resize Session" menu option to resize to a single screen. :)

| improve this answer | |
  • use SHIFT+F2 to get out of full screen to do this - might help someone else – Richard Dec 6 '19 at 18:49
0

Based on the comment above from @StackzOfZtuff regarding the opposite question, I fixed this by:

  1. Switching to windowed mode
  2. Resizing the window so that it only sits on one monitor
  3. Switching back to full screen
| improve this answer | |
  • That used to work for me, now when I switch back to full screen it spans both monitors, but treats them as a single monitor. I have no idea why. – Matthew Rathbone Apr 22 at 16:14
0

One very simple trick that worked for me (after trying a few others) was simply to switch off the monitor you don't want the Citrix session to "invade" and then choosing the full-screen option. Afterwards you turn on the monitor again and presto!

(to be clear: Only tested with HDMI/DP monitors and Ubuntu 20.04. Using another OS and/or DVI/VGA may yield different results.. but I'm lacking the hardware to test that)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.