I have a website that I created on a WAMP (latest version 64 bit) server. It runs perfectly from the localhost directory. I'm now ready to have outside connections connect to my www directory. My issue is there is something blocking me from viewing it when I enter in http://71.229.5.x:80

  1. WAMP server was put online
  2. httpd.config file in the apache directory was adjusted so that Listen was set to Listen
  3. My router was set to port forward on 80 (xfinity router).
  4. netstat -a -n confirms TCP: is listening
  5. All known firewalls are completely shut off
  6. telnet 10.0.0.x 80 on main computer connects (displays html from wamp)
  7. telnet 10.0.0.x 80 on laptop (on same network) connects (same thing with html)
  8. telnet 71.229.5.x 80 Failed to connect

I feel like I'm right there and I'm just missing one step. The main question seems to be why can't outside requests reach my IP? I should also mention that aside from what I provided above I'm a complete noob when it comes to these types of issues. Any type of help would be greatly appreciated. If there's anything else I can do to provide insight please let me know!

  • Are you outside your network when testing outside access?
    – Paul
    Nov 5, 2015 at 3:57
  • No I'm not. All instances of testing have remained within my house which is on the same network. Nov 5, 2015 at 20:37

1 Answer 1


From the way you describe it, it appears this has to do with hairpinning, i.e. the fact that you and the server are within the same NAT network, but you are trying to access the server thru its public IP rather than its local (LAN) IP. Currently, many routers do not allow that.

If you are running a Linux router (like a dedicated pc, or a router with DD-WRT, OpenWrt, Tomato, TomatoUSB, and so on) you can enable hairpinning as suggested in this ServerFault post. If not, you may read your router's manual and see whether it is possible to enable it. Failing this, you are left with just one possibility, access your server from a pc outside your LAN.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .