-1

I'm running Windows 8.1 and it's trying to resolve hostnames through a IPv6 ULA. Have a look at ipconfig /all:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : rivercardiff
   Primary Dns Suffix  . . . . . . . : rivercardiff
   Node Type . . . . . . . . . . . . : Mixed
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : rivercardiff
                                       lan

Ethernet adapter Ethernet 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : TAP-Windows Adapter V9
   Physical Address. . . . . . . . . : 00-FF-E5-CA-58-CA
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Ethernet:

    Connection-specific DNS Suffix  . : lan
    Description . . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connection
    Physical Address. . . . . . . . . : 00-19-99-C1-C9-49
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::38b5:3be8:dd73:5c3d%3(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.247(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : 05 November 2015 12:06:54
    Lease Expires . . . . . . . . . . : 05 November 2015 12:21:53
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DHCPv6 IAID . . . . . . . . . . . : 50338201
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-59-DE-57-00-19-99-C1-C9-49
    DNS Servers . . . . . . . . . . . : fdd7:3388:bf71::1
                                        192.168.1.1
    NetBIOS over Tcpip. . . . . . . . : Enabled
    Connection-specific DNS Suffix Search List : lan

Ethernet adapter VirtualBox Host-Only Network:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VirtualBox Host-Only Ethernet Adapter
   Physical Address. . . . . . . . . : 0A-00-27-00-00-00
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::188d:7f90:23b9:9918%436(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.56.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : -1190526937
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1C-59-DE-57-00-19-99-C1-C9-49
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1

My first thought was the problem could be related to Teredo (I had the Teredo adapters before I took that ipconfig /all), so I disabled it with

netsh int ipv6 isatap set state disabled
netsh int ipv6 6to4 set state disabled
netsh interface teredo set state disable

which got rid of the Teredo stuff, but the problem persists.

This is only happening to me, no other computers on the network (Win8.1, Win10) have the same issue.

0

EDIT: you can force ping to use IPv4 by using the -4 parameter, or IPv6 by using the -6 parameter

Example:

C:\Users\User>ping www.google.com -4

Pinging www.google.com [74.125.136.99] with 32 bytes of data:
Reply from 74.125.136.99: bytes=32 time=12ms TTL=48
Reply from 74.125.136.99: bytes=32 time=11ms TTL=48
Reply from 74.125.136.99: bytes=32 time=12ms TTL=48
Reply from 74.125.136.99: bytes=32 time=11ms TTL=48

Try disabling IPv6 in the windows GUI.

  1. Go to control panel
  2. Go to Network and Internet
  3. Go to Network and sharing Center
  4. Select the network adapter enter image description here

  5. Go to the properties of the network adapter

enter image description here

  1. Disable IPv6 by unchecking the option

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.