1

I want to use Docker on my Linux server for which I need to upgrade the kernel to 3.10 or higher. So following this answer I was trying sudo apt-get install linux-generic-lts-trusty, which results in:

dpkg: dependency problems prevent configuration of linux-generic-lts-trusty: linux-generic-lts-trusty depends on linux-generic; however: Package linux-generic is not configured yet.

dpkg: error processing package linux-generic-lts-trusty (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: linux-image-3.13.0-67-generic linux-image-extra-3.13.0-67-generic linux-image-generic linux-generic linux-generic-lts-trusty E: Sub-process /usr/bin/dpkg returned an error code (1)

So I tried installing linux-generic with apt-get install linux-generic, but that results in the same error message. I tried searching for the error message Package linux-generic is not configured yet, and tried some suggestions but nothing works.

I checked out my linux images:

$ dpkg -l | grep linux-image
iF  linux-image-3.13.0-67-generic        3.13.0-67.110           amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
iU  linux-image-extra-3.13.0-67-generic  3.13.0-67.110           amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
iU  linux-image-generic                  3.13.0.67.73            amd64        Generic Linux kernel image

So I do seem to have linux-image-generic. I wouldn't know what could be wrong with it though.

Does anybody know what I can do to upgrade my kernel to >= 3.10? All tips are welcome!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.