1

I am trying to install ISPConfig on Debian Jessie. I was following this tut https://www.howtoforge.com/tutorial/perfect-server-debian-8-jessie-apache-bind-dovecot-ispconfig-3/3/

I can install everything alright, but when I access https://ip:8080/ I get the default apache page. Why is this happening?

In my /var/www/ folder there is an html/ folder, as well as an ispconfig/ folder, and I tried moving ispconfig into html but when I try to access it the php is not run. And no, short tags are not the problem.

I tried a2dissite 000-default and then service apache2 restart but all stays the same.

Maybe I have to make some configuration that enables me to run different websites on different ports? In /etc/apache2/sites-available/ there is:

  • 000-default.conf
  • apps.vhost
  • default-ssl.conf ispconfig.conf
  • ispconfig.vhost

I am not really sure what to do. I don't have much experience with apache

What are you trying to do?

I am trying to get ISPConfig to run when I access https://ip:8080.

1

The Basics

It seems like a virtual host entry would possibly solve this issue.

Under the following directory:

/etc/apache2/sites-available

copy & rename 000-default.conf, keeping the .conf extension e.g.

 # cp 000-default.conf virtual.isp3.conf .

Edit your new .conf file and make it look something like this (note particularly the :8080):

<VirtualHost *:8080>

ServerName example.tld
ServerAlias www.example.tld *.example.tld
DocumentRoot /path/to/isp3/

</VirtualHost>

This should set all requests to that server on port 8080 to pull from /path/to/isp3/

Note that you don't have to delete any lines, just uncomment them.

Once edited, save the .conf and enable it with a2ensite e.g.

# a2ensite virtual.isp3.conf

Then restart Apache

# service apache2 restart


Caveats

  • If ISP3 is still failing, try a regular html page first to test the virtual host configuration (i.e. set DocumentRoot to access this custom plain page).

  • You may need to add or configure addition options for SSL access.

  • Likewise, if the plain page works, but a .php based page doesn't, you may need to take additional steps to make sure the server can parse .php files.

| improve this answer | |
  • I was a bit confused before as to what I was supposed to do exactly but I have now figured out. I just want the ispconfig folder to run under /var/www/html, but the php is not working. I have already commented out the lines I was supposed to comment, but still doesnt work – Mark Read Nov 7 '15 at 14:38
1

Had a similar problem, ispconfig url was showing apache default page, it was fixed by:

yum install mod_fcgid
service httpd restart
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.