I am in big trouble.

After searching over internet, I realised that my PCI Driver not installing because of Virus Probably.

Computer managment screenshot

But I can see that system is detecting device

Devices screenshot

And In Disk management, I can see following

Disk management screenshot

Can anyone suggest a solution?

  • 1
    I'd recommend you to try using a different USB cable with your external HDD, @KuKu Have you tried the external in another computer as well? The next important step is to download your external HDD manufacturer's diagnostic tool and test the drive. It will help you determine the health and SMART status of the drive, and show if there are any bad sectors you should be concerned about. I'd NOT recommend you to attempt initializing it, though, as it would erase your data. If you've got important files on it, I'd use third-party recovery software, see if it will help you. Keep us posted! :) Nov 11, 2015 at 14:00
  • @SuperSoph_WD Thanks for your reply on this. I have already done following things 1. Used another Cable 2. Used Different Machine 3. Downloaded Seagate Tool but computer do not show partition/hard drive, that tool is useless. 4. Downloaded 3rd party tool called DLL Fixer but its paid one, and I don't know event after that it will work or not! So... Kind of critical situation for me now! :(
    – KuKu
    Nov 12, 2015 at 6:36
  • This utility most definitely won't help at all with your external HDD. What you need to do is download a third-party HDD diagnostic utility to check the SMART attributes of the drive. I'd also recommend you to try plugging the external in another computer and see if it will get properly detected there. Give the tools that @journeyman suggested a try and see they will help you access the files. Keep us updated! :) Nov 12, 2015 at 13:08
  • What is your computer model, and have you run antivirus scans and with what product?
    – harrymc
    Nov 12, 2015 at 20:17

1 Answer 1


A seagate expansion drive is USB, and has nothing to do with PCI. Issues are entirely unrelated.

It looks like file system corruption, and the PCI driver thing is likely not related.

Boot into a linux live cd/usb and see if the drive is detected there. If so, force it to mount, copy out data, reformat, and copy it back in.

Else well, you could try something like testdisk and see if you can recover the drive.

At this point, you're going to have to break out the big complex tools like scapel, and practically would need to do a professional grade recovery job. Lots of time, careful poking around and such is going to be needed.

  • Thanks for the answer. As you said "A seagate expansion drive is USB, and has nothing to do with PCI. Issues are entirely unrelated." but as soon as it connect disk to the windows 7 desktop, I can see device installing popup. In that popup, it shows PCI Driver not installed. Coming back to the other OS idea, Yes, You are right, I need to try with another OS. :) Didn't came in my mind.. I will do and soon will update you on this.
    – KuKu
    Nov 12, 2015 at 7:39
  • @KuKu - The "missing" PCI Driver which isn't actually missing is not the reason your drive cannot be mounted. We are not going to be able to help you before your bounty expires if you don't tell us how the drive behaved on the other PC.
    – Ramhound
    Nov 17, 2015 at 16:52
  • @Ramhound I have installed Ubuntu and I attached HD to it. HD got detected after 20 mins. but after that it didnt worked. Like I can not see any files on it. This is the only latest update I do have.
    – KuKu
    Nov 19, 2015 at 6:50
  • Your file system may have issues then, or possibly the enclosure. Tricky tricky. Tried testdisk as per the instructions?
    – Journeyman Geek
    Nov 19, 2015 at 7:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .