0

When I click on the WiFi symbol of my taskbar, I see the various WiFi of my neighbors.

I would like my computer to NOT piggyback on those non-trusted computers.

So I click on each entry and uncheck the Connect automatically flag.

Only when I close that popup and reopen it, all of the Connect automatically flags are all checked again, as if I had done nothing earlier.

So I suppose that's the correct behavior, but then I still am wondering whether there would be a way for me to prevent connections from any of those hubs and only have my WiFi connect.

1

Have you every connected to your neighbors' WiFi routers? The "connect automatically" option is something you set the first time you connect to a new wireless network.

If you have never connected to those networks, trying to set/unset that option is futile.

If you have connected to those networks before, you should go to "Manage Wi-Fi Settings", and, under the "Manage known networks" heading, click on each, one-by-one, and click the "Forget" button that appears.

Then, don't connect again to their networks.

You might also want to disable Wi-Fi sense, specifically the "connect to networks shared by my contacts" if your neighbors are in your Outlook.com contacts list.

In addition, you might want to change your Wi-Fi network name to a new one with the suffix _optout_nomap.

Here, the _optout tells Microsoft you do not want this network to be included in Wi-Fi sense (so, if a friend comes over, you give her the password, she is not able to share access to your network to her contacts on her Microsoft account). See "How do I opt my Wi‑Fi network out of Wi‑Fi Sense?" in "Wi‑Fi Sense FAQ".

The _nomap tells Google you do not want this Wi-Fi network to be mapped. See "How do I opt out" in "Configure access points with Google Location Service".

AFAIK, Google demands _nomap to be a suffix, and Microsoft is OK with the _optout appearing anywhere in the name.

Of course, prefix the SSID with a name of your choosing to distinguish it. E.g. Franz_optout_nomap.

4
  • So the OS is stupid to show you that flag when it cannot save it... Good to know. Thank you for the optout and nomap flags. I will have to look into adding those to the SSID I currently have. Also my SSID is private, but that would probably not mean that it couldn't automatically be shared... – Alexis Wilke Nov 7 '15 at 22:35
  • Hiding the SSD is actually a hole in your security: "because a station must probe for a hidden SSID, a fake access point can offer a connection." en.wikipedia.org/wiki/Network_cloaking Instead, use an SSID that is not associated with your identity, and configure WPA2. – Sinan Ünür Nov 8 '15 at 0:27
  • 1
    Regarding the checkbox, the UI maybe confusing, but it is part of the "Connect" dialog. So, you can uncheck the box and connect, and it won't reconnect automatically the next time. Leave the box checked, and connect, and it will. But, the OS does not save information about WiFi networks to which you have not connected. It will just list all networks nearby. If the OS saved information about every wireless network it saw, things could get crowded in a hurry. In a sense, you can think of not connecting a network as if you pressed cancel in a configuration dialog. – Sinan Ünür Nov 8 '15 at 0:30
  • 1
    Hiding the SSID is a requirement when you deal with credit card (as a business). The technical side of it is irrelevant in itself and yes, I also use WPA2 and also filter with MAC addresses. Also I do not give those computers access to my main box which just forwards the network traffic (i.e. works as a safe proxy, much safer than just the router from my ISP.) – Alexis Wilke Nov 8 '15 at 3:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.