0

I'm using Window Movie Maker to import DV footage from a mini DV camera, since the fire-wire card only works on windows.

I want to use the files on Linux. Unfortunately, they appear to not be compatible with Linux video players? They play fine on windows Media Player. Audio plays fine, but video is blank during playback. When you pause the video, the current frame does show up, so the video is there, it just doesn't show the video while its playing.

The file command shows:

MyVideo.avi: RIFF (little-endian) data, AVI, 0 x 0, ~30 fps,

So does it think the dimensions are 0x0?

I've tried a bunch of different option s with mencoder and ffmpeg, but I don't know the right settings to use to make it fix whatever it is that causes a blank video when playing.

UPDATE: It seems that the black video during playback only occurs when attempting to seek. If I play it from the beginning and don't pause or fast forward, the video plays fine.

UPDATE 2:

So I tried rebuilding the index with:

mencoder -idx In.avi -ovc copy -oac copy -o Out.avi

And it does fix the Index, but the 10 minute video becomes an hour and 10 minutes long and plays in slow motion with no audio track. But indexing works!

The output of the command was:

MEncoder 1.1-4.8 (C) 2000-2012 MPlayer Team
success: format: 0  data: 0x0 - 0x68e1ba00
libavformat version 54.20.4 (external)
Mismatching header version 54.20.3
AVI file format detected.
AVI: ODML: Building ODML index (1 superindexchunks).
AVI_NI: No video stream found.
libavformat file format detected.
[lavf] stream 0: video (dvvideo), -vid 0
[lavf] stream 1: audio (pcm_s16le), -aid 0
VIDEO:  [dvsd]  720x480  0bpp   -nan fps  28771.2 kbps (3512.1 kbyte/s)
[V] filefmt:35  fourcc:0x64737664  size:720x480  fps: -nan  ftime:=  -nan
videocodec: framecopy (720x480 0bpp fourcc=64737664)
audiocodec: framecopy (format=1 chans=2 rate=48000 bits=16 B/s=192000 sample-0)
Pos:  -nans   4095f (28%)  0.00fps Trem:   0min   0mb  A-V: -nan [0:0]

Too many audio packets in the buffer: (4096 in 26236780 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
Pos:  -nans   4096f (28%)  0.00fps Trem:   0min   0mb  A-V: -nan [0:0]

Too many audio packets in the buffer: (4096 in 26236780 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
Writing header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
Writing header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
Writing index...
Writing header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.

Video stream:     -nan kbit/s  (-2147483648 B/s)  size: 491520000 bytes   -nan secs  4096 frames

Audio stream:     -nan kbit/s  (-2147483648 B/s)  size: 0 bytes  0.000 secs
  • Have you tried VLC? Does it plays them? – Cornelius Nov 7 '15 at 16:53
  • I've added an update above. It seems the video plays fine as long as I play it from the beginning and don't jump to a part of the video. When I try to seek to a certain part, rewind, etc, that's when the video goes blank and only the audio plays. – Nick Nov 7 '15 at 16:58
  • Have you tried transcoding using Avidemux? – Cornelius Nov 7 '15 at 17:59
  • Just tried it, Avidemux won't open the avi files. – Nick Nov 8 '15 at 8:36
  • Please provide a short sample input file. – llogan Nov 15 '15 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.