How can I create multiple Google Chrome desktop shortcuts, each leading to a different account?
(All accounts are signed in).

  • 2
    Can you please unaccept the accepted answer? It's incorrect and confusing. Apr 2, 2020 at 13:15
  • LOL, guess it's never too late. Thanks! :) Sep 10, 2021 at 14:02

10 Answers 10


Update (credit to @bdoserror)

  1. Go to Chrome settings (Click 3 dot stack in upper right, then Settings). Click Chrome name and picture Chrome name and picture
  2. Turn on Show desktop shortcut
  3. Toggle Show desktop shortcut off.
  4. Wait until the shortcut disappears from your desktop. Show desktop shortcut
  5. Turn Show desktop shortcut back on. Observe the new shortcut is created on your desktop..

Edit 2020-May-15: This no longer works.

The profile system has been updated sometime before Chrome version 75. In these versions, first activate the profile for which you want to make a shortcut. Then go to:

  1. Settings
  2. Chrome name and picture
  3. turn on Show desktop shortcut

Return to your desktop view, and see the new profile activation icon.

  • 5
    This no longer works in May 2020 (Version 81.0.4044.129 (Official Build) (64-bit))
    – Batman0730
    May 5, 2020 at 15:55
  • 2
    This worked for me (Chrome 83.0.4103.97, June 6, 2020) Jun 6, 2020 at 5:39
  • 2
    It looks like "Chrome name and picture" has been renamed to "Customize your Chrome profile".
    – hypehuman
    Apr 30, 2021 at 7:48

A picture is worth thousand words, here it is in Chrome 80:

enter image description here enter image description here

  • 2
    Looks like this option is gone now. My version: Version 81.0.4044.129 (Official Build) (64-bit)
    – Batman0730
    May 5, 2020 at 15:55
  • 2
    What the F...! They are removing it and making it reappear at different locations, then they finally kill it completely? What is wrong with them?!
    – Daniel F
    May 12, 2020 at 21:44
  • It works for me in Chrome 86. Nov 16, 2020 at 8:01
  • On Chrome, go to settings.
  • Scroll to the user list (people), and click on the user profile you'd like a shortcut for*.
  • Edit button will light up (after selecting a user).
  • Click on that edit button.
  • Click on Add desktop shortcut, then click on save.

A shortcut to that user's Chrome should now display on your desktop.

*Note: you will need to manually switch (sign-in) to each account, so that it is the (current) account in the user list (people) in order to be able to click on edit, and edit that account.
*Note: you will need to sign in with at least two accounts in order to see the "Add shortcut" option.
-To add one manually (why? But it's your choice): tech-recipes.com

  • 1
    Does it make sense I need to actually switch to each account to create the corresponding shortcut? Nov 9, 2015 at 16:53
  • Yes, that's correct. I forgot to mention it. Nov 10, 2015 at 0:11
  • Is it the most recent version of Chrome? Check for updates by going with Chrome to chrome://chrome/ Nov 11, 2015 at 1:05
  • Your answer helped me in conjunction with these other answers: superuser.com/a/908108/74576 and superuser.com/a/377195/74576
    – Ryan
    Dec 30, 2016 at 3:55
  • 14
    This is not valid any longer, refer to the answer for Chrome version 75+ for the current way to achieve it. Dec 27, 2019 at 12:48

Chrome change setting by an update that's why I noticed the accepted answer is not working. @Shimmy Weitzhandler has given step which is working but I want to add more information.

You can manage shortcuts and pictures by following two ways.

1) The easiest way, And I know it's favorite of most of us(I am also in same team).

  • Just click on a picture of your user. Refer to this image and you will find a way to change :)

2) But if `someone wants to dig deeper then follow way.


You can also do it manually, like so:

"C:\Program Files\Google\Chrome\Application\chrome.exe" --profile-directory="Default"
"C:\Program Files\Google\Chrome\Application\chrome.exe" --profile-directory="Profile1"

Where "Default", "Profile1", "Profile2" etc are folders in

"C:\Users\%username%\AppData\Local\Google\Chrome\User Data"

This is for Linux, this came specifically from my Debian 10, and works flawlessly. This only works AFTER you create or login in to each of the Google accounts, using Chrome to add other people, click on Icon upper left, left of the 3 vertical dots or hamburger, says other people +Add. Of course need to keep track of the accounts, first will always be "Default" all other logged in accounts will be Profile 1, Profile 2 and so on. Just put Chrome on desktop via Application Launcher then open with Kate to edit the file and save it as .desktop file add your specific data to the All CAPS that are in the code below save with a new name for each of your profiles, I expect this works with many Debian and Ubuntu distros. One note when you enter the Profile number ensure there is a space and is inside of quotes, as Profile 1 and NOT Profile1 this code below does not need much editing

#!/usr/bin/env xdg-open
[Desktop Entry]
# Only KDE 4 seems to use GenericName, so we reuse the KDE strings.
# From Ubuntu’s language-pack-kde-XX-base packages, version 9.04-20090413.
GenericName=Web Browser
Exec=/usr/bin/google-chrome-stable –profile-directory=”Profile 3″

Icon=/home/USERHERE/Pictures/DeskTop Icons/FILENAME.XXX

[Desktop Action new-window]
Name=New Window
Exec=Exec=/usr/bin/google-chrome-stable –profile-directory=”Profile 3″

[Desktop Action new-private-window]
Name=New Incognito Window
Exec=/usr/bin/google-chrome-stable –profile-directory=”Profile 3″ –incognito

As of Chrome 88, this works (an update of the answer by @ndemarco).

Go to Chrome settings (Click on 3 dots in upper right, then click on "Settings").

Then click on "Chrome name and picture" Chrome Settings

Then toggle the "Show desktop shortcut" switch off and wait for the shortcut to disappear from your desktop. Then turn it back on and you should get the new shortcut. Show desktop shortcut


The following is a stupid workaround which works in Chrome 81.x on Windows. It may work on other platforms as well.

Go into Profile A. Open the page what will be your startpage. This cannot be an empty tab, it has to be an URL. Press the three-dot-menu and in "More Tools..." select "Create Shortcut" (sorry, my Chrome is in German, but I guess that's what it would be in English).

Go into Profile B. Repeat the same you did for Profile A.

Now you have two shortcuts which will open the Browser with the corresponding profile.

But this will mess with the "open these webpages on startup" because it will additionally open the preconfigured website.

In order to fix that, edit the shortcut and remove the entire "--app-id=..." substring, the important thing is to keep the "--profile=..." substring.

Why don't they just add a "Create Desktop shortcut for this Profile" popup-menu when one right-clicks the profile icon in the top right? How do Googlers do it? Or have they stopped having the need for it and thus thought nobody else will need it?


As of version 95.0.4638.69, this is what worked for me

Couple of things to put in perspective:

  • My current situation is that I had 2 Google Chrome icons in my Windows taskbar. 1 that was the standard Chrome icon, one which had 1 of my user account profile picture attached to it.

  • Clicking on the one without a profile picture opened a new window with a choice to pick a user. The other (with profile pic) went to that specific user in the picture but was created by default when I created a shortcut and any attempt while in a different user to create a new shortcut for that specific user didn't work

This is how I fixed that (Windows):

  • Open Chrome from a non-user specific chrome link (like, from the desktop or taskbar) or create a new shortcut of Google Chrome
  • Start chrome from it
  • Click on the profile picture in the upper right corner of the browser, go to "Other Profiles" and choose the user for which you wish create a direct "Google Chrome desktop shortcuts" for
  • On the left TOC, click "You and Google"
  • Click on "Customize your Chrome profile"
  • Scroll down to "Create desktop shortcut"
  • Here's where it get insteresting, mine was already turned on. Turn it off and on again. You will see user profile pop on the chrome browser icon.

If you already have your Profile created.

Chrome Version 96.0.4664.45 (Official Build) (64-bit) Windows 10

Click the 3 dots in right hand top corner next to profile icon scroll in the drop down list box to settings and click settings.

In "You and Google" (Default page)

Select "Customise your Chrome profile" once in customise profile.

Scroll down to Create desktop shortcut and toggle the switch


Not the answer you're looking for? Browse other questions tagged or ask your own question.