36

I'm trying to delete Xcode from my MacBook, so I could download the latest version (updating it in the app store just gives me that spinning circle, which has been going on for three days).

However, whenever I drag it into the trash, nothing happens. When I'm deleting it from the applications folder, it says the following:

The item “Xcode” can’t be moved to the Trash because some of its extensions are in use.

One of the suggestions online is to use Activity Monitor to find out any open instances of the app. Well, unless Xcode's extensions are named differently, I didn't see anything that even starts with X in there.

Can anyone help me out pls?

Additional Details:
I'm on El Capitan, attempting to update my Xcode from 6.something to the newer version 7, before this happened.

75

Fixed it by doing the following

1. Control-click on Xcode  
2. Select 'show package contents'  
3. Open folder  
4. Delete plugins folder  
5. Open finder window  
6. Navigate to folder containing Xcode app  
7. Press command-delete and move to bin  
4
  • 1
    It worked! Weird! Delete a subfolder to delete parent! how does it work? – Necktwi Jan 23 '18 at 4:15
  • It is because XCode plug-ins are in use. @neckTwi. – Lal Krishna May 31 '18 at 13:54
  • Great job with the error message, Apple – syonip Apr 13 '19 at 14:58
  • This worked for me, thanks! – auspicious99 Jan 24 at 9:24
15

This worked for me:

 1. Open Activity Monitor 
 2. Search for XCode 
 3. Force quit all running instances of XCode
 4. Try again to move XCode to Trash
0
4

The problem for me was that I had the new version of Xcode running. The solution was to close Xcode and then I could delete the beta app file.

1
  • Xamarin (Visual Studio) users maybe also close Visual Studio, and might have to restart mac to be sure no plug-ins are still running. – ToolmakerSteve Nov 12 '19 at 11:21
2

I had Xcode and the simulator running on another user profile. Closing these windows fixed the problem for me.

1. Log in to your other user profiles which share Xcode
2. Quit any running instance
3. Attempt to delete it 
1

I had an old version of Xcode (10.2) that I kept around in case 10.3 didn't work out. It did work out just fine and I forgot about my renamed instance for a month or so. I saw it sitting in my Applications folder and decided to clean up. It gave me the above message about having extensions in use. Interestingly, the fix was to shut down the NEW instance of Xcode. In other words, the error isn't saying that the Xcode you're trying to delete has extensions in use. It's just saying AN instance of Xcode is in use, so you can't throw any others away. So clear the decks before cleaning out your stable of Xcode versions.

1
0

Restarting the machine did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.