1

I have a server app running on my windows 7 laptop and I have a client app running on my Android phone.

Both, laptop and phone when connected to my work WIFI can communicate. I can log it into my client and fetch data from server.

However, on my home WIFI, I cannot do that.

I did some research and found an article suggesting to use Wireless Network Connection Properties, Sharing tab to enable Internet connection sharing but that option has been disabled on my machine, so I am looking for another way, if there is any.

Some have suggested to go to my home WiFi router settings and do port forwarding. I did some research on that and found that it is used if you want to allow access from a connection from outside your home network to a device on your home network. So, that doesn't apply to me as both of my devices are on my home WIFI.

Another recommendation was to go to my router settings and disable firewall. But that does not sound like a good idea to me.

Can anyone provide some nice article or instructions with explanations how to do it one or the other way ?

Thanks.

5
  • Check for WiFi isolation options on the router, if you find it, disable it. Also, if you're using your external/WAN IP from inside the LAN to try and contact the server on your LAN, that probably won't work on your home-level router -- use the LAN IP. Nov 8, 2015 at 16:33
  • I'll check the router for 'isolation option' but to other points, both device and laptiop are connected to my home WIFI and I am using my private IPs (ips within the home network), not the public ISP provided IP. Thanks
    – dbnex14
    Nov 8, 2015 at 22:16
  • No 'isolation option' in my router settings
    – dbnex14
    Nov 8, 2015 at 22:26
  • If ICS is disabled, is this a work provided laptop?
    – Linef4ult
    Nov 9, 2015 at 12:24
  • yes, that is why I am wondering if there is other way to make it work only within my home network. My IT guy said to disable router firewall but that just does not sound right to me.
    – dbnex14
    Nov 9, 2015 at 17:10

1 Answer 1

0

Amazing, no answer to this question. Anyways, I found it. I went to my Windows Firewall -> Advanced Settings and added incoming rule as: Protocol Type: TCP Local Port: my port # Everything else was left as default , and that worked. Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.