0

I am having a strange problem using vncserver on Fedora 23. I did a new fresh install of Fedora 23 on my laptop, installed tigervnc-server and tigervnc, started it and got the "Oh, no!...." message when vncviewer displayed the desktop. I thought it was a bad install, but the problem happens with Fedora 23 Live and I tried it on multiple systems. The only errors I see are on the screen "Oops, gnome-shell seems to have crashed" and in journalctl I see an error that gnome-shell has restarted too many times.

This is easy to reproduce:

  1. Boot Fedora 23 Live
  2. dnf --assumeyes install tigervnc-server tigervnc
  3. vncserver :10
  4. vncviewer :10

I don't really know where to go from here. Any help would be appreciated.

3
  • I doesn't crash my gnome-shell in Fedora 23, but it is rather unstable. Never used this before, just got curious while reading your post. Sorry I can't help that much. – skytux Nov 22 '15 at 20:05
  • Thanks for replying,@skytux. I have been regularly updating with dnf and the problem has gotten a little better. Just updated tigervnc this morning and I now have an actual working vncserver on my laptop. I need it to run on my main workstation though, and I still get the "Oh No" message there. /var/log/gdm directory is empty. Thanks again for replying, at least I know now that I am not the only one. – John W Nov 23 '15 at 21:08
  • I'll have to agree with skytux here...VERY unstable, but not crashing my system. I have never used vnc to open another desktop of the machine i'm working on, always remote machines. This does run for me, and when I launched Chrome from the vnc session, it popped up in my native session. terminal opens correctly...and does show chrome running under that login. WHO in each terminal shows one login on the same tty..I think Fedora is treating the VNC session as a workspace. – Rex Sheffield Nov 27 '15 at 19:34
0

I hate to answer my own question but the problem is resolved. I don't have any idea what caused or resolved the problem other that to say this:

dnf upgrade installed kernel 4.2.6, upgraded the gnome-extensions packages and did not upgrade tigervnc.

I rebooted and vncserver started with no errors.

So, for this particular issue, the fix is to make your packages current.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.