0

I'm on a clean Funtoo install and after setting up ALSA i've just tried to play some movies through VLC but it doesn't seem to be able to detect/choose the default output audio device. If i go to Audio -> Audio Device and there i choose the proper audio device then it seems to work fine. Does anyone knows how to fix this issue?

This is the emerged VLC version

VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42

When i call vlc from console i can see this output, i'm on KDE Plasma 5

[00000000012741f8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0000000001386528] qt4 interface error: Unable to load extensions module

These are the used USE flags to compile vlc

[ebuild   R    ] media-video/vlc-2.2.1-r1:0/5-8::gentoo  USE="X a52 alsa avcodec avformat bluray cdda cddb dbus directfb dts dvbpsi dvd encode faad ffmpeg flac fontconfig gcrypt ieee1394 jpeg libass libsamplerate live matroska mp3 mpeg mtp ncurses ogg opengl png postproc qt5 run-as-root samba sdl svg swscale taglib theora truetype twolame udev upnp v4l vorbis vpx x264 x265 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -bidi -chromaprint -dc1394 -debug (-directx) -dvb (-dxva2) -fdk -fluidsynth -gme -gnome -gnutls -growl -httpd -jack -kate -kde (-libav) -libcaca -libnotify -libtar -libtiger -linsys -lirc -lua (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-media-library) -modplug -musepack (-neon) -omxil -opencv -optimisememory -opus -projectm -pulseaudio -qt4 (-rdp) -rtsp -schroedinger -sdl-image -sftp -shout -sid -skins -speex {-test} -tremor -vaapi -vcdx -vdpau -vlm -vnc -wma-fixed -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse" 20,450 KiB

Running

speaker-test -t wav -c 2
from console through my user on the system works fine.

aplay -l and aplay -L output

PauPC ~ # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC1200 Analog [ALC1200 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC1200 Digital [ALC1200 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

PauPC ~ # aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=Intel
    HDA Intel, ALC1200 Analog
    Default Audio Device
sysdefault:CARD=Intel
    HDA Intel, ALC1200 Analog
    Default Audio Device
front:CARD=Intel,DEV=0
    HDA Intel, ALC1200 Analog
    Front speakers
surround21:CARD=Intel,DEV=0
    HDA Intel, ALC1200 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, ALC1200 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, ALC1200 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
    HDA Intel, ALC1200 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
    HDA Intel, ALC1200 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, ALC1200 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
    HDA Intel, ALC1200 Digital
    IEC958 (S/PDIF) Digital Audio Output

This is my alsa.conf

cat /etc/modprobe.d/alsa.conf 
# Alsa kernel modules' configuration file.

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-card-0

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1
options snd-hda-intel id=Intel index=0

This is an unneeded ~/.asoundrc i've created just in case

$ cat .asoundrc 
defaults.pcm.!card Intel
defaults.pcm.!device 0
defaults.pcm.!ctl Intel

pcm.hda-intel {
        type hw
        card 0
        device 0
}

ctl.hda-intel {
        type hw
        card 0
        device 0
}

My motherboard is an Asus P6T and this lspci |grep -i audio output

 lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

cat /sys/class/sound/card*/id
Intel

Hope someone can help me to fix this annoying issue.

Thx!

0

Compiling VLC media player 2.2.2 Weatherwax (revision 2.2.1-282-g863a425) solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.