0

Every once in a while the time gets out of whack on my MBP 2014 running Yosemite. Just right now I noticed it was roughly half an hour slower. I fixed it by going to the Settings->Time Zone, unlocked the changes and it synchronized the time properly.

Last night it was running on battery, I also ran Windows 7 in a Parallels VM. I closed the lid (I didn't power it down), went to bed, opened it this morning, I connected it to a power source, I surfed a little bit, went outside, came back and I noticed the time difference.

Any ideas? Could it be because it was running on battery, then I closed the lid without powering it down? The time difference was big. I am going to keep an eye on it from now on.

Thanks

  • Have you tried resetting the SMC and NVRAM? – At0mic Nov 8 '15 at 23:14
  • I didn't. I managed to get the time right by unlocking the changes in the Date & Time settings section, and then just clearing and selecting again the checkbox on the Time Zone tab and it got its brains back. – costa Nov 9 '15 at 4:50
0

Have you set it to sync to an external time server?

Go to System Preferences --> Date and Time and check the "Set date and time automatically". By default it should be set to one of Apples Server, however you can try to use the pool.ntp.org time server. Have a look here and find a time server that is geographically closest to you.

http://www.pool.ntp.org/en/

Then reboot your mac and see if you find a time difference.

|improve this answer|||||
  • Yes, it is set to sync automatically on the Date & Time tab, and also on the Time Zone tab, set time zone automatically using current location. That's the puzzling thing. – costa Nov 9 '15 at 4:49
  • I will take a look tomorrow morning to see if there is any difference (will power it off tonight) . – costa Nov 9 '15 at 4:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.