4

I have download FileZilla server and I am trying to create a server using the FileZilla software. I have used a new port add a user and from the FileZilla client I tried to enter to the server. Everything worked fine. However when I closed the FileZilla server and tried to reopen again I got the following:

Connecting to server 127.0.0.1:port... Connected, waiting for authentication Protocol error: Unknown protocol identifier (0x50 0x50 0x48). Most likely connected to the wrong port. Connection to server closed.

What is that issue? Now I cant use any option of FileZilla sotware from menu. Every option is marked on gray (unavailable) and I am receiving constantly this message.

EDIT: with the suggested answer from @Martin Prikryl I am receiving from the server interface the following:

Connected, waiting for authentication Logged on Warning: FTP over TLS is not enabled, users cannot securely log in.

and from the client:

Status: Connecting to 127.0.0.1:12321... Status: Connection established, waiting for welcome message... Response: FZS Response: S
Response: D Error: Connection timed out after 20 seconds of inactivity Error: Could not connect to server

  • How did you "close the filezilla server"? Where you got the error? In the FileZilla client? Or FileZilla server interface? – Martin Prikryl Nov 9 '15 at 13:38
  • I terminate the service. The error is is the server interface. – Jose Ramon Nov 9 '15 at 14:06
  • In the management console? And you restarted the service there too? – Martin Prikryl Nov 9 '15 at 14:26
  • What port did you change? The FTP port or the admin interface port? – Martin Prikryl Nov 9 '15 at 14:26
  • Yes. After that I cant use the interface except the first pop up window in which you add the port. – Jose Ramon Nov 9 '15 at 14:27
2

It looks like there's another service running on the same port. Or (as it turned out), you have configured FileZilla server with the same port number for both FTP port and admin interface port. So the FileZilla service conflicts with itself.

Try to change the admin interface port to a yet another one (or back to the standard one, the 14147).

You can change it manually in
C:\Program Files (x86)\FileZilla Server\FileZilla Server.xml (64-bit path).

<FileZillaServer>
    <Settings>
        ...
        <Item name="Admin port" type="numeric">14147</Item>
        ...
    </Settings>
</FileZillaServer>

You should stop the service before changing the XML file and re-start afterwards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.