1

Every time I try to install a printer on this one PC, the Spooler crashes and the installation fails. PC is brand new. Through troubleshooting, I found out that anytime I try to do anything with the printers, the spooler fails, like trying to delete drivers.

When the spooler crashes, this error is generated:

  • Faulting application name: spoolsv.exe, version: 6.3.9600.17480, time stamp: 0x54585db9
  • Faulting module name: hpb6sy2917_x64gui.dll, version: 13.2.0.0, time stamp: 0x5553b101
  • Exception code: 0xc0000005
  • Fault offset: 0x00000000000c2f2b
  • Faulting process id: 0x10e0
  • Faulting application start time: 0x01d11b2357d095b2
  • Faulting application path: C:\WINDOWS\System32\spoolsv.exe
  • Faulting module path: C:\WINDOWS\system32\spool\DRIVERS\x64\3\hpb6sy2917_x64gui.dll
  • Report Id: baaa4645-8716-11e5-be88-8cdcd453c6a8
  • Faulting package full name:
  • Faulting package-relative application ID:

Obviously, I have tried manually starting the service, and it does start, but as soon as I try anything, it crashes again.

“SFC /Scannow” found errors, but could not fix.

“dism /Online /Cleanup-Image /RestoreHealth” completed successfully.

I’m at my wits end, any help will be appreciated.

  • 1
    Crap HP printer drivers strike again. You're probably going to have to manually hunt and destroy references to the printer form the Registry, then uninstall the drivers, and then try newest ones from HP. – Ƭᴇcʜιᴇ007 Nov 10 '15 at 15:33
  • That worked. Purged all HP items and reboot. Everything worked great after all the HP stuff was yanked out. Thank you! – Ian Hawkins Nov 10 '15 at 20:19
2

We had a similar issue today Nov 23 2016- All Win 8 computers spoolers started failing after we distributed an HP M604 with its specific M604 driver. The M604 driver does not contain hpb6sy2917_x64gui.dll identified in the crash log, another printer on the systems does however - the HP M553. We resolved by redistributing both he M604 and M553 printers with UPD drivers (v 6.1). Also had to cleanup fallout in the form of orphaned 'grayed out' print objects - old object names that were no longer in the GPO had to be deleted in Device Manager/printers with SHOW HIDDEN ITEMS switched on.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.