0

EDIT: The issue was actually Virtual Box related - it was not related to Windows 10 or the program I was trying to install.

I have a machine running Linux Mint 17. On this machine, I have an activated version of Windows 10 running in Oracle VM VirtualBox.

I would like to install a program from a CD on Windows 10 that is running in VirtualBox.

When running the setup.exe, a popup appears:

This app can't run on your PC
To find a version for your PC, check with the software publisher.

Unfortunately, the vendor has not been helpful - stating only that "there have been no reported issues with installing the program on Windows 10".

I have tried running the setup.exe with administrator privileges and in all combinations of compatibility mode to no avail.

The installation CD has the following files:

Manual (folder)
Setup (folder)
Autorun (Setup information file)
CBase13 (Icon file)
Setup (Application file)

If I run the setup_x64 Windows Installer Package file inside the Setup directory, the following error appears:

This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package.

Is there anything more I can try to do to get this program to work on Windows 10 inside a virtual machine?

0

Turns out I did not select passthrough when adding the CD/DVD drive in the storage options.

The checkbox is located in my VM settings -> storage -> Host Drive DVD A (this will likely be different for different machine setups) -> Passthrough checkbox (tick this!)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.