1

Suddenly today - I can't really pinpoint when - my CPU has become locked at a low frequency, even under load. I hadn't changed any settings in Windows 8.1 or in the BIOS, and everything appeared to be set as it needed to be. This is a desktop, and the power settings are set to maximum performance.

You can see details:

here.

The standard speed on this processor is 3.2Ghz, but it is limited to 1.34. I tested using some demanding programs I have used within the past few days and confirmed that the CPU load, temperatures, and fan speeds did not increase significantly, and performance was significantly decreased.

I've tried the amd/intelppm.sys "fix", but this appears to be only a placebo. Windows Task Manager shows that the speed is at maximum, but the behavior is as before, and Open Hardware Monitor reflects the lowered clock speed. I have also tried disabling AMD Cool n Quiet and changing the clock speed in the BIOS, without success, though I haven't had any problems before. I checked on Linux Mint installed on another partition, and /proc/cpuinfo seemed to suggest that the normal ramping up behavior of the clock speed was working, however neither the fan speed nor the temperatures increased, so I suspect it was not "real."

Summary
    Operating System            
        Windows 8.1 Pro 64-bit
    CPU
        AMD FX-8320E    28 °C
        Vishera 32nm Technology
    RAM
        16.0GB Dual-Channel DDR3 @ 933MHz (13-11-11-29)
    Motherboard
        MSI 970 GAMING (MS-7693) (CPU 1)    34 °C
    Graphics
        24M45 (1920x1080@60Hz)
        2048MB ATI AMD Radeon R9 380 Series (MSI)   41 °C
    Storage
        931GB Seagate ST1000DM003-1ER162 (SATA) 41 °C
    Audio
        AMD High Definition Audio Device
17
  • And you did not change your energy scheme settings?
    – Run CMD
    Commented Nov 11, 2015 at 8:30
  • I changed no energy/power settings until I noticed the problem. It was at Balanced before, and was probably like that since installation. It's now at Maximum Performance.
    – kmantel
    Commented Nov 11, 2015 at 8:52
  • 2
    Windows resource monitor shows the "maximum frequency" at 100% when the cpu is "stepped" to the max. If the steps were slightly wrong in the bios, via the base clock , or divisor things, is one reason why the clock # would be low looking, with the "frequency" still at max. I would want to fire up CPU-Z program (in windows) because it is pretty reliable at seeing divisor and base and voltages and stuff you need to see..
    – Psycogeek
    Commented Nov 11, 2015 at 9:21
  • I can't attach these to the post due to reputation: i.imgur.com/HRNL9h0.png (CPU-Z) valid.x86.fr/dz6af2 (CPU-Z submitted results). I have the BIOS settings at defaults.
    – kmantel
    Commented Nov 11, 2015 at 9:33
  • 1
    You're right. It took me a bit to realize that the ambient temperature is above 30C. I also stumbled on [tomshardware.com/answers/id-1636508/… post) that states the culprit is AMD Smart Protection in the BIOS. I found that this was the case, and disabling it brought the computer back to its normal behavior. But, I assume the protection is there for good reason so I reenabled it. Maybe the temperature sensors are off, and it was running much hotter than I thought? I had intended to get a better CPU cooler at some point, so I guess now is the time.
    – kmantel
    Commented Nov 12, 2015 at 9:33

1 Answer 1

1

It's good that you found the solution to the strange behaviour over at Tom's Hardware: FX-6300 weird throttling.

According to that discussion and your observation, your BIOS's Smart Protection is not working correctly.

You have several options.

  • Adjust the Smart Protection settings in your BIOS if possible.

  • See whether resetting all BIOS settings and configuring them from scratch does any good.

  • Try to find another BIOS version for your mainboard which supports your CPU amd fixes the problem. (It could be more recent or older.)

  • Disable Smart Protection.

I see the last option as absolutely safe. Your FX-8320E is a Piledriver just like my A10-6700 and my analysis of the A10-6700 suggests that the chip throttles down by itself based on temperature even (Test Cases 1.2 and 2.2 in conjunction with other results).

You may want to fix the root cause, though, because you said it worked before.

5
  • Thanks for working through with me. I will look into other versions of the BIOS - the current does not allow any config for smart protection. I actually considered just leaving it off, but having a couple random shutdowns on that setting put me off until I can do some more research.
    – kmantel
    Commented Nov 12, 2015 at 10:31
  • After installing a better cooler, the throttling was gone for about two hours. Now it's back. No idea what's going on now. Edit: a few minutes later it's back unthrottled? I tried opening up something demanding during the time it seemed downclocked, but that didn't fix it. I'm not sure what I did this time.
    – kmantel
    Commented Nov 18, 2015 at 5:18
  • 1) Get yourself some software to monitor CPU temperature accurately. I recall there are some where you can correct for wrong values. You may have values shown in BIOS as reference. Let the SW protocol the temp and analyse it. 2) "Better cooler"? Boxed coolers are always good enough, although hard to stand. Are you mounting it properly?
    – Run CMD
    Commented Nov 18, 2015 at 7:19
  • I found one more monitor, but no others. This one at least showed me another temperature reading that I didn't see on OHWM and that reads significantly higher than my CPU. This picture shows what happens when I disable AMD Smart Protection to force the normal clocking. The max values are while running a somewhat demanding game. The "Value" column is after I opened up a side panel on my case and pointed a desk fan inside. I tried to create the same setup with AMDSP disabled, but now the CPU remains forever at the lower clock, despite temperatures of 23, 37, 39.
    – kmantel
    Commented Nov 18, 2015 at 9:10
  • I'm fairly sure the cooler is mounted properly. Regardless, the temperatures with it were about 20C cooler than with the stock cooler, using the same measuring software.
    – kmantel
    Commented Nov 18, 2015 at 9:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .