29

I can't register a hotkey with a program because "other programs are using it" In this case "Print Screen" and "Ctrl + Print Screen" and every other combination of Shift, Alt, Ctrl, + print-screen.

How can I tell what hotkeys are in use and what programs are using them?

I've seen similar questions:

And they suggest using a program called Hotkey Explorer but that program doens't run correctly on my system (Windows 10 Ent x64).. in fact here is a warning: DO NOT RUN THIS PROGRAM ON WINDOWS 10. What a nightmare.

Also I don't have Dropbox installed (other questions said it might use the print-screen buttons)

3
  • Can't you try to use the program with admin rights? Or use another program like AutoHotKey?
    – Tom
    Nov 11 '15 at 15:22
  • @Tom What program are you referring to? The one I'm trying to run? I do run it as an admin, it is Tech Smith's Snagit (techsmith.com/snagit.html) It says it can't map the key b/c it is already being used by another program
    – Aaron
    Nov 11 '15 at 15:36
  • Hotkey Explorer on Windows 10 only if you like Narrator turned on.
    – Sun
    Mar 4 at 0:17
12

Sorry I can't suggest an alternative to Hotkey Explorer for Windows 8 or 10. It's a godsend on Windows 7.

I can only offer you the most primitive way of handling this problem. First, close all your running programs (including stuff in the system tray), one by one. Make notice of what you close and every time (or every once in a while) test if your program (is it Greenshot?) can now use that hotkey.

If everything is closed but the problem persists, open the Processes tab in the Task Manager (or better yet, download the Sysinternals Process Explorer). Sort processes by user and start killing user (not system) processes one by one. Again, keep checking if the hotkey becomes available. Sooner or later you should find the offending process. In my case, CSRHarmonySkypePlugin.exe (part of CSR Harmony drivers for a CSR Bluetooth 4.0 USB dongle) was grabbing Ctrl+Alt+Up and Down and a few others - with no UI to configure that or turn off!

This kind of problem is extremely annoying. Happy hunting!

9
  • 1
    Thanks for following up after all this time, I ended up throwing out snagit as I couldn't figure it out but suspected it may have been related to an onedrive installation because i saw an option in it to "automatically save screenshots" but had no real hard evidence of that.
    – Aaron
    Oct 12 '16 at 15:51
  • Maybe it had this problem. I have OneDrive installed now (with this option disabled) and it doesn't cause any problem for Greenshot that I use to take screenshots. Oct 12 '16 at 19:30
  • Try not to use the tool: ActiveHotKeys to check if shortcuts are in-use. While killing every running application in an second run, I wasn't able to find the grabbing application. As I closed ActiveHotKey I was able to use CTRL+ALT+LEFT and CTRL+ALT+RIGHT and all other arrow directions. In the end CSRHarmonySkypePlugin.exe was grabbing, too. Now Jetbrains IDEA get's the key-strokes for Navigate Left or Navigate Right. May 28 '17 at 23:01
  • CTRL+SHIFT+B was blocked by TPFanControl. TPFanControl has an configuration file C:\Program Files\TPFanControl\TPFanControl.ini where the Hotkeys can be disabled. May 28 '17 at 23:32
  • On new Windows installations, OneDrive has been the culprit for me. It sometimes grabs the PrntScrn key even if the option @Gene Pavlovsky mentioned is turned off.
    – ifconfig
    Jul 4 '18 at 3:50
9

You can use the tool Spy++ that comes with Visual Studio: https://stackoverflow.com/a/43645062/62838. It will allow you to see what window and process are receiving the WM_HOTKEY window message. If the 32 bit version doesn't work, try the 64 bit version instead.

8

A small extension to Gene Pavlovsky's answer: in Sysinternals Process Explorer you can activate Views » Scroll to new processes

Sometimes, the assigned application will be highlighted as soon as you press the hotkey :-)

2
  • 1
    I didn't know about this option, thanks for that. If I understand it correctly, it scrolls to a newly launched process. If some application is already running and is intercepting some hotkey, pressing that hotkey generally isn't gonna create a new process, so how can it help? Sep 5 '18 at 14:29
  • not work! i was trying to find out which app took over my ctrl+d shortcut in excel.. and using this method was no use. However i solved the problem it was tinytake application. Any other method to find out which app uses my hotkey??
    – ihightower
    Jul 3 '19 at 5:51
2

I had the problem that with a Polish keyboard layout the key CTRL+ALT+A (or ALTGr+A) was not working. It should produce the polish letter ą.

I found this site: https://defkey.com/ which has a database for hotkeys. I found that my password manager, KeePass had grabbed that key combination.

Disabling the never used combination solved the issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.