I am clicking on an ad in Firefox and the browser keeps preventing the pop up from opening in a new tab. I believe that this is because the ad uses javascript:window.open() for the link.

I first added an exception for the website, but it continued to block the pop ups. Then, I turned off the pop up blocker off in preferences, but it still blocked them. I tried restarting the browser, but it turned the pop up blocker back on.

How can I turn the pop up blocker off?

I am using firefox 40.0.3 on Mint 17.

  • A couple of thoughts. Do you have more than one blocker (like adblock plus ghostery)? Are you getting a message saying it's being blocked or it just doesn't display? It could be a problem with java or javascript. Verify that you have the latest versions and that you haven't disabled it. – fixer1234 Nov 12 '15 at 5:58
  • I don't have any other ad blockers installed. I am getting a message saying that it is being blocked. – TheCaptan Nov 12 '15 at 16:33
  • There are blockers for things other than ads, like tracking cookies, which will block some content. Also, there are seperate settings for Firefox's internal pop-up blocking and add-on ad blockers. You may need to white-list or disable in several places. – fixer1234 Nov 12 '15 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.