2

Hello I was wondering if anyone could help with an issue on my Windows PC as to why I keep getting BSOD only during Torrent downloads in Windows 10. It always happens during the downloading of Torrents not the start of the program. I have swapped several torrent clients and still am able to reproduce the same issue, a BSOD with "Page Fault in Non Paged Area." Downloading large files via web browser or Skype were tested with no issues, however the BSOD often pops up downloading any torrent on any client and the file can be any size.

My Windows 10 Copy is genuine and I had recently done a fresh install in an attempt to eradicate any potential problems with no avail. The fresh windows 10 install also was installed on a brand new hard disk drive so it could not have been a HDD issue, I only replaced it because Crystal Disk had caution on the old drive (it is fine on the new drive). My RAM also isn't an issue as I have ran MemTest86 for approximately 5-6 hours and everything checked out fine. Therefore I am having trouble pinpointing the issues causing this. Previously my PC was on a Windows 8.1 version and the issue did not arise until after I upgraded to Windows 10. Thus I think thinking it could potentially be a driver issue which is causing this BSOD but I cannot pinpoint what. I have read many issues online regarding this BSOD which is why I have done several tests myself before comming onto here. I have messed around with paging options as suggested in other posts but it did not appear to solve the problem. As for antivirus software, I am currently using Norton Internet Security 2015, for the sake of testing I have also disabled it before resuming torrent download and reproduced the same BSOD. Please help!

Here is a minidump: http://www.filedropper.com/111215-34031-01

Anyone who can help is appreciated! Thank you!

Extra Info: ( Via Belarc Advisor)

* Windows 10 Professional (x64)
* Hewlett-Packard HP ENVY 15 Notebook PC E1P05AV
* Boot Mode: UEFI with successful Secure Boot
* 2.40 gigahertz Intel Core i7-4700MQ
* Board: Hewlett-Packard 1963 KBC Version 93.52
* 8126 Megabytes Usable Installed Memory
* HGST HTS721010A9E630 [Hard drive] (1000.20 GB) -- drive 0
* Intel(R) HD Graphics 4600 + NVIDIA GeForce GT 740M
* Norton AntiVirus Version 22.5.4.24 Norton Security
  • Most of the time you cannot simply "disable" security software and expect it to still not cause problems. I suggest using Autoruns and only loading the absolute minimum to boot your system. You can then perform your tests at that point. Is your system to configured to use a RAID and/or Intel's Rapid Storage currently? Be sure you install the Fall Update, it might solve some problems, due to the installation process. – Ramhound Nov 17 '15 at 14:06
4

I checked the dmp file with Windbg and it shows that the Intel storage driver iaStorAV.sys causes it:

*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Some common problems are exception code 0x80000003.  This means a hard
coded breakpoint or assertion was hit, but this system was booted
/NODEBUG.  This is not supposed to happen as developers should never have
hardcoded breakpoints in retail code, but ...
If this happens, make sure a debugger gets connected, and the
system is booted /DEBUG.  This will let us see why this breakpoint is
happening.
Arguments:
Arg1: ffffffffc0000005, The exception code that was not handled
Arg2: fffff801017b0a77, The address that the exception occurred at
Arg3: ffffd00072b27818, Exception Record Address
Arg4: ffffd00072b27030, Context Record Address

Debugging Details:
------------------


DUMP_CLASS: 1

DUMP_QUALIFIER: 400

BUILD_VERSION_STRING:  10240.16590.amd64fre.th1_st1.151104-1714

SYSTEM_MANUFACTURER:  Hewlett-Packard

SYSTEM_PRODUCT_NAME:  HP ENVY 15 Notebook PC

SYSTEM_SKU:  E1P05AV

SYSTEM_VERSION:  0982110000405E00000320000

BIOS_VENDOR:  Insyde

BIOS_VERSION:  F.65

BIOS_DATE:  11/20/2014

BASEBOARD_MANUFACTURER:  Hewlett-Packard

BASEBOARD_PRODUCT:  1963

BASEBOARD_VERSION:  KBC Version 93.52

DUMP_TYPE:  2

BUGCHECK_P1: ffffffffc0000005

BUGCHECK_P2: fffff801017b0a77

BUGCHECK_P3: ffffd00072b27818

BUGCHECK_P4: ffffd00072b27030

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - Die Anweisung in 0x%08lx verweist auf Speicher 0x%08lx. Der Vorgang %s konnte nicht im Speicher durchgef hrt werden.

FAULTING_IP: 
iaStorAV+50a77
fffff801`017b0a77 8b01            mov     eax,dword ptr [rcx]

EXCEPTION_RECORD:  ffffd00072b27818 -- (.exr 0xffffd00072b27818)
ExceptionAddress: fffff801017b0a77 (iaStorAV+0x0000000000050a77)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: 0000000000000000
Attempt to read from address 0000000000000000

CONTEXT:  ffffd00072b27030 -- (.cxr 0xffffd00072b27030)
rax=fffff801017b0b74 rbx=ffffe0008f7ff6d0 rcx=0000000000000000
rdx=ffffe0008f000000 rsi=ffffe0008c6a1780 rdi=ffffe0008e6bb108
rip=fffff801017b0a77 rsp=ffffd00072b27a58 rbp=0000000000000080
 r8=ffffe0008f809c28  r9=ffffe0008f7ff6d0 r10=ffffe0008f801a48
r11=0000000000ffffff r12=0000000000000000 r13=ffffe0008e6ba400
r14=ffffe0008e6bb0f0 r15=fffff8010177a550
iopl=0         nv up ei ng nz na po nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010286
iaStorAV+0x50a77:
fffff801`017b0a77 8b01            mov     eax,dword ptr [rcx] ds:002b:00000000`00000000=????????
Resetting default scope

CPU_COUNT: 8

CPU_MHZ: 95a

CPU_VENDOR:  GenuineIntel

CPU_FAMILY: 6

CPU_MODEL: 3c

CPU_STEPPING: 3

CPU_MICROCODE: 6,3c,3,0 (F,M,S,R)  SIG: 1E'00000000 (cache) 1E'00000000 (init)

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  NULL_DEREFERENCE

PROCESS_NAME:  System

CURRENT_IRQL:  0

ERROR_CODE: (NTSTATUS) 0xc0000005 - Die Anweisung in 0x%08lx verweist auf Speicher 0x%08lx. Der Vorgang %s konnte nicht im Speicher durchgef hrt werden.

EXCEPTION_CODE_STR:  c0000005

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  0000000000000000

READ_ADDRESS: fffff8025fe3d500: Unable to get MiVisibleState
 0000000000000000 

FOLLOWUP_IP: 
iaStorAV+50a77
fffff801`017b0a77 8b01            mov     eax,dword ptr [rcx]

BUGCHECK_STR:  AV

ANALYSIS_VERSION: 10.0.10586.567 amd64fre

LAST_CONTROL_TRANSFER:  from fffff801017afc2b to fffff801017b0a77

STACK_TEXT:  
00 iaStorAV
01 iaStorAV
02 0x0

THREAD_SHA1_HASH_MOD_FUNC:  2e70278ad85cc0c401beede13079d4c58692b6a4

THREAD_SHA1_HASH_MOD_FUNC_OFFSET:  639afddbdda95410ece8f65337030e4c00394798

THREAD_SHA1_HASH_MOD:  2e70278ad85cc0c401beede13079d4c58692b6a4

FAULT_INSTR_CODE:  2341018b

SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  iaStorAV+50a77

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: iaStorAV

IMAGE_NAME:  iaStorAV.sys

FAILURE_BUCKET_ID:  AV_iaStorAV!Unknown_Function

BUCKET_ID:  AV_iaStorAV!Unknown_Function

PRIMARY_PROBLEM_CLASS:  AV_iaStorAV!Unknown_Function

PRODUCT_TYPE:  1

OSPLATFORM_TYPE:  x64

OSNAME:  Windows 10

OSEDITION:  Windows 10 WinNt TerminalServer SingleUserTS

OSBUILD_TIMESTAMP:  2015-11-05 05:15:48

BUILDDATESTAMP_STR:  151104-1714

BUILDLAB_STR:  th1_st1

BUILDOSVER_STR:  10.0.10240.16590.amd64fre.th1_st1.151104-1714

ANALYSIS_SOURCE:  KM

FAILURE_ID_HASH_STRING:  km:av_iastorav!unknown_function


    Loaded symbol image file: iaStorAV.sys
    Image path: \SystemRoot\System32\drivers\iaStorAV.sys
    Image name: iaStorAV.sys
    Timestamp:        Thu Feb 19 13:08:39 2015

The driver is from February 2015, so look for a driver update.

| improve this answer | |
  • I looked up iaStorAV.sys and found it to be linked to a Intel Rapid Storage driver, if I update with the setup found here I should be okay (Dated August 2015)? I'll install and see if I can repeat the BSOD situation as it occurs always during BT dls and nowhere else. (I've tested moving large files repeatedly within drive and to external drive and back as well as dlng large files on browser and streaming content. This BSOD only comes up during BT dls.) link italic bold code – Lawrence Nov 13 '15 at 8:46
  • I was able to again reproduce the BSOD torrenting, I have already uninstalled Intel Rapid Start which was associated with the iaStorAV.sys file and installed the newer Intel Rapid Storage software but seemed to have obtained the same effects when I torrent. I have a new dump of the new BSOD. (filedropper.com/111315-16468-01) – Lawrence Nov 13 '15 at 11:46
  • Reproduced it again quickly in case more is needed. I have no idea what the issue is. Perhaps the Intel application and drivers are not compatible with my OS? I have installed and reinstalled the newest one found on the Intel site various times. here is another minidump. (Different from the two above: filedropper.com/111315-16203-01) – Lawrence Nov 13 '15 at 12:15
  • (filedropper.com/111315-14921-01) Okay I figured out how to look at the minidumps myself and learned now the last 4 posts were caused by a driver from my broadcom wifi adapter in my PC. I have uninstalled + deleted driver, installed newest driver (still BSOD), installed newest HP provided driver (older, still BSOD), I'm unsure how to proceed now, all 4 mini dumps were the same Broadcom wireless card driver causing the BSOD. This might also explain why it only occurs only during torrent downloads but for some reason not during browser downloads or long term streaming of HD videos. – Lawrence Nov 13 '15 at 13:49
  • Does this mean I have to purchase a new wireless card? – Lawrence Nov 13 '15 at 16:39
1

I had been having regular BSODs (every 1-3 days, computer always on) since I've upgraded to Windows 10. Quite annoying. My problem was a bit different: the crashdumps all indicated the jraid.sys driver caused it. However, there might be a similarity here as both jraid.sys and iaStor.sys are software RAID-related drivers.

Since my (rather old motherboard) driver have not been updated in a while, I went in the BIOS and disabled software RAID, which made a few extra SATA (and E-SATA) ports on my motherboard non-operational.

I then used this DriverView utility to confirm that the driver was no longer loaded by Windows. So far, so good.

First you should check multiple minidumps to confirm the same driver is always in cause. (It's not very difficult if you follow a guide)

Then you could try to find a way to stop relying on this driver. If you have Intel storage/raid drivers installed, try removing them to revert to basic drivers, or install/remove drivers from your notebook vendor, or disable certain BIOS features. Don't forget to backup your things first.

| improve this answer | |
  • I don't BSOD if I leave my computer on for days or doing anything else. Only downloading on any torrent client (I've tried several clients 6 so far and have been able to get the same BSOD for page fault in non paged area.) I thought it might only be an issue of downloading files only so i tried downloading larger files on browser various times (to keep the process on longer), downloading large files via skype as well as transferring and re-transfering of large files across storage devices and could not replicate the BSOD until i torrent. Processor intensive programs were also tested. – Lawrence Nov 13 '15 at 11:50
  • It seemed to be something with Intel's driver as magicandre1981 above pointed out, but I still can't seem to solve this issue yet. – Lawrence Nov 13 '15 at 11:51
1

I've been having the same issue! Tried everything from virtual memory assignment, to antivirus uninstall, to ram stick re-insertion... And no luck. Then, I came across a reddit thread. I am using Dell laptop. They told to use a network driver from windows 8 that will still work with windows 10, and fix the issue and linked me to a driver.

I installed this new driver (wifi+bluetooth), rebooted the system, fired up uTorrent and started download. Went for a bath, came back, and viola! It's still downloading.

So it's a network driver issue (obvious as issue is related with downloading). So I would recommend to update your network driver, or let windows check for updates for it.

In case anyone with Dell Laptops (Inspiron, XPS) faces this issue, go ahead and install this driver:

The source: Page fault in nonpaged area Windows 10.

| improve this answer | |
  • Worked for me on my Dell Latitude – Liero Mar 23 '17 at 20:01
1

I Own a Dell inspiron 5748. It came with windows 8.1 and i never had any BSOD while downloading torrents from utorrent. Upgraded ti windows 10 home edition 64bit and had BSOD after downloading 100mb or so through utorrent. I tried everything from upgrading bios, deleting network driver and resetting wifi settings. NOTHING WORKED - UNTIL , i tried the driver as mentioned above. I removed the network driver and manually searched for the driver. I have downloaded 9 GB so far without a single BSOD. SO IT Works !!

Solution :- Remove your Network Driver and download from dell.com from June 2015 for windows 10 WIFI + Bluetooth Driver.

| improve this answer | |
0

I had same problem with uTorrent, but only when i used PCI-E WiFi card to connect to internet. When i used USB-Wifi or cable there wasn't any problems.

My solution: uTorrent on virtual machine with Windows XP (shared folder with host, and uTorrent configured to store files in this folder) - so far no problems.

| improve this answer | |
0

I've had the same problem quite a few times on different Dell laptops, from Latitude to Insipiron, all having a Broadcom wireless device (I prefer it to Intel WiFi modules which are the other possible option) and have tried all kinds of different driver versions.

The only non-crashing version I have found didn't come from Dell's support site, nor the unofficial Dell FTP driver store. The working driver version (at least for my situation) was and still is 6.30.223.170 dating 06.09.2013. It's available from HP here and from Lenovo here.

Edit: Just to mention the only torrent client I have ever used is uTorrent say if that matters, because I'm not really sure myself.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.