Linked Questions

52
votes
10answers
162k views

Why did my flash drive become “read only” and (how) can I fix it? [duplicate]

I have a brand new flash drive (one week old) that has become marked as read only, by Windows, Kubuntu and a bootable partitioner. Why did this happen? Is it fixable? If it is, how can I fix this? ...
23
votes
5answers
278k views

Why is my USB Flash Drive Now Read-Only? [duplicate]

Suddenly my USB Flash Drive (8gb Corsaire Voyager) is suddenly read-only, and I'm not sure why. There is no "read-only" switch on the drive. All of the data is still there. But nothing can be ...
10
votes
2answers
9k views

Remove the write protection from a USB flash disk [duplicate]

My flash disk encountered an error saying that it has been write protected, so of course I can't even copy files or even format my flash drive. What happened to my flash drive to cause this? And ...
2
votes
5answers
100k views

How to remove write protection from sandisk cruzer switch pen drive? [duplicate]

I have a sandisk cruzer switch pendrive. It is write protected. I want remove that write protection. I did Google very much i am not getting how to remove it. I tried on mac also but it didn't worked ...
4
votes
4answers
18k views

Unable to format usb stick [duplicate]

I have 4GB pendrive. while trying to formatting, it gives Write protected message. The pendrive is not having write protection notch. I have tried is on Windows as well as on Fedora 13. cfdisk & ...
4
votes
1answer
17k views

USB pen drive suddenly became read-only [duplicate]

Kingston DTSE9 16 Gb USB pen drive (genuine one) suddenly becomes read-only. It has been used in a car, permanently plugged in into the USB socket as music collection for approx 6 months. It was ...
1
vote
2answers
19k views

MicroSD card is write protected [duplicate]

I have a 32 GB Lexar microSD which had been working perfectly for the past 3 months on my phone. But recently I noticed I am unable to write new files to the SD Card. I tried to format it from my ...
4
votes
3answers
5k views

Did I screw up my USB stick? And if not, how can I fix it? [duplicate]

Basically, I am doing various tests with Linux/BSD and USB booting at the moment. I had a live CD for a firewall that offered to partition a (hard) disk. I tried to use my flash drive for this - It ...
3
votes
1answer
10k views

Read Only USB Drive can't be erased/re-set [duplicate]

I bought a 32 GB flash drive several months ago, and after using it for a month or two, something happened to it. Right now, the drive has become read only. I tried using Mac OS X's Disk Utility, ...
0
votes
1answer
9k views

I can't remove the write-protection from a USB Drive [duplicate]

I know this is a duplicate question, maybe triple duplicate or more, but I really cannot find a solution for this. My USB Drive wasn't write protected before, but something happened to it and now I ...
0
votes
2answers
8k views

How do I make a USB flash drive writable on Linux? [duplicate]

I want to reformat a SanDisk Cruzer Edge USB flash drive but it appears read-only: $ sudo dd if=/dev/zero of=/dev/sdg dd: failed to open ‘/dev/sdg’: Read-only file system I checked the readonly ...
3
votes
1answer
7k views

Pen Drive automatically got Write-Protected [duplicate]

I had given a pen drive of mine to a friend with some data on it. He plugged the pen drive into the Windows 7 powered Acer netbook, didn't eject (unmount) it before pulling it out. When I again ...
0
votes
0answers
8k views

SD card has CURRENT Read-only State : Yes [duplicate]

DISKPART> attributes disk Current Read-only State : Yes Read-only : No Boot Disk : No Pagefile Disk : No Hibernation File Disk : No Crashdump Disk : No Clustered Disk : No DISKPART> ...
3
votes
1answer
7k views

How to remove write protection from USB stick [duplicate]

I have followed up the below process in cmd: DISKPART> attributes disk clear readonly Disk attributes cleared successfully. Even if I do that it displays Read-only:yes: DISKPART> attributes ...
1
vote
1answer
3k views

Copying data to USB flash drive throws “Write Protect Error” [duplicate]

I have a USB flash drive, which I made bootable for use as an anti virus disk. After formatting the drive, whenever I copy some files to it, it shows an error: The disk cannot be written to because ...

15 30 50 per page
1 2 3 4 5 9