Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [apt]

The Advanced Packaging Tool (APT) is a package management system for Debian, and a set of tools for manipulating that system.

2
votes
0answers
13 views

How to change Raspbian default apt-get mirror?

The thing is the mirror that was configured on installation is causing checksum mismatch in all packages. I read everywhere that in order to change de mirror apt-get uses for download I have to edit /...
1
vote
1answer
15 views

Ubuntu 18.10 and modify installed package - OpenMPI

I've installed openmpi-bin (OpenMPI 3.1) on Ubuntu 18.10. I also run slurm on the same machine and would like to recompile or reconfigure my installation of OpenMPI to cope with Slurm-feature. If one ...
1
vote
1answer
35 views

Update manager finds updates but `apt update` doesn't

In Linux Mint 19.1 I found a kernel update in update manager but when I checked in terminal by the command: sudo apt update I didn't find anything. When I refreshed update manager it still shows the ...
0
votes
1answer
19 views

Ubuntu - Apt-get Install failure

I am trying to install package XScreensaver. This is on a HP T410 Thin client and I am using XTerminal; lsb_release -a (OS version) returns: Ubuntu 10.04.4 LTS - Lucid. Running sudo apt-get upgrade ...
0
votes
0answers
24 views

Installation of apt stuck on Parrot OS

I have Parrot OS, armhf version installed on Raspberry Pi 3B+. Bootloader or whazever you call it is Berryboot. The problem is, I accidently removed apt itself. Then I downloaded the armhf version ...
0
votes
1answer
42 views

Getting stuck at “sudo apt-get upgrade” on Parrot OS

I have Parrot OS headless running on a Raspberry Pi. I started the upgrade but it now has stopped at: Installing new version of config file /etc/apt/apt.conf.d/01autoremove The output before was: ...
0
votes
0answers
25 views

unable to solve apt-get issues in ubuntu terminal

venky03@venky03:~$ sudo apt-get update [sudo] password for venky03: Err:10 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu bionic Release 404 Not Found [IP: 91.189.95.83 80] Hit:11 http://linux....
0
votes
0answers
31 views

How to install armhf packages on an x86 host

I am trying to cross-compile some libraries for an ARMv7, and one of the needed prerequisites is python3-dev:armhf. I am starting with a fresh debian docker-container (docker pull debian) so this ...
0
votes
0answers
45 views

Unable to install any package in ubuntu

I am not being able to install any package into ubuntu 18.04.2 LTS (Bionic Beaver). It tries to login into some server whose cred i don't know. Even if i do dpkg --configure -a, It points me to the ...
0
votes
2answers
50 views

What is the -y flag in the `apt install` command?

I'm seeing the -y flag being used in apt install -y a lot today but when I do man install no -y flag is described. Am I missing something?
0
votes
1answer
69 views

Firefox not installing properly in Ubuntu

I'm having a strange issue installing Firefox. Usually I browse Firefox in private mode, but recently I wanted to use the default mode. When I looked for it in the app dock, Firefox wasn't there (...
0
votes
0answers
26 views

Not Able to Configure dpkg in ubuntu 16.04, How to solve this

$ sudo dpkg --configure -a Setting up unattended-upgrades (1.1ubuntu1.18.04.7~16.04.2) ... dpkg: error processing package unattended-upgrades (--configure): subprocess installed post-installation ...
1
vote
2answers
92 views

I can't sudo apt upgrade

I have a new installation of Linux Mint and I cant run apt upgrade without getting this response. How can I fix it? Sorry that it's in german. me@mypc:~$ sudo apt upgrade Paketlisten werden gelesen.....
0
votes
0answers
34 views

What causes the APT error “You have held broken packages” when trying to install a newer or older version of some package?

I currently have a Debian 9 system, with a LAMP stack installed from the official repositories (Apache 2.4.25, PHP 7.0.33, MariaDB 10.1.38) I need to install PHP 7.3 because an application needs it. ...
0
votes
0answers
200 views

how do I install curl from source, including updating the libcurl version?

I am working on a distro of linux that doesn't have the version of curl I need supported via apt-get. The latest I can get through apt-get is 7.52.1 and I want the latest (7.65.1). So, I've followed ...
0
votes
1answer
46 views

How to purge available updates information in Ubuntu?

I have Ubuntu 18.04.2 installed, but had to temporarily add a repo from the next (cosmic) release to install a couple of packages. Now after I've commented out the cosmic repo in my sources.list, did ...
0
votes
0answers
47 views

apt downgrade to a specific version of package (not present in repository)

I've got a system with libgtk-3-0 version 3.22.30-1ubuntu1 installed. To fix a known bug I want to downgrade to version 3.22.21. However, running aptitude to find the available versions yells the ...
0
votes
1answer
28 views

apt-get update fails with custom repository

In my /etc/apt/sources.list I have an entry deb https://www.myserver.tld/download/Linux/Ubuntu/ bionic main The path on this server is valid, the packages can be found in https://www.myserver.tld/...
0
votes
1answer
44 views

Inconcistencies with Debian packages, executing from path, listing with dpkg and looking derivative utilities except apt

Self-explanatory: $ npm npm: archivo no encontrado (file not found) $ whereis npm npm: $ which npm $ apt list npm Listando... Hecho (listing, done) npm/stretch-backports 5.8.0+ds6-...
0
votes
0answers
28 views

How to acquire /var/lib/dpkg/lock?

Mostly situation revolves around /var/lib/dpkg/lock is to release it from zombie lock. My question: how does this lock work? how to acquire such a lock so that only I or my process can use apt ...
0
votes
0answers
59 views

How do I downgrade my linux-image-X.X.X-X package

As part of setting up a server on my box I followed a tutorial. The tutorial said that I should upgrade my system with sudo apt upgrade. This turned out to be a mistake, as it stopped my wireless ...
2
votes
1answer
107 views

apt-get error on openhabian when calling '/usr/lib/apt/methods/http'

I hope I'm right here, some days ago apt-get broke on my Raspberry Pi Model B rev. 2 (running Openhabian). I'm not sure why yet and wasn't able to fix it myself. When I try to apt-get update as root ...
1
vote
1answer
500 views

libssl-dev dependency issue on Ubuntu 18.04

I am currently trying to install libssl-dev on Ubuntu 18.04 but I am met with this issue: Some packages could not be installed. This may mean that you have requested an impossible situation or if you ...
0
votes
1answer
286 views

The method driver /usr/lib/apt/methods/https could not be found

I have C.H.I.P. and I had to reflash it (Jessie, server (I also had PocketCHIP image which wasn't playing well with my original C.H.I.P, so I went to server image), stable) due to corrupted ...
0
votes
1answer
456 views

Can't use Debian archive repositories, despite having installed debian-archive-keyring and debian-keyring

I'm trying to use some Debian Archive repositories in my sources.list, for testing purposes. I want to be able to search packages from Debian Sarge. My sources.list looks like that: # Stretch (...
1
vote
1answer
59 views

apt-get throws 400 URI failure when trying to download docker-ce

I'm having a strange issue with trying to install docker-ce instead of the outdated distro packages on Debian Stretch. I followed their simple guide verbatim: https://docs.docker.com/install/linux/...
0
votes
1answer
40 views

Linux Mint 18.1 64 not updating, mintupdate error

Whenever I try to update Linux Mint 18.1, I get the following error from the Update Manager. E: /var/cache/apt/archives/mintupdate_5.2.1.3_all.deb: subprocess new pre-removal script returned error ...
1
vote
1answer
176 views

Non-interactive apt upgrade

I'm trying to provision a machine using Vagrant and plain bash scripts. The two lines are: DEBIAN_FRONTEND=noninteractive apt-get update DEBIAN_FRONTEND=noninteractive apt-get upgrade -yq However, ...
0
votes
0answers
41 views

How to update the apt-check count of “X packages can be updated” message

Is there a command to update the apt-check results so I can use bash script to check them? I run upgrade and it shows 0 but apt-check still shows 12 packages can be updated. How often is this suppose ...
0
votes
1answer
19 views

Replace package from one repo with the same package from another repo

On my debian box, some time ago I needed a newer version of PHP than was available through official repo. I installed these from dotdeb repo (i.e. all php packages have -dotdeb- as part of the version....
0
votes
0answers
29 views

Is multiple package install through apt-get faster than one by one installation?

Is there a significant installation time difference between doing: sudo apt install -y packageA packageB packageC versus: sudo apt install -y packageA sudo apt install -y packageB sudo apt install -...
0
votes
0answers
31 views

Broken apt system prevents running wireshark

I have trouble running wireshark: $ wireshark wireshark: error while loading shared libraries: libQt5Widgets.so.5: cannot open shared object file: No such file or directory According to Ubuntu, ...
1
vote
1answer
25 views

Why does 'apt' do not store downloaded packages anymore?

I was used to apt storing downloaded packages in /var/cache/apt/archives/, but it does not do it anymore and I can't figure out why. Configuration is set accordingly IMHO: # apt-config dump | grep -...
0
votes
1answer
61 views

Error while installing G++ on Ubuntu

Hi I was wondering how to fix g++ and build essential. This is what it keeps saying: Setting up g++ (4:8.2.0-1ubuntu1) ... update-alternatives: error: /var/lib/dpkg/alternatives/c++ corrupt: invalid ...
1
vote
0answers
22 views

Grouping apt packages in Debian

I was wondering (and searching all over the place, sorry if I missed an obvious one) if, in Debian, there is any equivalent flag or option to the --virtual of Alpine Linux when installing apt packages....
0
votes
1answer
46 views

MongoDB repo for apt-mirror

Must mirror the Debian MongoDB repo for an offline DMZ. Ubuntu works, Debian doesnt. What is wrong here? Works: deb http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.2 multiverse Does not ...
2
votes
1answer
138 views

apt steam-devices dpkg error

Tried to run sudo apt update; sudo apt upgrade the other day and got an error regarding dpkg which I've not seen before and google doesn't appear to be much help either. I will just paste the output ...
0
votes
0answers
35 views

Difference in using gdebi or apt for local deb Package Installation

Back in the days, if you wanted to install a locally downloaded .deb package with remote dependencies to further packages, dpkg and apt-get where not really suited, for this scenario. Then I became ...
0
votes
1answer
67 views

How can I create an apt repository mirror on a network that is isolated from the internet?

I have a network that has no internet connectivity from any of the devices. The only way I can get data on it from the outside world is via a USB mass storage device (USB stick, external hard drive, ...
0
votes
0answers
37 views

apt-mirror always wants to download

apt-mirror is always trying to download ~430MB (every day). Downloading 4 dep11 files using 4 threads... Begin time: Wed Jan 16 09:04:43 2019 [4]... [3]... [2]... [1]... [0]... End time: Wed Jan 16 ...
0
votes
1answer
29 views

Using apt why do I get file 'network_proxy.conf' in directory '/etc/apt/preferences.d/' as it has an invalid filename extension

I get the following warning when I try to install packages. N: Ignoring file 'network_proxy.conf' in directory '/etc/apt/preferences.d/' as it has an invalid filename extension Using apt why do I ...
2
votes
2answers
1k views

Install old version of package Firefox-ESR on Ubuntu

I would like to install Firefox v52 ESR on Ubuntu 16.04 in order to access a legacy Java applet. The current version Firefox 60 ESR no longer allows me to do that. In effect, I would like to apt-get ...
1
vote
0answers
28 views

Debian 9 Stretch install new gsmartcontrol from special repo

echo 'deb http://download.opensuse.org/repositories/home:/alex_sh/Debian_9.0/ /' > /etc/apt/sources.list.d/home:alex_sh.list apt-get update Ign:1 http://download.opensuse.org/repositories/home:/...
0
votes
1answer
145 views

Error installing nginx with passenger on Debian 9

I am in the process of upgrading a Debian installation to version 9 and I am facing problems getting nginx with passenger to run. The issue is with trying to install libnginx-mod-http-passenger, ...
0
votes
0answers
32 views

Ubuntu 16.04, uninstalled python, now vim is broken and I can't fix it

I was having some problems with conflicts between my Anaconda python installation and my system Python on Ubuntu 16.04, so I decided to remove the system python packages. Apparently that was a bad ...
0
votes
0answers
39 views

Aptitude - choose resolution strategy (ie. upgrade-to-unstable before remove)

Is it possible to choose default (or per-launch) aptitude "unmet dependencies" resolution strategy? For example to have aptitude first offer upgrade-to-unstable/install-from-unstable (sid) than ...
0
votes
1answer
3k views

Not enough space in /var/cache/apt/archives/

I attempted to install the texlive package, but it could not finish the installation properly. When I then tried to continue on, it almost finished installing everything, but the texlive-publishers-...
1
vote
1answer
70 views

Why can't I install rust-doc?

I just installed rustc successfully, and saw, apt suggested I got rust-doc also. $ sudo apt install rust-doc Reading package lists... Done Building dependency tree Reading state information......
0
votes
0answers
232 views

apt-get upgrade not working after upgrade from stable to testing: error cycle with libc-bin package

I upgraded from debian stable to debian testing, and now I am not able to do apt-get upgrade anymore. When I do that I get this error: Processing triggers for libc-bin (2.27-6) ... dpkg: cycle found ...
0
votes
1answer
1k views

Unmet dependencies for PostgreSQL 10 under Ubuntu 16.04.5 LTS (xenial)

Following official instructions in https://www.postgresql.org/download/linux/ubuntu/, I got following error: The following packages have unmet dependencies: postgresql-10 : Depends: postgresql-...