Questions tagged [chsh]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer

How to check what is the default shell

Is there a config file that stores the default shell (bash, zsh, etc) for the current user ?
faressoft's user avatar
  • 393
3 votes
0 answers

Including a fallback in default shell

I have an account on a network, and my shell is set to zsh, but when I log onto a computer that doesn't have zsh installed on it, a terminal I launch tries to run zsh and fails, so I get an empty ...
Jakob Weisblat's user avatar
4 votes
1 answer

When default shell is not bash-compatible, why do bash scripts not work well?

My default shell is fish, because it's a lot nicer. But often when I run scripts, I get errors that seem to be from the bash script being processed by fish. I think this is because the script writer ...
endolith's user avatar
  • 7,447
7 votes
3 answers

Why do I see "Operation was denied because the current credentials do not have the appropriate privileges" when trying to chsh?

I'm setting up a new dev Macbook Pro, and trying to replace bash with zsh. I installed zsh and can run it to change shell in a session. When I use sudo chsh -s /bin/zsh username I get the error ...
alecmce's user avatar
  • 173
5 votes
1 answer

Use user-installed shell? [duplicate]

How do I change my shell to one installed in my home directory? I installed a new zsh in my home directory, which is picked up: >> which zsh >> /home/myname/bin/zsh It's not listed in /...
ash's user avatar
  • 763
107 votes
3 answers

How can I change shell in Ubuntu? [duplicate]

I have a Ubuntu Server VPS and I want to use /bin/bash/ as my shell. How can I change my shell? I have root access but I don't work as root. So dash is my default shell now. I have read How do I make ...
Jonas's user avatar
  • 26.6k
9 votes
4 answers

Ubuntu: Accidentally changed root user to nonexistent shell

I tried to change my user's shell, but used "sudo chsh", and changed the root shell to "bash" instead of "/bin/bash". Now when I try to change it I get "chsh: PAM authentication failed" and it seems ...
endolith's user avatar
  • 7,447
1 vote
1 answer

What chsh did when I type `chsh -s SHELL` and how to go back to previous SHELL?

I have mistakenly setting my user login shell to some unknown directory:([1]. Now, I can't login to this user. Every time I try to ssh, it always failed as if I enter the wrong password. I try to ...
ariefbayu's user avatar
  • 1,143
5 votes
4 answers

Mac Terminal: changed my shell, now can't start it

I installed bash 4.0 via MacPorts, then used sudo chsh -s /opt/local/bin/bash my_user to change my shell. Before that I tried just running plain chsh without sudo, but it wouldn't allow me to change ...
kch's user avatar
  • 2,152