Questions tagged [curlftpfs]

CurlFtpFS is a filesystem for accessing FTP hosts based on FUSE and libcurl

Filter by
Sorted by
Tagged with
0 votes
0 answers
30 views

curlftpfs: Server connection left intact, but ftp is not mounted

I'm trying to mount a ftp-server as a local directory with curlftpfs at Linux Mint. I tried it with two different ftp-servers, but with no success. The problem is that there is no error massage at all ...
1 vote
1 answer
831 views

Use curlftpfs in a secure way, without plaintext and world-readable password (e.g. in /etc/fstab)

How to use curlftpfs, in a secure way? I mean without having FTP password in plaintext and world-readable. I ask this because curlftpfs works running a command like that: curlftpfs HOST /mnt/path -o ...
0 votes
2 answers
182 views

Can't see content (PDFs) in FTP when mounting via curlftpfs?

Can't see content (PDFs) in FTP when mounting via curlftpfs (onto a CentOS7 machine). Can anyone help debug what could be going on here? I am using the instructions here: https://linuxconfig.org/mount-...
1 vote
1 answer
613 views

Cannot mount SFTP URL on local FileSystem using curlftpfs

curlftpfs -o allow_other -o ssl -o no_verify_hostname -o no_verify_peer -o ftp_port=22 -o user='{{ ftp_user }}:{{ ftp_pass }}' {{ ftp_URL }} /mnt/sftp/ output is Error connecting to ftp: Access ...
0 votes
3 answers
951 views

Download file from ftp server #1 to ftp server #2

I would like to use a Php Script with cURL library to download one directory name datas ( with one .xml and one .txt.zip file ) which is inside my ftp server #1 into my ftp server #2 . This directory ...
1 vote
0 answers
175 views

curlftpfs can touch but not update modify time

I've got a ftp mounted using curlftpfs. When I touch a file that doesn't exist, it creates the file. When I touch a file that already exists, it doesn't update the mtime. I've tried chmod 777 the ...
  • 151
1 vote
0 answers
396 views

FTP: wildcard downloading

I am trying to download a file with name ending with *.csv The problem is complicated by the fact that this *.csv contains in directory of unknown name: eg. Sometimes it would be 2015->Date 29:10:...
1 vote
1 answer
2k views

Cannot modify files with SAMBA and CurlFTPfs

I have all my ftp accounts mounted via CurlFTPfs with allow-others option. All directories have --- --- rwx (0007) permission after ftp mount with umask=0770 . This way I can log as another user (than ...
  • 53
4 votes
1 answer
7k views

How to mount curlftpfs in fstab

How can I permanently mount a remote FTP directory in fstab with curlftpfs, so it will be accessible for the common users on the machine? I am using Linux Slackware.
  • 893
0 votes
1 answer
1k views

Loop mount file available through FTP

Using curlftpfs, is it possible to mount a file available through FTP on a loop device? I get a Permission denied error when I try it: $ sudo losetup /dev/loop0 FTPMount/BigFile losetup: failed to ...
  • 118
2 votes
1 answer
3k views

How to determine ftp server filenames encoding?

I am trying to mount a ftp server with curlftpfc. But the server has unknown encoding, and all the filenames look like ???????.avi, ??????.inf. I know that I need to specify the encoding for ...
  • 143
1 vote
0 answers
793 views

curlftpfs fails on speedport ftp

I use curlftpfs for a lot of servers, but it fails for out speedport router. If I log in with filezilla, I get forwarded to /mnt/LexarUSB_Flash_Drive/16_STICK. When I have it mounted in a folder, I ...
0 votes
1 answer
449 views

Strange behavior while editing files on a curlftpfs mount in vim

While editing vim sometimes doubles characters. That is, while typing, some characters APPEAR twice. If I try to delete, vim deletes the characters in a different order than they appear. If I do not ...
  • 115
6 votes
2 answers
9k views

curlftpfs doesn't work for a username with a "@"

My hosting company makes all my usernames with a "@" in them. curlftpfs user="user@domain.com:pass" ftp://ftp.domain.com/ ~/domain/ For some reason I get in response Error connecting to ftp: ...
  • 979