Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [glib]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
2 answers
64 views

glib2 gio operation not supported trash

I would like to empty the system trash the proper way (ie not just rm -rf) and for this I wanted to use glib2, which provides a command called gio trash which can be used to interact with the trash. ...
TheFibonacciEffect's user avatar
1 vote
0 answers
193 views

`gio open` fails to use its own mime config

I'm struggling with gio failing to open an url using default browser under XFCE4 desktop environment. What could be the reason and how to fix it? gio info http://google.com identifies the link as text/...
krvkir's user avatar
  • 111
0 votes
0 answers
36 views

Would it be possible to remap the Delete key in Nautilus to a custom script instead of gio?

In Ubuntu 22.04 with GNOME 42.5, pressing the Delete key while in Nautilus runs gio trash. There has been a long-standing issue with the way gio handles Trash within subvolumes in the btrfs file ...
Majal's user avatar
  • 957
1 vote
1 answer
196 views

how to redirect to newer version of a linux library if two or more older versions of that library are found?

I downloaded the latest version of libglib2.0 2.76.3 and installed it from source. However, pkg-config finds an older version of glib when i try to install some programs. What I must do? export ...
Estatistics's user avatar
0 votes
1 answer
262 views

Multiple versions of glib

I have an older version of glib that all applications are compiled against and use. I need to install a new application that requires a newer version of glib to compile and run. I installed the new ...
Tohiko's user avatar
  • 101
1 vote
1 answer
1k views

unable to connect to any IRC server using irssi

I am using irssi 1.2.3 (20210409 0011). When I do /connect Freenode (or any server for that matter), I get the following error. GLib warning SSL handshake failed: server closed connection unexpectedly ...
weirdsmiley's user avatar
0 votes
1 answer
79 views

On mingw/pacman why does harfbuzz requires glib2, which requires python?

I was installing SFML from pacman, which requires freetype, and I got a nasty cyclic dependency between freetype and harfbuzz, which is another issue. My main question is about this chain of ...
jokoon's user avatar
  • 409
6 votes
1 answer
11k views

ERROR: Dependency "mount" not found, tried pkgconfig and cmake Linux while trying to install glib-2.60.0

Runing the following command from a terminal: sudo python3 meson _build : **The Meson build system** Version: 0.50.0 .... Checking for function "ngettext" : YES Checking for function "...
cam zilla's user avatar
1 vote
1 answer
827 views

Solaris libglib2.0-dev

I want to install mc-4.8.12 (Midnight Commander), but I get this error: glib-2.0 not found or version too old (must be >= 2.12) When I search Google for a solution, I see the package libglib2.0-...
aykon's user avatar
  • 35
1 vote
0 answers
53 views

Is there a way that I can upgrade my glib in opensuse 13.1?

I am trying to install gtk+ but this requires glib >= 2.39 and I have 2.38. I would like to upgrade to 2.40 but once I installed it it still told me it could not find it. Now I could not change the ...
ciprianr's user avatar
  • 111
0 votes
1 answer
587 views

Building gstreamer 0.10 under Win32 via Cygwin

There is no more installer for GStreamer 0.10 available on GStreamer website (only versions 1.x). I really need to work with this version so I tried to build it from source. I found this laconic page ...
MarAja's user avatar
  • 321
3 votes
1 answer
6k views

Slackware Linux: Glib can't find libffi.so.6. Where is it trying to look?

I have libffi installed and it's in /usr/local/lib, yet the glib make process can't find it /home/mathmagi/src/glib-2.32.4/gio/.libs/lt-glib-compile-resources: error while loading shared libraries: ...
Mathmagician's user avatar
1 vote
1 answer
543 views

libiphone build issues on Debian Squeeze (x64)

I'm trying to build libiphone from source on Debian Squeeze (64-bit). But autogen.sh keeps giving me this: configure: error: Package requirements (glib-2.0 >= 2.14.1) were not met: No package '...
Dr Kitty's user avatar
  • 544
2 votes
0 answers
2k views

Unable to install synergy on red hat 5.4

I'm trying to install Synergy on Red Hat Linux 5.4 but I'm getting the below errors: rpm -ivh synergy-1.3.8-Linux-x86_64.rpm error: Failed dependencies: libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is ...
Mike's user avatar
  • 233
1 vote
1 answer
3k views

Cannot uninstall old version of GLib (2.26.1) to install GTK

I am trying to install GTK as a dependency of a dependency of Audacity. The first time I tried to do the usual configure-make-make install set of commands for it, it said I was missing the cairo ...
dpitch40's user avatar
  • 169
1 vote
2 answers
740 views

Build Firefox from source code under Mac OS X

I'm trying to build Firefox from source code under my Macbook pro. I believe I follow all direction on their pages, yet I still stuck on building it up. I installed all requirement (mercurial libidl ...
REALFREE 's user avatar
0 votes
3 answers
2k views

In which directory should I extract and install gtk+, glib, gdk-pixbuf, pango in ubuntu?

I am trying to install the latest version of GTK+ and I have downloaded all the packages listed here: http://www.gtk.org/download-linux.html In which directory should I extract each of the tar ...
snooper's user avatar
  • 177
0 votes
1 answer
739 views

Poppler installation

I downloaded the new poppler 0.15 tar ball and i built it from source successfully but when trying dpkg -l | grep poppler it outputs ii libpoppler-dev 0.14.3-...
Wazery's user avatar
  • 822
0 votes
1 answer
3k views

How do I install a newer version of GTK in Ubuntu without replacing the current one?

I am trying to compile file-roller from git, but running autogen.sh gives me this error configure: error: Package requirements (gtk+-3.0 >= 2.91.1) were not met: No package 'gtk+-3.0' found ...
William Friesen's user avatar
1 vote
2 answers
2k views

Where to get glib-config for Kubuntu?

I'm trying to compile Midnight Commander on a KUbuntu 9.10 (Karmic) box with no root access. I've set up a directory under $HOME, downloaded the mc source package and various stuff required for ...
Carl Smotricz's user avatar