Questions tagged [glibc]

glibc (GNU C Library) is the C standard library from the GNU project.

Filter by
Sorted by
Tagged with
0
votes
2answers
88 views

Pacman and Arch Linux - No longer booting due to package issues, glibc

After having some pacman issues, I am not longer able to boot into my arch linux systemafter grub. All I get is a black screen without the ability to input anything. I believe this is due to ...
0
votes
2answers
1k views

Arch GLIBC_2.33 not found errors after updating one package

I ran sudo pacman -Syu ...saw all the packages needing download and backed out. Then I ran sudo pacman -S openssl to update just that package, and it succeeded. Now, I can't do much of anything ...
0
votes
0answers
64 views

How to correctly use localedef to create new locales

I am setting up an embedded linux system with petalinux and want to create new locales, specifically the en_US.UTF-8 locale. My systems currently has locale and locale-def and glibc 2.3 . Running ...
0
votes
0answers
74 views

Glibc installation Winstars3 on CentOS 8

I tried to run WinStars 3 on CentOS 8 and I get: [root@comp WinStars3]# ./WinStars3.sh /opt/WinStars3/./WinStars3: /lib64/libm.so.6: version `GLIBC_2.29' not found (required by /opt/WinStars3/./...
0
votes
0answers
30 views

Accidentally switched to incorrect version of libc, can't update back

While doing a CTF I downloaded a deb containing a version of libc (ubuntu 2.28). I tried to extract the binary, but accidentally uninstalled my libc, and replaced it with the wrong one. Now I can't ...
0
votes
0answers
29 views

how to start a file necesary glibc 2.17 without uid0?

I need a solution or a improvization how to start a file with this error " : /lib64/libc.so.6: version `GLIBC_2.17' not found (required by ........ ", i need a resolve how to start or how to resolve ...
1
vote
0answers
110 views

Minimum version of glibc for pytorch

Is there a minimum version of glibc required for installation of pytorch when installing from source. My system’s glibc is 2.12 and I am trying to install pytorch = 1.3 on it. OS is CentOS - 6.5
0
votes
1answer
361 views

how to resolve this yum dependency error while installing glibc?

Error: Package: glibc-common-2.17-260.el7.x86_64 (@base) Requires: glibc = 2.17-260.el7 Removing: glibc-2.17-260.el7.i686 (@base) glibc = 2.17-260.el7 ...
2
votes
0answers
529 views

docker cp command get system error

root@CentosWebServer opt]# docker export acf -o test.tar Error response from daemon: Error exporting container acf: error processing tar file: docker-tar: relocation error: /lib/x86_64-linux-gnu/...
2
votes
1answer
4k views

ImportError: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found

I'm trying to run a Python script over ssh on a distant server on which I do not have sudo rights. This piece of code display the error specified in the title import dlib After this, I run the ...
5
votes
2answers
745 views

How exactly a system might break by updating glibc?

Suppose that I have a program that relies on a newer glibc version that is not available in the system via packages. And it gives: version `GLIBC_2.xxx' not found One solution is compiling the ...
1
vote
0answers
120 views

Why no-nls utf8 locale is called C.UTF-8 in Debian and C.utf8 in Gentoo

I usually worked with Debian GNU/Linux, and UTF-8 locale with no translations was called C.UTF-8. I assumed, this is de-facto name for such locale. Recently, I was installing Gentoo GNU/Linux ...
1
vote
0answers
210 views

make check fails building glibc 2.28

I'm getting the following result when make checking glibc 2.28: UNSUPPORTED: elf/tst-audit10 UNSUPPORTED: elf/tst-avx512 XPASS: elf/tst-protected1a XPASS: elf/tst-protected1b FAIL: intl/tst-gettext ...
1
vote
0answers
2k views

how to update libc6 on Red Hat Enterprise Linux Server release 6.6

I am running into following error while compiling a build and based on https://askubuntu.com/questions/421642/libc-so-6-version-glibc-2-14-not-found I tried to upgrade the libc using yum, brew,apt-get,...
1
vote
0answers
195 views

Running project that has a .so file dependent on a newer version of GLIBC than I have installed on my system

I am attempting to run the software stored in this repository: https://github.com/uwnlp/EasySRL. I am a user on a cluster machine and as such have no root access. I compile the above project with ...
0
votes
1answer
517 views

CentOS 6: configure: error: the compiler must support C cleanup handling

I'm trying to install glibc 2.14 on CentOS 6 - centos-release-6-9.el6.12.3.x86_64 from source while running ./configure --prefix=/opt/glibc-2.14 command, I am getting following error configure: ...
0
votes
1answer
702 views

Return the version of glibc to 2.12

on CentOS release 6.9 (Final) I have updated glibc to 2.14 according to this procedure https://unix.stackexchange.com/questions/176489/how-to-update-glibc-to-2-14-in-centos-6-5 However after ...
0
votes
2answers
549 views

why does configure recent glibc complain that nptl is not there?

I am trying to recompile a recent (2.12.1) glibc, following the directions in http://www.tldp.org/HOWTO/html_single/Glibc-Install-HOWTO/ From a build directory I do ../*2.12.1/configure --prefix=/...
1
vote
0answers
278 views

Nemo won't stop crashing, trying to fix it actually broke Firefox and other things

I'm using LMDE Betsy, and nemo has been crashing all the time lately. The windows usually last a few seconds, and the Desktop icons keep disappearing as well. I've tried to fix it in several ways ...
13
votes
1answer
21k views

What is / does ld.so.preload do?

I stumbled upon a file called ld.so.preload and can't find any real usage for it. Does it have something to do with the env variable LD_PRELOAD ?
0
votes
2answers
622 views

CentOS 5.2: GLibC version too old (libgio issue), upgrade to which GLibC version

I'm working on a CentOS 5.2 system. The application I'm trying to launch, refuses because a reference to libgio-2.0.so.0 seems not to exist. This seems to be due to the GLibC version, so I had ...
0
votes
1answer
1k views

xenserver 6.5/centos 5.10 parted/glibc upgrade missing dependency that is not missing

I cannot seem to find the official best way to get round this issue: $ yum --enablerepo=base --disablerepo=citrix install parted Loaded plugins: fastestmirror Loading mirror speeds from cached ...
0
votes
1answer
5k views

SLES 11 update glibc using rpm

I'm trying to upgrade glibc but I'm getting failed dependencies however it also says the dependencies is (installed)? Should I run it with ignore all dependencies? SUSE Linux Enterprise Server 11 (...
0
votes
0answers
741 views

how to install a local version of GLIBC on RHEL (without su permissions)

The glibc on the RHEL system I am using is old. I don't have su permissions on that system. Anyone knows how to install a local, updated version of GLIBC on my user account, without the need to have ...
1
vote
0answers
173 views

ulimit seems to freeze bash script

I'm running a bash script that runs multiple small apps with different inputs. Some of these apps have bugs (e.g., never finish) and so I use ulimit to get the output or an error from all of them. In ...
1
vote
0answers
242 views

Buildroot 2015 Fails glibc

When I try to use buildroot, Glibc fails to compile with this error: checking for suffix of object files... configure: error: in `/home/sam/buildroot/buildroot-2015.05/output/build/glibc-2.20/build':...
4
votes
1answer
2k views

Upgrading glibc in centos 6.6

My server is using glibc-2.12.x. when I install certain packages it gives an error.Dependency not found glibc-2.14 or above is required.When I try using yum install glibc* it says server is already ...
0
votes
1answer
146 views

Determine vulnerable programs affected by glibc's ghost bug?

How do I determine the programs that are installed on my system which could be vulnerable to glibc's ghost bug? (Presuming the system has a vulnerable version of the libc6 library). Posts like How To ...
13
votes
3answers
3k views

GHOST glibc vulnerability (CVE-2015-0235): is it required restart a server after glibc upgrade?

I want to update glibc according to RedHat: https://rhn.redhat.com/errata/RHSA-2015-0090.html Is it required restart a server after the glibc upgrade?
1
vote
1answer
11k views

Redhat Linux /lib/libc.so.6: version `GLIBC_2.16' not found (required by /lib/libncurses.so.5)

I am running a server RHEL 6.4 which currently has GLIBC 2.12 installed on it. We are trying to run a program which gives this error /lib/libc.so.6: version `GLIBC_2.16' not found (required by /lib/...
0
votes
1answer
688 views

Copying glibc from initrd to my root filesystem

I'm trying to install glibc 2.20 (built recently) to Debian using this guideline from FAQ referenced at this page (the question within FAQ is How do I install all of the GNU C Library project ...
0
votes
2answers
10k views

Installing a specific glibc version on debian/apt

A user of my software uses Debian wheezy. The software generated a core dump that I want to analyze. However, for this to work, I require the correct versions of low level system libraries, especially ...
4
votes
1answer
4k views

unable to install libc6-dev

I type in sudo apt-get install libc6-dev and get the following back: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. ...
3
votes
4answers
41k views

Where to download missing libc.so.6

I recently accidentally deleted the file /lib/x86_64-linux-gnu/libc.so.6. This file is needed by most programs, so my computer is basically broken and I can only access the hard drive through a live ...
2
votes
1answer
4k views

Installing selinux headers

I'm trying to build the newest version of glibc (2.19) on CentOS 5.6 and I've run into some issues The documentation of glibc says that I need at minimum the linux kernel headers 2.6.19 (even if this ...
1
vote
0answers
720 views

Compile with openssl-1.0.1e but linked against old glibc

Desirable result: compile a binary with statically linked openssl 1.0.1e but dynamically linked glibc, stdc++, etc. Binary should run on most servers, for example Ubuntu 11.04 or RHEL 6, CentOS 6.4. ...
2
votes
2answers
17k views

Version `GLIBCXX_3.4.15' not found in CentOS (in file /usr/lib/libstdc++.so.6)

I try to use a program and I get the following error. /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found Under /usr/lib64 the libstdc++ I see is libstdc++.so.6.0.13 (and a soft link). ...
2
votes
2answers
2k views

how to update libc on debian squeeze?

I want to install Arachni scanner on my debian squeeze box. But it has problem with glibc version. It need glibc 2.15 but what is installed on my debian is 2.11 . How can I update my libc from 2.11 ...
1
vote
0answers
643 views

glibc's --with-cpu option

I'm unable to compile glibc: configure exits with the following error: configure: error: The [CPU] subspecies of x86_64 is not supported. I'm sorry; this must be somewhere, but I haven't been able ...
0
votes
1answer
203 views

Are there any problems after glibc update from 1.2.10 to 2.12 in Linux?

I want to update my glibc from 1.2.10 to 2.12. Are there any problems regarding dependency for other tools and software currently installed using previous version of glibc on CentOS release 6.3 (Final)...
1
vote
0answers
44 views

install drivers - dependency conflict: ubuntu 64 bits

I got the message from the system as follow: # apt-get install build-essential The package libc6 needs to be reinstalled, but I can´t find an archive for it. It is running in Ubuntu 64bits on Mac ...
0
votes
2answers
744 views

How much RAM for running a Tor Bridge?

Heyho, I'd like to run several Tor bridges on vservers. Operating system will be Linux (Ubuntu 12.04 amd64). Does someone have experience with how much RAM I'll need? The 512MB vservers cost 30 - 50 % ...
2
votes
0answers
3k views

Can you run a program using a custom glibc? [closed]

I installed Mathematica 9 on an old Red Hat Enterprise Linux AS release 4 system. After the installation, I tried to start Mathematica, but following message came out: /home/wcbao/M/Wolfram/...
32
votes
3answers
179k views

How to fix “/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found”?

How to fix this error: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found Platform: Linux alef 3.2.0-4-amd64 #1 SMP Debian 3.2.35-2 x86_64 GNU/Linux
3
votes
1answer
2k views

execvp exec format error for shell script on Red Hat Enterprise Linux 6

We have two RHEL 6 systems that are running identical versions of the kernel and glibc (glibc–2.12–1.90.el6_3.6). According to the POSIX standard and the Linux man pages, if the kernel determines that ...
0
votes
1answer
872 views

Linux From Scratch, glibc Make error

I am following the LFS guide 7.2 and I am at section 5.7. When executing the Glibc make, I receive the following error. -o /mnt/lfs/sources/glibc-build/math/s_isnan.os -MD -MP -MF /mnt/lfs/...
0
votes
2answers
1k views

Wine on Gentoo fails with libgcc_s.so.1 must be installed message

Not long ago problems with Wine have began on my Gentoo PC... When I try to launch any application I see this thing: libgcc_s.so.1 must be installed for pthread_cancel to work wine client error:25: ...
0
votes
1answer
972 views

What is the error on executing apt-get (GLIBCXX_3.4.15 not found)?

I have an error by installing and executing the apt-get (there is no package manager except udpkg): apt-get: /usr/lib/libstd++.so.6: version GLIBCXX_3.4.15 not found (required by apt-get) I have the ...
1
vote
1answer
2k views

Trying to compile glibc in ubuntu. Why does configure stop at linuxthreads?

Here's the config.log contents: I disabled _FORTIFY_SOURCE because it caused an error. But I'm completely clueless as to what might be wrong. (I am aware of this post, suggesting to --disable-sanity-...
1
vote
2answers
1k views

Why program fails when started using /lib/ld-linux.so.2?

$ /bin/bash -c 'echo qqq' qqq $ /lib/ld-linux.so.2 /bin/bash -c 'echo qqq' /bin/bash: xmalloc: ../bash/variables.c:2176: cannot allocate 3 bytes (8192 bytes allocated) Why this happens (zsh4, python ...