Questions tagged [hdiutil]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
49 views

Homebrew cask installs fail with hdiutil error

I'm consistently getting the same error while trying to install any cask. hdiutil: attach failed - Resource busy Homebrew tries to attach an image twice (why?) and second attempt fails. Although ...
0 votes
1 answer
50 views

hdiutil Microsoft Remote Desktop 10 issue

Currently I am using macOS Microsoft Remote Desktop 10 to connect to a virtual machine. Within the settings of this Microsoft Remote Desktop 10 application, I set the re- direct folder to the disk ...
1 vote
0 answers
48 views

Recover Time Machine sparsebundle backup

I have a Time Machine backup from an old computer that I can't open. When I double click on the sparsebundle file, I get "no mountable filesystems". I've next tried this: hdiutil attach -...
1 vote
0 answers
87 views

Creating a base image for macOS High Sierra with Apple File System (APFS)

I used to be able to create a single dmg file of a Mac disk drive (contains all partitions including recovery partition) and then deploy it to another Mac as per these instructions: https://support....
  • 31
3 votes
1 answer
2k views

Create single disk image from drive with multiple partitions

I'm running Mac OS X 10.11.6. I have a variety of old CD-R's that contain multiple partitions (I would imagine this also applies to an HD). When I insert the disk, each partition mounts as a separate ...
  • 51
2 votes
1 answer
5k views

format disk with APFS, the new apple file system?

Has anyone managed to format an actual real disk with the new apple filesystem APFS in Mac OS Sierra ? the documentation explains how to make a disk image with APFS: hdiutil create -fs APFS -size ...
3 votes
0 answers
688 views

Is it safe to cancel hdiutil compact?

A sparse image is a type of disk image file used on Mac OS X that grows in size as the user adds data to the image, taking up only as much disk space as stored in it (quoth Wikipedia). If a sparse ...
  • 215
2 votes
0 answers
700 views

Mount the second partition of an image with hdiutil

I'm trying to open a partition on my Mac (OSX Mavericks). Particularly, I've got a file.img image which includes two partitions: a boot partition and a second partition formatted in ext2. When I ...
  • 123
4 votes
2 answers
21k views

Can't unmount dmg. Keep getting "Resource Busy"

"Workspace" is an encrypted dmg where I keep my code. I don't usually unmout it but I need to take a backup and it's refusing to let me unmount: mark@mark-macbook-air /Volumes$ lsof | grep Workspace ...
  • 141
9 votes
3 answers
18k views

Mounting an ISO image with readwrite permission

I am following these instructions for creating a cross-platform CD. I am coming across a problem in Mountain Lion where I cannot mount the image as read-write. When I enter the following in Terminal: ...
0 votes
1 answer
437 views

Attach disk drive in Linux

Is there a Linux equivalent of the Mac's sudo hdiutil attach -imagekey -diskimage-class=CRawDiskImage -nomount I have an imagine I want to attach as a disk drive, but I don't want to mount it. The ...
  • 323
1 vote
0 answers
522 views

Determine exact size of DMG to hold data

Let's say that I have three files with the following sizes: FileA: 15468bytes FileB: 3874235bytes FileC: 10452326bytes and I want to create a UDIF, GPTSPUD, HFS+ DMG with hdiutil which will ...
  • 524
9 votes
2 answers
20k views

Converting .iso to .img in Mac OS X 10.6

I'm trying to convert an .iso file (Ubuntu disc image) to a .img file. I run a command like so: hdiutil convert -format UDRW -o ubuntu.img ubuntu-11.04-server-amd64.iso But no matter what, I get ...
  • 245
16 votes
2 answers
13k views

Shrink a .sparseimage

I have a .sparseimage that occupies 90GB of space on my hard drive despite only having 30GB of files in it. How can I reclaim the empty space used by the .sparseimage and compact the file?
  • 6,665
8 votes
1 answer
9k views

hdiutil on Linux

Anyone know of a Linux port of the Mac OS tool hdiutil (http://www.unix.com/man-page/osx/1/hdiutil/)?
  • 266
17 votes
7 answers
7k views

Bypass a licence agreement when mounting a DMG on the command line

I'm automating my Mac installation using puppet. As a part of it I need to install several programs that come in a .dmg format. I use the following to mount them: sudo /usr/bin/hdiutil mount -plist -...
19 votes
13 answers
149k views

I'm unable to mount a DMG, getting a "no mountable filesystems" error

I downloaded a DMG of some commercial Mac software (CSSEdit) but I found that the DMG wouldn't mount. I tried another image from the same company, and then a number of images I had laying around from ...
  • 1,661