Questions tagged [innodb]

InnoDB : MySQL's ACID-compliant Storage Engine

Filter by
Sorted by
Tagged with
0 votes
1 answer
72 views

MySQL Cluster binlog replication order

We are facing an issue with our MySQL replication stack: We actually have a MySQL ndb cluster (7.6.11) acting as a master and an innoDB(5.7) as a slave. Everything seemed to be working right until we ...
kaladan's user avatar
0 votes
1 answer
889 views

XAMPP Mysql shutdown unexpevtedly

Please, my MySQL is damaged after my PC suddenly shutdown. 18:05:24 [mysql] Error: MySQL shutdown unexpectedly. 18:05:24 [mysql] This may be due to a blocked port, missing dependencies, 18:05:24 [...
Gusti Syailendra's user avatar
1 vote
0 answers
64 views

Rollbacks in transactional DDL statements for innodb in MySQL 8.0

System: MySQL 8.0, Storage engine - Innodb In a given scenario, I obtain an explicit transaction in application layer, and run some DDL and DML statements. If tx fails, I roll-back it. But only DML ...
uzumas's user avatar
  • 111
0 votes
0 answers
2k views

InnoDB Cluster - addInstance have issue. what is the step for troubleshoot

cluster.addInstance("root@c-1:3306"); A new instance will be added to the InnoDB cluster. Depending on the amount of data on the cluster this might take from a few seconds to several hours. Adding ...
Neeraj Yadav's user avatar
1 vote
0 answers
49 views

Restoring InnoDB-Table does not work

i have some issue while restoring data from ibd and ibdata-file. I had worked with these instructions, Recovering A Corrupt MySQL Database and it worked fine until I took a look at the data. The ...
user8651114's user avatar
0 votes
0 answers
2k views

How to restore corrupted .IDB files on a MySQL server?

I currently have all the old .frm and .idb files from a MySQL server (actually the entire data directory). The server itself has been deleted by the user in his troubleshooting and he has installed a ...
singerm0's user avatar
0 votes
1 answer
5k views

MariaDB Server cannot start: "InnoDB: No valid checkpoint found."

After my VM server has fully crashed, and I do not know why, MariaDB on this Debian cannot be launched again. Content of error.log with log files: 2019-04-15 0:40:43 139787712552320 [Note] InnoDB: ...
Felix Stupp's user avatar
7 votes
2 answers
26k views

How to fix MariaDB when it gets stuck during shutdown (Waiting for page_cleaner)?

I am running MariaDB (v 10.3.13) on Arch Linux (Manjaro). It worked normally for the last months but now there are some issues. When I try to reboot the computer, it gets stuck at A stop job is ...
jost21's user avatar
  • 747
0 votes
1 answer
193 views

How exactly does the InnoDB engine in MySQL update its main data storage files?

It's come to my attention in the course of testing Linux's Back In Time backup utility that I can't understand how MariaDB actually saves data. After adding a bogus record to a table and leaving it ...
mike rodent's user avatar
21 votes
3 answers
32k views

Cannot start mysql: InnoDB: Upgrade after a crash is not supported

I am trying to run MySQL from a Homebrew installation, but it keeps failing when trying mysql.server start. My /usr/local/var/mysql/<name>.local.err reads as so, and keeps sending this error ...
nipponese's user avatar
  • 1,114
0 votes
0 answers
73 views

How to check how much InnoDB space is used?

I have 20GB /var/lib/mysql/ibdata1. How to check how much of this file is really used and how much are junk data which does not store any real data, but just takes space of my disk?
porton's user avatar
  • 311
1 vote
1 answer
49 views

Is it possible or desirable to run MySQL without any MyISAM tables?

We would like to avoid using MyISAM tables because they don't support transactions. However, I've noticed that many internal tables in MySQL use MyISAM. I can get a list like this: select ...
Nick Retallack's user avatar
3 votes
1 answer
82 views

How to find whether mysql database my key_buffer and innodb_buffer_pool contending

Server infrastructure: I'm having a centos server running nginx + wordpress + mysql. Problem: mysql frequently getting shutodown and wordpress showing the "cannot connect to database" alerts. ...
MohanBabu's user avatar
  • 143
0 votes
0 answers
85 views

InnoDB + Windows 10 "Storage Spaces" =?

Ok, I think I can repeat this problem. Win 8.1 Pro x64 . Drive S: is "Storage Spaces" mirror made of two 250 GB HD's. Drive C: is SanDisk SSD 120 GB WAMP/MySQL Inno DB consistently refuses to start ...
DBJDBJ's user avatar
  • 101
0 votes
2 answers
385 views

innodb buffer pool size and munin

I was looking at the below graph of one of my db server's memory usage and have the following question. Is the mysql innodb buffer pool included in the apps or the cache memory allocation? Right now ...
Josh's user avatar
  • 41
0 votes
1 answer
1k views

Why there is always a tilde (~) sign in the result message in mysql

Whenever I refresh or search anything in the table in mysql, the result message always shows result like this. Showing rows 0 - 10 ( ~11 total , Query took 0.0004 sec) When it is showing the exact ...
Waseem's user avatar
  • 223
2 votes
1 answer
4k views

MYSQL fails with: InnoDB: Operating system error number 30 in a file operation

My MYSQL server has been stopping recently about once a week. It requires a reboot to get is working again. But once its rebooted, it will work again for another week or two. The error in question is ...
Jon's user avatar
  • 123
0 votes
2 answers
231 views

MySQL server stopped working

Yesterday, out of the blue, the MySQL working as a backend for my private postfix server stopped working. No log entries, nothing, it just won't start. I reinstalled it and it worked until I copied ...
mcandril's user avatar
  • 123
35 votes
3 answers
146k views

MySQL InnoDB lost tables but files exist

I have a MySQL InnoDB which has all the database table files, but MySQL doesn't see them, and isn't loading them. The problem happened because I deleted these three files: ibdata1, ib_logfile0 and ...
Get Off My Lawn's user avatar
0 votes
3 answers
386 views

Is MyIsam safer than InnoDB?

Is MyIsam engine safer than InnoDB about loss of data due to FileSystem error? It seems that InnoDB is not reparable with MySQL tool. I had to choose my engine and I chose InnoDB because of foreign ...
Tobia's user avatar
  • 2,253
4 votes
2 answers
12k views

Can't start mysql (xampp) after installing on external drive

I decided to move my XAMPP installation to external drive. It's USB3 3TB Seagate drive. Unfortunately mysql doesn't want to start. All works fine if I install XAMPP to C drive but doesn't work when I ...
Klikerko's user avatar
  • 171
1 vote
1 answer
756 views

XAMPP on external 4 TB USB 3.0 drive not working as expected

I can't seem to start MySQL on my external USB 3.0 drive. In the past, I haven't had problems working off of external drives. This is the first time using a large drive. Any help will be appreciated. ...
t q's user avatar
  • 303
1 vote
2 answers
804 views

Mysql InnoDB Disabled

I have modified the my.cnf for a MySQL 5 installation and now I receive the following error in syslog: InnoDB: Error: log file ./ib_logfile0 is of different size 0 5242880 bytes InnoDB: than ...
James's user avatar
  • 153