Questions tagged [kext]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer

Kali Linux - Switching to GNOME from XFCE in KEX on WSL2 (WIN11). How to?

I'm unable to switch to Gnome desktop envivorment in Kali linux running on WSL2. I'm booting with kex (kex -s). Already installed Gnome updatet to latest release, but it always boot in Xfce. Tried ...
danieldeluca's user avatar
0 votes
0 answers

How do I remove kext files after uninstalling Norton Antivirus on mac to then install Avast?

I removed Norton after having problems with it interfacing with MacOS on many levels. I proceeded with the standard Norton uninstall and found that it seemed to work. However, when adding Avast I ...
Farsight's user avatar
0 votes
1 answer

Running wine on mac to get Windows drivers working

If the required kexts for macOS are not available and macOS does not support my device natively, can I still use devices like modem, soundbox, etc on macOS by installing wine and then installing all ...
Nick's user avatar
  • 3
0 votes
0 answers

MacBook Pro Retina SLOW boot on Mojave

This is my first post and I wanted to know if anyone else has the same issue as me - Current boot time with Mojave 1-2min. My system is a Mac book Pro retina mid 2012 highest specs, ssd with a fresh ...
Stelab's user avatar
  • 1
0 votes
0 answers

Driver from C code (autoload, kext, lkm)

I've made a question on StackOverflow thinking it was the right place for asking, but they directed me here because they think its a SuperUser-releated topic. So here I am :) I'd like to ask you how ...
pippo's user avatar
  • 101
1 vote
0 answers

Locate and remove audio device kext (Virtual DJ)

I try to uninstall VirtualDJ software from a macbook pro running El Capitan, following instructions delivered by both official site and users forums -> delete app in application folder delete ...
Naja's user avatar
  • 111
0 votes
1 answer

Free solution for tracking mac kext installs - managing security with disabled kext-signing

The goal is to track when kexts are installed and determine whence kexts came. For instance TRIM is disabled for 3rd party drives in OS X Yosemite. To use a utility like Trim Enabler one must disable ...
thepen's user avatar
  • 243
2 votes
3 answers

How to get ExpressCard 34 USB3 working on Apple Mac OS X 10.10 / 10.11 + (via 1 or more of: kexts,signing or choosing compatible models/chipsets)?

Note that I want to try this manual approach first before using MultiBeast. Failed to do the driver install—failure message on screen—when I last tried last week or any other automated tool. I want ...
therobyouknow's user avatar
0 votes
1 answer

How to enable ATI 48xx in Mavericks (tried with Multibeast but no use)

I managed to install Maverick 10.9 - but the Graphics is not detecting my ATI 4890 Cyclone 1GB. How do I enable it ? I tried various options: Install the kexts using Multibeast 6.2.1 boot with -...
Dio Phung's user avatar
  • 839
0 votes
1 answer

Mac 10.9 kext file unloads randomly

I'm working with Mac 10.9 (Mavericks) and making a kernel extension (ported from 10.8). I load the kext file in the /System/Library/Extension folder but at times I will find the the kext gets unloaded ...
Chef Pharaoh's user avatar
18 votes
1 answer

Using OpenVPN from Mac OSX Terminal, cannot load Tun/Tap

I am looking to use OpenVPN straight from the terminal instead of using a gui such as tunnelblick - but am encountering a couple of problems. I have tested my config file and it works fine so it is ...
xizor's user avatar
  • 451
11 votes
3 answers

How to kextunload in OS X Lion

I'm starting to learn more about the mac os x internals. Now i want to load and unload some kernel extensions. I startet to load the MS-DOS file system via sudo kextload /System/Library/Extensions/...
ohboy21's user avatar
  • 233
0 votes
1 answer

Error message - kexts installed improperly

I have just gotten an error message for every single kext file there is. The error message goes something along the lines of: The system extension "file path" was installed improperly and cannot be ...
JqueryToAddNumbers's user avatar
0 votes
1 answer

Can't change owner/group to root:wheel on certain stubborn files

SOLVED: Turns out at one point while trying to copy files over to the thumb drive it must not have been mounted by OS X, and since I was root, it made the same mount point directory and copied into ...
Jay's user avatar
  • 11
2 votes
0 answers

macosx: how to reload ethernet kext?

I was thinking about a kextunload followed by a kextload but that didn't really worked: %sudo kextunload /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext (kernel) ...
Albert's user avatar
  • 6,581
1 vote
2 answers

Snow Leopard: how can I monitor loading of specific extensions?

I'm installing the VoodooHDA extension in order for Intel 82801I (ICH9 Family) HD Audio 8086:293E sound card to operate. The sound card does not work but I have no idea how to debug the issue. How ...
ufk's user avatar
  • 901
7 votes
2 answers

How can I force a Mac OS X kext to load prior to login?

I have a kext that I would like to be loaded at startup time. It doesn't need to be loaded particularly early in the process, but I would like it to be loaded before a user logs in. The kext in ...
wfaulk's user avatar
  • 6,198
3 votes
7 answers

Mac OS X Snow Leopard - Error CNQL2410_ClassicNotSeize.kext was installed improperly

Does anyone know how to fix this problem? The system extension CNQL2410_ClassicNotSeize.kext was installed improperly. I'm not sure what is triggering the error.
ScArcher2's user avatar
  • 271
38 votes
5 answers

How do I uninstall and remove a .kext on Mac OS X?

I bought a X-in-1 media card reader and had to install a driver in order to be able to read SD-HC cards. Now sometimes when I unplug the reader from the USB port I get a kernel panic. So now I'd like ...
Marc's user avatar
  • 1,317