Questions tagged [minicom]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers

Minicom enable echo by default and set color for local echo

To enable the echo with Minicom I use the combination Ctrl+A E, I was wondering if there is a way to activate the echo automatically without having to use this key combination every time? Also is ...
Parminder Singh's user avatar
0 votes
3 answers

How do I enable serial access to a computer (not from a computer)?

I have a Linux server (on Desktop hw) running Ubuntu Server (headless). Its tucked away and hard to access, once a year an update or something else create a problem where I can no longer ssh into it. ...
Duxa's user avatar
  • 134
0 votes
0 answers

Minicom showing garbage characters

I am developing a program for an IP camera and when I tried connecting my device's serial console through minicom, I got the following prints. ~ # ls ...
Thilak's user avatar
  • 1
0 votes
0 answers

Why is my USB serial device communication garbled when using minicom and how do I fix it?

I have a Aoetec Z-Stick Zwave device I am playing around with. I am trying to communicate with it using minicom and I have never tried something like this before. I asked about baud rate in a discord ...
Jackie's user avatar
  • 817
1 vote
0 answers

Can’t reboot after using Minicom connected to a SIM7100E modem

I am using a SIM7100E modem made by Qualcomm. It is a multi-band TDD-LTE/FDD-LTE/WCDMA/GSM/GNSS card. Since this modem is capable of going into a state that is not even fixed by a reboot, but requires ...
Salocin's user avatar
  • 121
0 votes
1 answer

Minicom and screen in background

I would like to log serial port output in background. I use screen command for minicom to make sure minicom running on the background when I disconnect my ssh session. This actually works fine, but ...
Krisz's user avatar
  • 111
5 votes
1 answer

Issues establishing a stable Minitel to Raspberry Pi serial port connection

I'm working on repurposing old Minitel into a dumb terminal. But I came across a problem with the serial port connection. As I found out, the serial connection from the Minitel to the Raspberry Pi ...
paddy's user avatar
  • 91
1 vote
1 answer

Default to ANSI Terminal Emulation in Minicom

Is there a way to default to ANSI terminal emulation in minicom instead of VT102 ? Once I'm in minicom, I can press Ctrl+A, T and then toggle using A. This system is restricted to ...
Drew Chapin's user avatar
  • 5,900