Questions tagged [packages]

Typically used in reference to Linux software, a “package” refers to a compressed file archive containing all of the files that come with a particular application.

Filter by
Sorted by
Tagged with
0
votes
1answer
58 views

Unable to update or install packages in Manjaro KDE

I did a fresh install of Manjaro KDE on one of my laptops. I have run Manjaro Xfce before, but I am a rather inexperienced user. I tried to install some of my favorite packages using Pamac 9.2.0-1 ...
0
votes
1answer
36 views

What are com.[username].[api]? and how are they hosted? [closed]

I am trying to learn about API wrappers (still have no clue as to how they are made) and was wondering, if I ever were to make any wrappers for APIs, how would I host them? I have used APIs before ...
0
votes
0answers
24 views

Wxwidgets: Unmet dependencies and broken packages

I am installing wxwigets by following the instruction here. But i get the following here: The following packages have unmet dependencies: libwxgtk-webview3.1unofficial3-dev : Depends: libwxgtk3.1-dev ...
0
votes
0answers
8 views

Package version numbers when using MSBUILD

I'm trying to build package using MSBUILD and used this version number in my customization file:11.0.1.0205 but MSBUILD is throwing this error: error APPX0501: Validation error. error C00CE169: ...
0
votes
0answers
17 views

Cannot installing Swig through conda command

I am currently working with Raspberry Pi 3B using Berryconda. I am intending to install PTSA (Python time series Analysis) into my Raspberry and need swig package first to be installed. I tried so ...
0
votes
0answers
99 views

How to install pandas on Sublime Text 2?

I'm new to programming with Python, and so far it's been a headache to create a build environment- and need your support and expertise in this area. Background I'm running a MacBook, and using ...
0
votes
0answers
6 views

How to point a dependency in a package to an earlier version of another dependency in the same package

I'm trying to enable TLS for my sip server, but it doesn't support openssl 1.1.1. I've built 1.1.0 but I don't know how to point my package (kamailio-tls-modules) to use the manually compiled 1.1.0. ...
0
votes
0answers
10 views

Libraries and Packages, Python and R, old version to new

A computer was formatted. Previously I had Python 2.7 and R installed, and they are working fine in the old set up with all packages and libraries. All related folders were saved as copies. Now I ...
1
vote
0answers
139 views

install sendkeys package on python 3.7.4

im using win10, python 3.7.4 and tried literally every solution on google, im so frustrated. when installing using 'pip install sendkeys' i first got an error saying i need VS14.0, so i installed it ...
2
votes
1answer
69 views

How to install packages to specific versions of Python?

I have multiple versions of Python installed on my system (Mac) according to the VS Code interpreter selector: Python 2.7.1 64-bit in usr/bin/python Python 3.7.4 64-bit ('base': conda) in anaconda3/...
0
votes
2answers
323 views

RStudio: Trouble uploading an Excel file. "No package called 'pkgconfig'

I was able to import an excel spreadsheet into RStudio and work on it while at work, so I decided to email myself the same spreadsheet and work on it at home as well. When I downloaded the excel file ...
0
votes
0answers
17 views

unable to install any package in R studio and R

I cannot install any packages in R studio. Online or from downloaded file on my system. Online, it's a problem of some connectivity. Offline, it gives this message: installation of package ‘C:/...
1
vote
0answers
11 views

How does sudo apt-get remove package_name handle dependencies

I installed smartmontools and it installed alot of stuff with it like a postfix mail server/system. I was wondering how ubuntu handles uninstalles of the "side-tools" and "side-packages" when ...
0
votes
1answer
385 views

Unable to install Tidyverse Package in RStudio

When i try to install Tidyverse package in RStudio im geetting following error and installation gets terminated. Warning in install.packages : unable to access index for repository https://cran....
0
votes
0answers
37 views

Trouble installing R packges

I've installed Cygwin, with R, gcc and some other tools. It all appears fine, however when I try to install R packages (e.g. install.packages("e1071") ) I get the following messages: g++ -std=gnu++11 ...
0
votes
2answers
715 views

How do I make a GitHub repository into an exe?

I know this is going to sound so dumb because I am new into software developing. I have found this GitHub repository which I plan to modify. Let's just say I fork this repository and modify it. How ...
1
vote
0answers
232 views

How to install bzlib.h package without root privilege / yum command to install a software in home directory on remote server

I am trying to install a package that includes "bzlib.h" so that I am able to install the "AmberTools14"/"Amber14" software in my home directory on a remote server, but since I don't have root access, ...
0
votes
0answers
87 views

Emacs relative+current number line

I just switched from vim to emacs :) happily using evil mode and the first problem I have is the lack of (column) relative number functionality. No problem, I found two threads that halfly resolved: ...
1
vote
0answers
22 views

Change directory R looks for packages that are outside conda environment

I am using R in RStudio outside of a conda environment (I have miniconda3 installed to operate QIIME2). However, when I try installing R packages, I am always getting errors as R is always looking in ...
0
votes
0answers
134 views

What is the most elegant way of striping AOSP of its pre-installed packages?

I am trying to gradually stripe AOSP out of its default apps. But I wonder if the method I am going to apply is correct and is the most effective. After looking through ways of doing that I have come ...
0
votes
0answers
63 views

NUXT (production, extractCSS: true) does not remove inline styles of some Vue packages

The styles of some of the plugins (sweet alert, owl carousel) are duplicated inline and in the link tags, despite the inclusion of extractCSS. How can I put all the packages styles into separate ...
0
votes
1answer
131 views

How do I install all dependencies automatically?

For example, I have "winehq-devel_4.12.1_buster_amd64", which requires "wine", which requires "wine-development", and so on. (I mean .deb files here, being installed by Package Manager) How do I ...
0
votes
0answers
104 views

packages have unmet dependencies

I tried to solve this by myself, but failed. Below is what I tried..should I add new link to sources.list file? This is my ubuntu version: Ubuntu 14.04.6 LTS \n \l got error with '_gdbm' Traceback ...
0
votes
0answers
267 views

Why building mongodb from source on arch linux take so long

I wanted to install mongodb on Manjaro.On arch wiki it says that there are two options mongodb - builds from source, requiring 180GB+ free disk space, and may take several hours to build (i.e. 6.5 ...
1
vote
0answers
294 views

Having problems installing R package due to accented username

I am working with RStudio on Windows 10 and trying to install package "hms" with no success. It seems that the problem is with my accented name in the Users account. Here is the error: * installing *...
0
votes
2answers
34 views

Windows PowerShell returns error for “python --version” even though I have it installed

For a very long time I've used python to code. I installed Anaconda and I use Visual Studio Code to write the code. I want to download a new package using pip, and following the "Installing packages" ...
3
votes
1answer
164 views

udunits2 package installation in Docker image

I'm trying to install the R package udunits2/units in a Docker image FROM jupyter/datascience-notebook:abdb27a6dfbb USER root RUN sudo apt-get update RUN sudo apt-get install -y libudunits2-dev RUN ...
0
votes
0answers
141 views

R tidyverse installation errors Ubuntu 16.04

I have installed r-base following the directions from DigitalOcean. I have installed several other packages, and I have installed libcurl4-openssl-dev, libxml2-dev, and libssl-dev as per other ...
0
votes
1answer
25 views

Atom apm show package config information

I am currently trying to set up Atom's linter-eslint as per instructions here. Whilst the tutorial cites a settings page for the linter-eslint I receive no such thing. Perhaps all the config is no ...
0
votes
0answers
64 views

Cassandra Cluster Manager: ccm start doesn't work. ValueError: invalid literal for int() with base 10: ''

I'm trying to set up Cassandra using ccm, but I can't get it to run. After creating a cluster and a node, ccm start command should do it, but I'm getting ValueError: invalid literal for int() with ...
0
votes
0answers
26 views

Pycharm 2019 issues with Django server & project interpreter

So I have set up a virtual environment and linked the project interpreter in Pycharm to this environment. Everything seems to be working fine with the installed packages until I start the Django ...
0
votes
0answers
43 views

User key binding for packages in Sublime 3

I'm using OS X. At the moment I cannot determine whether it is possible to add user key bindings to packages added to Sublime Text 3. I'm trying to add a user key binding to an action in a package I ...
0
votes
0answers
135 views

Installing a python package in Jupyter Notebook

I was trying to install a package on Python. I successfully installed the package on Windows terminal using the following: python -m pip install import_ipynb However, when I tried to import the ...
0
votes
0answers
19 views

R packages not compiled?

I'm trying to use the VIP function in the plsVarSel in R. > sessionInfo() R version 3.4.4 (2018-03-15) Platform: x86_64-w64-mingw32/x64 (64-bit) Running under: Windows 10 x64 (build 16299) ...
0
votes
0answers
28 views

Idea cannot resolve java.sql.* symbol,notice cannot import

The idea cannot resolve java.sql symboles, below is the problem I find. I install jdk with 1.8.0_181. I have already tried using the following actions: file->invalidate cache /restart, but the ...
0
votes
0answers
53 views

Impossible to load a package in R no ZIP file found

I'm trying to load the AFEX package in R and I get the following message: install.packages("afex") Installing package into ‘C:/Users/antonin.ricard/Documents/R/win-library/3.6’ (as ‘lib’ is ...
0
votes
0answers
13 views

Pip package creation - __init__.py can't find local file to import

When I run the __init__.py with python3 locally, it successfully imports "other" import other But when I download it on another computer through pip install sql_panda_wrapper --upgrade importing ...
0
votes
0answers
336 views

Warning in install.packages : installation of package ‘processx’ had non-zero exit status

I try to install devtools but I always receive this error: Error : package or namespace load failed for ‘devtools’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]): ...
0
votes
0answers
7 views

Installing “lme4” in Pycharm

I'm trying to install "lme4" to Pycharm. I've gone to R Packages and couldn't find it there. I added https://github.com/lme4/lme4 to the repository list but still can't find it. What am I doing wrong?
1
vote
0answers
59 views

Trying to write haskell in emacs but not working, get error 'The Haskell process 'haskell' has died. Restart?"

Trying to write haskell in emacs but not working, get error 'The Haskell process 'haskell' has died. Restart?" I installed the packages for haskell but somehow the code cannot be complied. Can someone ...
1
vote
1answer
100 views

Can no longer login after update - Failed to start Service for snap application quassel-kalikiana.core

After updating my Manjaro GNOME edition last night I come to login this morning and I'm presented with an error screen before the select user option even shows and gives me a logout button. When ...
1
vote
0answers
145 views

Is there a way to fix these Mesa dependecy issues?

sudo apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 11 not fully ...
0
votes
1answer
204 views

yay update error failed to prepare transaction, breaks dependency

When I want to update my system I get shown :: 2 Packages to upgrade. 2 aur/jdk 11.0.2-1 -> 12-1 1 aur/jre 11.0.2-1 -> 12-1 [...] ==> Making package: jre 12-1 (Sat 13 Apr 2019 03:25:...
0
votes
0answers
112 views

archlinux makepkg does not follow my Directory path settings

Background (Optional) I am new to archlinux. I am using SysRescueCd to boot up and trying to install Gentoo Linux with ZFS. I know Fearedbliss has made a patched version of SysRescueCd with the ZFS ...
0
votes
0answers
21 views

How to determine easily the dependancies between list of packages

Example on Fedora 29: When I would like to install Xorg server + GNOME without extra packages I have determined this list of packages to install: yum install xorg-x11-server-Xorg \ ...
0
votes
0answers
157 views

Install mysqlclient on CentOS 7 without root access

I am on CentOS 7 and dont have root access. Is it possible to install mysqlclient on the machine ? Please help.
0
votes
1answer
34 views

How to install package control for Sublime Text 3

How can I install package control to Sublime Text 3 ? As notted it says Open the Sublime Text 2 console by pressing Ctrl+`. But when I type ctrl+` it writes ` How can I do this ? Thanks
0
votes
1answer
100 views

SublimeText plugin_host crashes when I load a PHP file

After I updated to the last version of SublimeText3 (build 3176) the plugin_host started to crash every time that I select a tab with a PHP file. plugin_host has exited unexpectedly, plugin ...
0
votes
0answers
19 views

Python packages installed but only can import on Jupyter notebook not on terminal

I have python packages that are installed on my computer and they can be imported using Jupyter notebook. However, when I try to run separate .py script on terminal, I get ModuleNotFoundError. When I ...
2
votes
1answer
8k views

Command “python setup.py egg_info” failed with error code 1 in /private/tmp/pip-install-xkffs1ax/word2vec/

I'm trying to install word2vec, but I keep on getting this error when I run pip install word2vec Collecting word2vec Using cached https://files.pythonhosted.org/packages/98/9c/...

1 2 3 4 5 7