Questions tagged [pecl]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
1answer
568 views

How to Install PHP-7.3 pecl packages in Amazon Linux 2018.03?

Upgrading PHP v5.4 to v7.3 in the Amazon Linux AMI VERSION="2018.03". I am unable to install these following PECL packages to PHP v7.3 as they are not found in the AVAILABLE packages list in the ...
0
votes
0answers
144 views

Installing mcrypt extension on php 7.3.x via pecl/pear

Im trying to get the mcrypt extension on php 7.3 running via pecl. Currently only on php version 7.3. I get the following error which basically forces me to install php7.2-dev. Is there any ...
0
votes
0answers
268 views

Make failed for PECL install ssh2 on Ubuntu 14.04

I'm running Ubuntu 14.04 and want install ssh2 module for php 7 using this command : pecl install -f https://pecl.php.net/get/ssh2-1.1.2.tgz I've got this return : downloading ssh2-1.1.2.tgz ... ...
0
votes
0answers
913 views

Install PHP-IMAP on PHP 7.3 and enabling APCu

I am trying to install IMAP-PHP and APCu on my Mac, but I incurred in a problem that is blocking me. I've installed PHP with: brew install php and now che command php -v returns: PHP 7.3.2 (cli) (...
1
vote
1answer
364 views

Install php trader on mac os

I am trying to install on my MAC the trader modul from PHP. I am running on PHP 7.1 Here my error: sudo pecl install trader Warning: Invalid argument supplied for foreach() in Downloader.php on ...
0
votes
1answer
291 views

Pecl error when installing php71 on Centos6.9 by yum, remi repo

I got package related error like this. Error: Package: php-pecl-xhprof-0.9.4-4.el6.remi.5.6.x86_64 I guess it is related with dependency about pecl though... can't figure out. I use to use php56 ...
0
votes
2answers
2k views

Need uploadprogress in Debian 9 / php 7

For a drupal installation on debian 9, I want to install php pecl uploadprogress. In Ubuntu there's an easy way with ondrej's ppa, but I can't find anything on how to get it to work in Debian. For ...
2
votes
2answers
961 views

How can I idempotently pecl install a module twice?

I have a bash script which should be re-runnable. It includes pecl install foo || { echo "Could not install foo!"; exit 1; } If this runs twice, it errors pecl/foo is already installed and ...
3
votes
0answers
1k views

FreeBSD install PECL php7

I want to active the gnupg extension for php7. But I can't find a package for pecl for php7. Does anyone know a way to install pecl for php7 or how to activate gnupg without pecl?
1
vote
0answers
2k views

Unable to install php mongodb driver on Ubuntu 14.04 LTS

I have been trying to install php driver for mongodb on Ubuntu Linux 14.04 LTS. Tried to install as follows : sudo pecl install mongodb output is No releases available for package "pecl.php.net/...
1
vote
2answers
1k views

PHP PECL Sphinx module won't install

I'm trying to install the PHP Sphinx client (PHP 5.6) on my Debian 7 server using PECL. I get the misleading error "wrong libsphinxclient version or lib not found" when trying to build, even though I'...
0
votes
1answer
495 views

Cannot install PECL ev package(OS X Yosemite)

I am trying for an hour already to install the g..amn ev package so I can use EvTimer in php but with no success. I am running sudo pecl install ev in terminal but I get the following error. /bin/sh /...
1
vote
2answers
2k views

PECL SSH2 Installation issue

I am running this command: sudo pecl install ssh2 It resulting the following log and exit with an error: libssh2 prefix? [autodetect] : building in /var/tmp/pear-build-rootHyRX5L/ssh2-0.12 running: ...
3
votes
3answers
6k views

Bash script to run “pecl install oci8”

I am trying to create shell script that will do the initial provisioning of a vagrant vm (running Ubuntu 12.04). Everything (installing php, apache, oracle instantclient, etc,) works fine, except for ...
4
votes
3answers
12k views

How do you install PHP PECL extensions with Macports?

I'm using PHP 5.5 installed through Macports. I'd like to add the APCu PECL library. But there's no macports package and I can't see a way to install the PEAR/PECL command line utility. So how does ...
0
votes
1answer
1k views

Installing libevent via PECL fails on Ubuntu 12.04

I have Ubuntu 12.04 built with Moodle Stack installed. I'm trying to install this: $ sudo pecl install libevent I get this error: Failed to download pecl/libevent within preferred state "stable", ...
0
votes
1answer
101 views

How do I clone a PECL SVN repository?

I'm trying to clone the PECL OAuth repo, but clicking on "SVN Instructions" in the top-right corner leads to instructions on how to clone the Github repo for PHP itself... Does any of the elders know ...
2
votes
3answers
4k views

Can't link Xdebug to PHP 5.4

Today I installed/updated my previous php 5.3.x to 5.4.11. Did it accordingly how do I upgrade from php 5.3 to php 5.4.6 in ubuntu? Install was successful, but it seemed to me, that xdebug was ...
2
votes
4answers
5k views

PECL install error after upgrading to OSX 10.8

I've just upgraded my OS to Mountain Lion and PECL is no longer working (it's on a test drive so no drama, but I'd like to get it working so I can upgrade the OS on my shiny new SSD as well). I'm ...
1
vote
0answers
493 views

Ultimately installing a PECL extension but need a new version of libtool > 2.2

What's my end game : installing SSPLUS, a PCEL extension My config : A virtuozzo server running Linux 2.6.18-028stab069.6 (Debian Lenny ??) What I've done : 1 pear install spplus Deprecated: ...
2
votes
1answer
2k views

Installing xdebug on Mac OS X Lion 10.7.2 using pecl

Im trying to get the xdebug environment up and running om my mac os x lion box using pecl. I got the latest version of xcode installed and linked the binaries sudo ln -s /Developer/usr/bin/autoconf /...
3
votes
2answers
693 views

Installing python through pecl - how do I “specify path to Python distribution files”?

I have found several instances where this question has been asked, but never answered. This is the part where the installation goes wrong checking for Python files in default path... not found ...
13
votes
5answers
45k views

How to install PHP, Pear, PECL, and APC with Homebrew on Mac OS X?

I'm trying to install APC for PHP 5.3 in the easiest way possible. I love Homebrew so I started down that route. I was able to install PHP 5.3.6 with this command: brew install https://github.com/...
2
votes
2answers
4k views

php pecl install mac os x 10.6

Does anyone know how to install pecl for mac os x 10.6. I have tried googling with no luck.
1
vote
1answer
5k views

How to install Imagick on Mac OS with XAMPP

I'm having some trouble installing Imagick on a Mac. I have XAMPP installed and when I run sudo pecl install imagick, I get this error: checking ImageMagick MagickWand API configuration program... ...
2
votes
1answer
1k views

php's pecl - oauth - Mac OS X 10.6.6

I'm trying to install a php extension through pecl and I'm getting some weird errors... any ideas? wcmisdpilotpc1:~ alexus$ sudo pecl install oauth Password: Notice: Array to string conversion in ...
0
votes
1answer
3k views

PHP: libssh2 prefix on Ubuntu 9.10?

So I decided to install the libssh2 library using PECL. I'm at the point where it is asking me to specify a libssh2 prefix: 5 source files, building running: phpize Configuring for: PHP Api Version: ...