Questions tagged [pip]

pip is a tool for installing and managing Python packages

Filter by
Sorted by
Tagged with
1
vote
0answers
55 views

Errors with pip3 and apt after upgrading python and Anaconda (Debian 9)

In order to install PyMC3, I installed Python 3.8 from the official repository without realize that I already had Anaconda2 (with python 3.6). Python 3.8 worked fine but I wasn't able to make it ...
0
votes
0answers
15 views

Network issues with pip

I'm trying to get pip working behind my companies proxy network. Here is the pip verbose log: C:\Users\<Username>>pip install -v numpy Created temporary directory: C:\Users\<Username>\...
0
votes
0answers
10 views

Adding pip, pip3, pip3.7 to PATH [duplicate]

Hi after the installation, I got this warning: The scripts pip, pip3 and pip3.7 are installed in '/Users/stevetsang/Library/Python/3.7/bin' which is not on PATH. Consider adding this directory to ...
0
votes
1answer
1k views

pip not found fresh Kali Linux installed

My Fresh kali Linux install doesn't find pip and so i can't run my scripts. So here is what i tried: kali# pip -V Command not found kali# whereis pip pip: kali# locate pip | grep /usr/bin /usr/bin/...
1
vote
3answers
4k views

Ubuntu 20.04: E: Unable to locate package python-pip

I have just installed Ubuntu 20.04 and I have come across an issue when trying to install pip. On my older machines running 18.04, the command ran fine and installed the package. However, when ...
0
votes
0answers
71 views

i get unmet dependencies while installing python3-pip in ubuntu 18.04 LTS

i am getting unmet dependencies while installing python3-pip in ubuntu 18.04 LTS nv@nv-Lenovo-ideapad-320-15IAP:~$ sudo apt-get install python3-pip Reading package lists... Done Building dependency ...
0
votes
0answers
34 views

Installing pycrypto on windows (popular solution not working)

This is a traight up copy of my question from here. I got a comment recommending posting it here as well since it is more of an environment thing. I need to install pycrypto for a project that ...
2
votes
1answer
3k views

How to fix “Permission Denied” in Git Bash in Windows 10?

Whenever I tried to run this command: python get-pip.py, git bash gave me this response: bash: /c/Users/Sergio Ley/AppData/Local/Microsoft/WindowsApps/python: Permission denied. I don't know how to ...
1
vote
1answer
47 views

Installing python3-pip to WSL Ubuntu 18.04 from Powershell

Scenario In an automated installation procedure I am trying to install python3-pip. However during the manual installation of the package installer pip, I got a purple screen prompting me for a ...
0
votes
2answers
1k views

How to install python packages with all dependencies offline via pip3?

first of all I have managed to install Ansible on a server which has no internet access. But I wonder if my approach is correct. At first I downloaded the necessary dependencies via pip3. pip3 ...
1
vote
0answers
300 views

PyCairo Install: Cannot open include file: 'cairo.h': No such file or directory

I'm trying desperately to install PyCairo for use in the JetBrains PyCharm IDE and no matter what I try I keep getting this error when I try to use pip to install PyCairo: C:\Users\Jack\AppData\Local\...
0
votes
1answer
43 views

Pip: installing a newer module version with `--user` option

Scenario: A python package abc is installed as a system package e.g. to /usr/lib or /usr/local/... (either as sudo pip install abc or via the system package manager). A higher version of the abc ...
0
votes
0answers
21 views

Pip and Python version conflicts

I had to reinstall Ubuntu 19.10. While reconfiguring my system for Python development, I had a problem. I have 3 different pip versions: $ which pip /home/d7v7loper/.local/bin/pip $ which pip2 /usr/...
1
vote
1answer
4k views

Fixing site-packages permission for pip/python

I have a new Macbook - a user installed it, and then I installed a new user (mine), granted admin privileges and deleted the old one. I am on OS Catalina. Since the installation I've been having ...
1
vote
1answer
79 views

pip3 cannot install packages - cannot find a version on embedded system

I'm running python pip3 on TinkerOS (for Asus embedded computer Tinkerboard). TinkerOS is based on Debian. linaro@chione:~$ uname -a Linux chione 4.4.132+ #1 SMP Tue Oct 23 18:03:49 CST 2018 armv7l ...
0
votes
1answer
113 views

What is the difference among pip.exe, pip3.exe and pip3.8.exe?

I found these three in C:\Program Files (x86)\Python38-32\Scripts What is the difference among them? pip files
0
votes
0answers
34 views

How to fix pipenv shell so it activates venv?

I'm running WSL2 Ubuntu 18.04 When I run pipenv shell the venv does not activate and I need to manually activate it (using the command it shows that it is trying to run): davidg@AERC-PCD-088:~/temp$ ...
1
vote
1answer
1k views

why pip install turtle (graphics) error

I get the following error when installing turtle, what should I do? $ sudo pip install turtle --proxy http://10.144.1.10:8080 WARNING: Running pip install with root privileges is generally not a good ...
0
votes
0answers
67 views

pip3 not working after reinstall

I have recently reinstalled python3 on my Ubuntu Xenial Gnome system using apt. I also installed python3-pip. However, now pip3 no longer works. Attempting to run pip3 gives a strange error: bash: /...
0
votes
0answers
32 views

How can I block pip and python user packages

I'm trying to prevent users from using pip to install packages in their home directories. The output from python3 -m site --help would indicate that it is possible for a super user to disable the ...
0
votes
0answers
6 views

Cannot install python packages using pip on Ubuntu 16.04 using wired LAN connection

I seem to be the only one facing this problem, all others don't have a problem installing the packages even using our wired LAN connection, pip works well when I use a wireless wifi. Is there any ...
2
votes
1answer
42 views

Adding a path to login.conf in Bash / FreeBSD

Due to the fact that freebsd pkg repos (binary) do not come with support for lame mp3, and I don't want to complicate things by having a dual dependency tree, I'm attempting a workaround by installing ...
0
votes
0answers
329 views

Can't use pip anymore

In my anaconda environment I can't use pip anymore (roo_env) (base) C:\Users\antoi\Documents\Programming\roomfinder>pip install csvkit Traceback (most recent call last): File "C:\ProgramData\...
0
votes
0answers
67 views

Error occurs when I try to install sklearn by pip

Version info: python: 3.8 scipy: 1.3.2 numpy: 1.17.4 Details: It works well when I install other libs; however, it throws the below error message when I install sklearn by pip or pip3. Error ...
0
votes
1answer
654 views

Can't install some specific packages for python using pip

Below is for pygame, but I get similar error in tensorflow, matplotlab, email etc... C:\Users\Deep Raval>pip install pygame Collecting pygame Using cached https://files.pythonhosted.org/packages/...
0
votes
0answers
55 views

Remove pip packages from Ubuntu 16.04

How do I remove all packages installed in ubuntu 16.04 using pip or any other method? And how do I remove all installed python and start with beginning?
0
votes
0answers
22 views

Destroyed python set up on OSX

I upgraded Homebrew and my python virtualenvs didn't work. I went through a bunch of fixes from here, including: Uninstalling/reinstalling Python via homebrew Changing my PATH (a few times) ...
0
votes
1answer
61 views

Issue installing SciPy

I am trying to install Scipy to run on Jupyter (in VirtualBox Ubuntu OS, Windows Host). I type the following command and get errors. How can I fix it? python -m pip install --user numpy scipy ...
1
vote
2answers
2k views

Can't install anything on pip

Everytime I try to install anything on pip it ends with following error message. The package setup script has attempted to modify files on your system that are not within the EasyInstall build area, ...
1
vote
2answers
3k views

Upgrade pip to newest version on Ubuntu 16.04

I'm trying to upgrade pip into the newest version (old version 9.0.1 and newest version 19.3.1. using the following commands. pip install --upgrade pip sudo apt-get upgrade pip But it won't ...
0
votes
0answers
196 views

difficulty installing tensorflow using requirements.txt and 'pipenv install'

I am having difficulty installing and using tensorflow with pipenv install. I am running Ubuntu (16.04.6 LTS). At the end of my ~/.bashrc I have the following: export PATH="/home/nw/.pyenv/bin:$PATH" ...
0
votes
0answers
225 views

Having problems trying to install pygame

I have tried a countless amount of tutorials yet whenever I try to install Pyame I end up with the error message: ERROR: Command errored out with exit status 1: command: 'c:\python\python38\...
0
votes
0answers
364 views

Pip not working

My problem is pip install [module] gives me this error Traceback (most recent call last): File "c:\program files (x86)\python37-32\lib\runpy.py", line 193, in _run_module_as_main "__main__", ...
0
votes
1answer
272 views

ValueError: invalid literal for int() with base 10 when trying to install pip

I've had this error with pip for a day or two now. Originally, I thought it was a problem with pip itself, because it would error out and fail whenever I tried to install a package. So, I uninstalled ...
0
votes
1answer
6k views

pip and pip3 does not work on ubuntu 18.04 TypeError: 'module' object is not callable

I have this issue with pip & pip3, reinstalling them did not solveenter code here hp@hp-desktop:~$ python3.6 -V Python 3.6.8 hp@hp-desktop:~$ python3 -V Python 3.5.2 hp@hp-desktop:~$ python -V ...
-1
votes
1answer
162 views

Tried to install airflow 1.10.3 in airflow, but airflow 1.10.5 is installed

I am using pip install apache-airflow[1.10.3], but apache-airflow-1.10.5 is installed. Log is below, it says apache-airflow-1.10.5 is installed: Successfully installed Babel-2.7.0 Flask-Babel-0.12....
0
votes
0answers
105 views

Unable to open jupyter notebook and pip install through Gitbash on Windows

I recently realized I am no longer able to open jupyter notebook through my gitbash anymore. When I just to open jupyter notebook I get the code bash: jupyter: command not found. I've also tried ...
1
vote
1answer
5k views

I've been trying to install pygame, but i keep getting this error:

ERROR: Command errored out with exit status 1: command: 'c:\users\pichau\appdata\local\programs\python\python38\python.exe' -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\Pichau\\...
0
votes
1answer
201 views

“cannot import name IncompleteRead” error when running pip

When I install python-pip it shows it is install allready installed, but when I am using pip command, below error shows: Traceback (most recent call last): File "/usr/bin/pip", line 9, in <...
0
votes
1answer
103 views

Error during installation of pip on win10

i've run into some problems while trying to install pip on win10, I can't understand from where it's coming from, here's what the error looks like: I run the command python get-pip.py --prefix=/usr/...
0
votes
2answers
737 views

Error with gcc installing psutil (and it's dependants) with pip

I'm trying to install Apache Airflow, using pip. In the process of doing that, it tries to install psutil, and gets a gcc error. If I try to install psutil separately, it still gets the same error. ...
0
votes
0answers
67 views

pip install in a different directory

I'm installing pip on my leptop, also I just install anaconda for other uses. When I run a script I have this error: ModuleNotFoundError: No module named 'sacred' For that I just installed the ...
1
vote
0answers
547 views

Error while installing Box2D Python package

I am trying to install OpenAI's Gym in Windows 10, according to this article. I followed most of the steps without problems. However, at the step for installing Box2D with pip, I get the errors below....
0
votes
0answers
234 views

Trouble updating pip: “Requirement already up-to-date”

I'm trying to upgrade pip, following the suggestions from pip after another module's installation failed. pip install -U pip Requirement already up-to-date: pip in ./anaconda/lib/python3.4/site-...
0
votes
1answer
118 views

Permission Denied - RIDE

Unable to save files in ride 1.7.3.1. Getting "Error in serializing. Permission Denied". Installed ride using the command "pip install robotframework-ride".
0
votes
0answers
6 views

Why does my python or pip exhibit odd behavior?

Recently, I upgraded my python from python version 3.4 to 3.5 so I can install tensorflow, as directed by the package requirements. Prior to the upgrade, the pip package manager claimed that it ...
2
votes
1answer
222 views

Why does venv Python interpreter say “no module named __” when pip freeze & reinstalling indicates the module is installed?

I'm using venv for Python programming for the first time; so I'm assuming my difficulties are coming from that. I've followed these instructions to create my virtual environment; which seemed to work ...
0
votes
0answers
321 views

PIP is not working on my Rasberry Pi (Raspbian), raises ssl-Errors

When I try to install python packages with pip on my Raspberry-Pi (running Raspbian Buster), I get the following error: pip install opencv-python (same for every other package) Looking in indexes: ...
0
votes
0answers
139 views

MacOS Mojave system python2.7 does not have working pip

I don't usually use the system python, but was uninstalling and reinstalling Python 3.7 when I noticed this error. Traceback (most recent call last): File "/usr/local/bin/pip", line 6, in <...
0
votes
0answers
10 views

pip is not correctly installing many packages (no error messages)

I have tried installing several packages with pip. The command will finish running without error but the package won't show up (e.g., when I type '''which x'''). When I uninstall the package, it does ...

1
2 3 4 5 6