Questions tagged [zypper]

Zypper is the native command line interface of the ZYpp package manager for installing, removing, updating and querying software packages of local or remote (networked) media.

Filter by
Sorted by
Tagged with
1
vote
1answer
101 views

Sometimes zypper doesn't locate packages when it is provided with the filename only

If the command is provided the full path, the expected package is found: > zypper search --provides --match-exact /usr/sbin/update-ca-certificates Loading repository data... Reading installed ...
0
votes
1answer
73 views

Match wildcard during zypper remove?

I'm trying to remove an old kernel from openSUSE. The openSUSE version is Tumbleweed (20191128), and the old kernel is 5.1.16. The manpage for Zypper is here. It looks like Zypper supports wildcards (...
0
votes
0answers
58 views

How to Install dotnet-sdk-2.2 Non-Interactive in SUSE Linux 64

I am trying to run #sudo zypper --gpg-auto-import-keys -n install dotnet-sdk-2.2 The command exits with the follwing message: Problem: nothing provides libopenssl1_1 needed by dotnet-runtime-deps-2....
1
vote
1answer
23 views

SLES 11.3 zypper over local repository has missing packages

SLES 11.3 zypper over local repository has missing packages Trying to install Apache Ambari over SLES 11.3, I downloaded a full repo tarball. Then I created a local repository over the uncompresed ...
0
votes
0answers
598 views

Troubles with root partition running full

When I originally installed my opensuse-leap distro (42.1), I took the recommended size for the root partition, which was 40gb. At the meantime I upgraded to 42.2 (Plasma 5.8.6) and today, when I was ...
1
vote
1answer
385 views

Unable to install MongoDB on LEAP 42.2 (AArch64)

Good morning! I'm playing with my Raspberry Pi 3 Model B version 2 with openSUSE LEAP 42.2 version (AArch64) in order to install an updated MongoDB version. The problem is that I'm following the ...
0
votes
1answer
486 views

RPM encrypt/decrypt with YUM / Zypper

I´d like to create a repository with encrypted RPM Packages. The Host get´s the GPG Key for decryption. If there a way to "auto decrypt" the packes with yum / zypper ?
0
votes
1answer
347 views

zypper equivalent to yum groupupdate?

Is there an equivalent command? Tried the obvious: $ zypper update -t pattern <pattern name> Warning: The /etc/products.d/baseproduct symlink is dangling or missing! The link must point to ...
0
votes
1answer
1k views

zypper or yast unable to install third-party RPM from local repository

I am using a SLES11 SP4 machine, and trying to install an RPM from local yum repository. All other RPMs which are provided by SUSE and copied in my local repository installs fine like mysql, samba etc....
2
votes
2answers
8k views

How to mount 3 ISO images as repos in SLES using zypper

I'm wanting to mount the three ISO disks of the SLES11SP3 OS onto my system, as we have a minimal installation and we need to zypper install some additional packages. zypper addrepo iso:/?iso=/path/...
2
votes
1answer
2k views

SUSE SLES 11: zypper: Ignore dependency in scripted setup

I have an issue here, trying to install libopenssl-devel on a SuSE box. The installation is purely from DVD (no online updates involved). $ sudo zypper install libopenssl-devel Loading repository ...
1
vote
2answers
180 views

Error to remove openSUSE repository

I'm using OpenSUSE Leap with Gnome I trying remove a repository to fix a error, but haven't had any success When I type sudo zypper ls is returning for me: sudo zypper ls # | Alias | Name | ...
1
vote
1answer
416 views

How to add this repo to yast in openSUSE?

Following these instructions I'm trying to build the sync client for owncloud. Since building the client installer for Windows is only officially supported on openSUSE I installed openSUSE in ...
1
vote
0answers
88 views

Broken dependencies when upgrading SLES 11.3 to 11.4

I'm trying to upgrade SLES 11.3 to 11.4 with zypper using the following instructions: https://www.suse.com/documentation/sles11/book_sle_deployment/data/sec_update_sle11sp3.html After launching the ...
1
vote
1answer
202 views

How to determine OpenSUSE package maintainer?

According to the Zypper Cheat Sheet, we can use zypper info to get package information. Unfortunately, I am not getting results back when using it: > zypper info cryptopp Loading repository data......
0
votes
1answer
3k views

Reinstall KDE from scratch on OpenSUSE

I have installed KDE 5 a while ago after KDE 4. It just broke. So, I am tired of trying to fix the situation here, and I just want to start over from scratch. What I want to do is: Uninstall All Qt ...
13
votes
1answer
29k views

zypper: How to list different available versions of a package?

I want to get a list of all available versions of a package, the same list that you can see in Yast, but using zypper. OpenSuse 13.1, zypper 1.9.16
2
votes
1answer
2k views

Can't uninstall or upgrade git

I'm on openSUSE ver 12.2. My git seems to be installed in /usr/lib. rnx@linux-sh2d2:~> git --version git version 1.7.10.4 rnx@linux-sh2d2:~> which git /usr/bin/git rnx@linux-sh2d2:~> cd /...
1
vote
2answers
10k views

Zypper on Ubuntu

I'm trying to install packages using zypper but Amazon server that runs Ubuntu seems not to have zypper installed. How can I install zypper? code: zypper install git gcc gcc-c++ error: > ...
4
votes
2answers
10k views

Zypper: How to list installed packages that are not in a repo

In a system using Zypper for package management (openSuse, in my case) how can one get a list of all installed packages that are not associated with a currently enabled repository? Real problem: When ...
0
votes
1answer
143 views

zypper always install devel packages

Is there an option to force zypper to always install the ${PKG}-devel packages to the packages I install via zypper in $PKG, maybe in a config or cmd? I did not see any but would love to be able to ...
2
votes
0answers
652 views

Error in repository initialization

I am running opensuse 12.1. When I start up YaST software manager I get an error: There was an error in the repository initialization. Error refreshing service Synergy (http://synergy-foss.org/pm/...
0
votes
0answers
170 views

zypper always going to background. How to restore stdin?

I'm upgrading 11.4 to 12.1. What's annoying in zypper dup is that after about a minute it goes background. Output to console is still active, but I lose the ability to do stdin. A message appears ...
1
vote
1answer
3k views

How to install Erlang and RabbitMQ on OpenSUSE 11

I'm still very new to OpenSUSE , and I'm trying to install erlang then rabbitmq with the package manager but it's not working , like when I do : > zypper install erlang Refreshing service '...
0
votes
2answers
175 views

Can't update opensuse from 11.4 to 12.1 because of lack of space in /var

I'm trying to update opensuse from 11.4 to 12.1. Needable size of download is more than 1.0 GB, but my filesystem /var is precisely 1.0 GB, that's why zypper stops while downloading .rpm packages ...
5
votes
3answers
5k views

Am I using 'zypper' correctly?

I'm a relatively new OpenSuse user, coming from several years with Ubuntu. In Ubuntu, the update manager would pop up every now and then and let me know when I had stuff to install. If I manually ...
0
votes
1answer
713 views

OpenSuse zypper is slow on startup

Whenever I open the terminal to install something from the repositories, it takes like 1 minute to 'build' them and all that junk. I recently switched from Ubuntu and apt never had this issue. What ...
23
votes
2answers
27k views

Zypper: How do I display all packages from a certain repository?

Please tell me, how to let zypper display all installed packages of a certain repository.