Hot answers tagged

105

Just delete it: ip link del docker0 (The old way, specific to bridges: brctl delbr docker0)


38

I am appalled at the misinformation in the accepted answer. While I have no experience with the ActionTec P5001a, I do have experience with half a dozen similar devices, and they all work the same way when in bridged mode. When it's in bridge mode it has no web interface, no IP. Wrong. It has the same default IP address (192.168.0.1) and the same web ...


12

Wi-Fi cannot be bridged to Ethernet. This is not a Windows limitation in any way. There’s a good explanation on why that is in the old OpenWrt wiki. Instead, you should use Internet Connection Sharing (ie. make your PC a router): Go to the Network Connections control panel (where you’re currently trying to create the bridge) Open your Wi-Fi connection’s ...


11

This cannot be done. You cannot bridge a WiFi client connection. If you could, we wouldn't need WDS, we'd just bridge. The problem is very simple -- an access point is prohibited by the WiFi specifaction from broadcasting traffic over the WiFi network unless something authorizes that transmission. This is largely a relic from the days when WiFi networks ...


11

Bridges made easy: There is a project on sourceforge made just for your situation. http://sourceforge.net/projects/bridger/ It even comes as a deb package. With regard to 'dropping' packets: Did you check to see if iptables is set to default drop? sudo iptables --list should say "ACCEPT, ACCEPT, ACCEPT" for a box of this type. If that's the issue turn ...


11

In Windows it's a bit messy. What you want to do is to use VBoxManage.exe list bridgedifs to list the possible bridge interface names (the actual names are device names, not connection names which you see in ipconfig output) VBoxManage is probably not in your %PATH% but you can find it in Virtualbox's dir. You also can just copy the device name from ...


9

Managed to find my GUI in new address: http://192.168.100.1 (original was 192.168.0.1 before bridged mode) logged in and turned it back to router mode and after waiting it to reset Clicked network Internet access logo on desktop and there troubleshoot problems. this video helped me: https://www.youtube.com/watch?v=C-0VhTXxHS8


9

You can try to add the adapter: 1 to the config. Although I still find some problem with it. See if it will help you starts from somewhere. Example: config.vm.network "public_network", bridge: "Broadcom BCM5709C", adapter: "1", ip: "192.168.x.xx" You will still have the eth1 which is host-only network...


8

In case of Arris routers (such as the DG1670) when in bridged mode the UI is available at: http://192.168.100.1:8080/


7

I’ve just spent a while trying to figure this out as well. Apparently, bridged mode is not working between host and guest in recent releases of VirtualBox 5 according to this ticket (#14457): In reference to this forum post: https://forums.virtualbox.org/viewtopic.php?f=6&t=69597 after upgrading to VirtualBox 5.0.x I could no longer ping ...


6

I had the same problem setting up openvpn over wifi on my raspberrypi. It turned out, that the flaw was wpa-roam. The wlan0 section in /etc/network/interfaces had to be changed to: allow-hotplug wlan0 iface wlan0 inet dhcp wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf The important part was replacing wpa-roam by wpa-conf. Background In my /var/log/...


6

This is that simple: hostapd adds your interface to the bridge specified by bridge= after it has turned wlan0 in AP mode. Adding your interface in a bridge before hostapd is running is not possible, because your interface is still in the default managed mode. Don't tell ifupdown (via /etc/network/interfaces) to add wlan0 to your bridge and let hostapd do it ...


6

I have some wireless bridges working on Debian Linux and Openwrt, so I am very familiar with this issue. You missed one important command: You forgot to tell your wireless driver to transmit 4-address frames (sometimes improperly/historically called WDS), which is required for 802.11/wireless bridging. Do this with the command "iw dev wlan0 set 4addr on". ...


6

I ran into this issue when switching the internet connection on my Linksys WRT1900ACS from DSL to a mobile hotspot. I'm bridging through the 5 Ghz radio and serving clients through the 2.4 Ghz side. The Linksys has much better WiFi coverage than the hotspot and also supports 4 wired GB devices. I can still connect WiFi directly to the hotspot from devices in ...


6

It looks like the Archer C7 makes it easy to disable the DHCP server, but there's no way to to make the WAN port act like one of the LAN ports (that is, switch off all firewall/router/NAT gateway features, making it just a bridge). So you'll have to disable the C7's DHCP service, set its LAN port to have an IP address on the NAT private IP subnet that your ...


6

The solution was almost like Wireless Ethernet Bridge, except that Wireless Ethernet Bridge sets up the LinkSys Wifi as a "client" - ie. other devices can't connect to the Wifi on the LinkSys. (This is not obvious in the GUI, as the client/hosting wifi modes look identical). Instead, I did this: Set Administration > Password to something secure. ...


6

The MAC address is randomized if you do not explicitly set it in your bridge configuration in Netplan. If I recall correctly, Hetzner restricts the IP address you are allocated to your server's MAC address, so you may need to set the bridge's MAC address to the physical interface's. To get the physical interface's MAC address, run this command: cat /sys/...


5

You just need a different management IP on the LAN side of the TPLink. The IP needs to be different from your Alcatel and not in the DHCP range. So on the TPLink assign a LAN IP of 192.168.1.2 for example and disable DHCP. That should get you going according to the documentation below. From what you described above you have an IP conflict with 192.168.1....


5

No. Adding an additional layers do not make the insecure hops go away. If you want to secure your connection over something like an insecure wifi or dodgey hotel network you need something like a VPN connection to a server you trust to funnel your traffic through.


5

When configured for active WDS, all transmissions made to the other endpoint are done in 4-address mode. A side configured for active WDS can make the first transmission or it can wait for the other side to contact it first. When passive WDS mode is used, the device cannot make the initial contact. But when the other side contacts it, if the other side uses ...


5

Bridged mode doesn't do what you think it does: It provides a bridge between a wireless network (where it acts as a client) and wired network (via its LAN ports). It's for connecting wired-only devices to a wireless network (so that they are in the same broadcast domain, hence "bridged"). It does not necessarily work as a repeater. In theory, it could, but ...


5

Bridging doesn't work the way you think it works. :-) A bridge is only concerned with OSI level 2 (Ethernet frames). On this level, IP addresses etc. don't exist. Conceptually, you can think of a bridge as a collection of ethernet interfaces. Each interface is called a port, and a packet that goes into one port comes out on all other ports. (Actually, in ...


4

(Edit) I answered the question first and when re-reading, I realized that wireless part of the question is in the title so I looked into that also. Specifically about the "wireless bridge": In summary, not possible with specifically the gear you have. Here is why I say this: - the ZTE is made as a base station. The documentation is fairly poor. It ...


4

You can’t bridge to a client-mode Wi-Fi interface. Bridging leaves MAC addresses as-is, and APs don’t accept frames from MAC addresses that have not authenticated and associated with the AP. For two devices to both bridge frames across a Wi-Fi link, they must both implement an optional part of 802.11 known as Wireless Distribution System (WDS). macOS does ...


4

I made my raspberry pi into a router. I created a br0, then addif both eth0 and wlan0 to br0. That's not a router. (It'd be a router if it linked two networks together, but right now you have a bridge – which means same subnet on both sides.) Started dhcpd and hostapd Somewhat concerned about this – is your Raspberry Pi the only ...


3

I had a similar problem with LXC, I worked around the bridging issue in wifi devices. First you need a spare ethernet device in the computer. The trick is to create a route from the ethernet device to the wifi. In the server file, change /etc/network/interfaces, pick an unused network for your virtual hosts, i.e. 10.0.0.0. Assign one IP to your spare ...


3

You seem to need ip forwarding. try cat /proc/sys/net/ipv4/ip_forward If it's 0 issue: echo 1 > /proc/sys/net/ipv4/ip_forward


3

I know I'm late, but I encountered the same problem recently. Mainly find the solution here: http://ajitabhpandey.info/2007/07/interconnecting-qemu-and-virtualbox-virtual-machines/ Key steps are enable IP forwarding and setup MASQUERADING on the bridge interface: $ echo "1" > /proc/sys/net/ipv4/ip_forward $ sudo iptables -t nat -A POSTROUTING -o br0 -...


3

I use to have this very modem and I think I speak for everyone when I say this thing sucks! However, there is hope. It sucks bad enough that I decided to crack it open and do some soldering onto it to get to a root shell. From there, I discovered a root escalation vulnerability in their web user interface. What all this means? You can root your modem with ...


3

I think with bridged mode OpenVPN doesn't hand out IPs. So you need to provide a DHCP server to do that. Looking more closely... here are my thoughts. I take it you got tap0 and eth0 junctioned into bridge br0? (brctl can verify) br0's IP on the server is NOT within the OpenVPN subnet. Let me guess, eth0is your Internet facing interface. You don't need ...


Only top voted, non community-wiki answers of a minimum length are eligible