New answers tagged

0

If you get certificate prompt, you can connect. The ECONNREFUSED probably refers to the data connection for directory listing, as you have not opened data ports. In Pure-FTPd you configure the data ports using --passiveportrange <minport:maxport> command-line switch. And you need to open those ports in your firewall. Plain unencrypted FTP likely works ...


0

Okay well, I figured it out in the end. I had two problems that looked like one to begin with. The first is that I didn't have the -c option enabled so when trying to write flash from my ProCurve to the server it wouldn't work. By editing /etc/default/tftpd-hpa config file and adding -c to the arguments I was now able to write files to the server. The error ...


0

If it is a problem with Thonar, then try the SSHFS FUSE filesystem: sudo apt-get install sshfs sshfs-mount -o reconnect user@remotehost:/some/dir/ /home/me/mountpoint/ If you use SSH keys for authentication then -o reconnect will work great. If not, leave off -o reconnect. Note that once sshfs has mounted you can use it like a normal filesystem, so no ...


0

You could be hitting a NAT timeout or something strange. Others noted the use of ClientAliveInterval and ClientAliveCountMax in the comments. This is what my config has been using for years: ServerAliveInterval 45 ServerAliveCountMax 60 On the server side you could try this: ClientAliveInterval 60 TCPKeepAlive yes Also see this in another SE community: ...


0

You dont have to set anything in your router for this. Just manually configure the network on your switch. Once you get to the IP address, fill out the ip address and network mask, but leave the gateway empty. The gateway is its access to the internet and by leaving it blank, it will only have local network access.


0

The typical way to handle this in FTP is to use the cd command to change the remote directory, while using the lcd (local cd) command to change the local directory (obviously a shell escape from FTP won't help (MS-Windows excepted, maybe)). Then just put your files from the local directory to the remote directory.


0

It's probably a bad idea to share your C:\ drive. Without firewall and with anonymous login enabled even more so!! Try a different directory and make sure the access rights are set correctly. Maybe it could help to create a user specifically to access this FTP share. This user can be provided with the appropriate rights more easily.


Top 50 recent answers are included