Skip to main content
69 votes

What does an `output is not a tty` error mean?

I found an similar topic like this. One Solution which worked for me: Write php.exe -i > info instead of php -i > info So yust append the .exe extension to your commands and it works. ...
Radon8472's user avatar
  • 801
35 votes

phpinfo() and php -v shows different version of PHP

If you have this problem while upgrading from PHP5 to PHP7 on Ubuntu 14.04 with Apache, here's what helped me (credit goes here): Disable PHP5 module on Apache: sudo a2dismod php5 Now enable PHP7: ...
Jan Żankowski's user avatar
32 votes

What does an `output is not a tty` error mean?

If you happen to be using winpty under the hood, you have to pass the -Xallow-non-tty argument to fix this: $ winpty python -c 'print("hello")' | grep h stdout is not a tty $ winpty -Xallow-...
chtenb's user avatar
  • 1,895
25 votes

What does an `output is not a tty` error mean?

What worked for me, based on Peh's comments to stackoverflow.com/questions/33622087 If you use C:\Program Files\Git\bin\bash.exe instead of C:\Program Files\Git\git-bash.exe then the command ...
targnation's user avatar
24 votes
Accepted

Apache showing PHP code - after upgrade on Mac to macOS Sierra

Sierra comes with PHP 5, not PHP 7. Anyway, check if the module is loaded in httpd.conf: LoadModule php5_module libexec/apache2/libphp5.so If this doesn't work, probably you didn't told Apache to ...
pietrop's user avatar
  • 366
23 votes

phpmyadmin symlinks error after ubuntu upgrade

For others: sudo apt-get install php-gettext might be the answer (especially with php7 as it seems that this is not included by default, maybe because it is a pear extension).
twicejr's user avatar
  • 331
19 votes

Where is the PHP executable on Ubuntu?

Type the following in your terminal whereis php
Robert Sinclair's user avatar
18 votes

make a certain software version the default in ubuntu

I think the best way to do this on Ubuntu is like that: sudo update-alternatives --set php /usr/bin/php5.6 You may change the version according to your needs.
Brainski's user avatar
  • 181
17 votes

How to install PHP, Pear, PECL, and APC with Homebrew on Mac OS X?

Now homebrew-php has been migrated to homebrew-core and by default, PECL should be installed along with your PHP. Here are the suggested steps: Reinstall PHP via: brew install php. Check pecl ...
kenorb's user avatar
  • 25.7k
16 votes

Error message: sudo: mysql_secure_installation: command not found

If you install mariadb over a package manager you will end up with the same error nowadays which can be solved by using this which is the new mariadb name alternative: mariadb-secure-installation
Unicornist's user avatar
16 votes
Accepted

ffmpeg command for concatenate two mp3 files

To skip re-encoding, use the concat demuxer: Create a text file file '/path/to/first.mp3' file '/path/to/second.mp3' and then ffmpeg -f concat -i list.txt -c copy out.mp3 If re-encoding is fine, ...
Gyan's user avatar
  • 36.8k
13 votes

Where is the PHP executable on Ubuntu?

I found the executables in /usr/bin/ eg: /usr/bin/php /usr/bin/php7.0 /usr/bin/php7.1
Andrew's user avatar
  • 399
13 votes
Accepted

Running PHP works in Command Prompt but not Git Bash

What can I do to get PHP working through my Git Bash command line? alias php='/c/wamp64/bin/php/php7.0.10/php'
simlev's user avatar
  • 3,852
11 votes

How to install the SQLite PDO extension on Ubuntu

Just for clarification, I recently got into this issue, for php7.2 I had to run sudo apt-get install php-sqlite3 which did install sqlite-3 there was no package named php-sqlite
Shobi's user avatar
  • 211
10 votes

How to install the SQLite PDO extension on Ubuntu

In ubuntu 16.04 there is no php5-sqlite. You need: sudo apt-get install php7.0-sqlite sudo service apache2 restart
Ganesh Bhosale's user avatar
10 votes

How to run PHP with Nginx on Windows 10 bash WSL?

Okay, I finally got PHP + Nginx working on Windows 10 bash. /etc/nginx/sites-available/default location ~ \.php$ { fastcgi_split_path_info ^(.+\.php)(/.+)$; fastcgi_pass 127.0.0.1:9000; ...
Scott Yu - builds stuff's user avatar
10 votes

Apache not executing PHP on CentOS 7 in browser

For those who care, apparently the default php72 don't install the mod_php. php72-php should be used instead. So I just simply reinstalled PHP using php72-php instead of php72 and restarted Apache....
IMB's user avatar
  • 5,533
9 votes

configure: error: Unable to locate gmp.h

just in case someone having same issue while trying to compile php via phpbrew, although /usr/include/x86_64-linux-gnu/gmp.h is definitely there and available: symlink for gmp.h solved this for me ...
Marat's user avatar
  • 210
9 votes

ffmpeg command for concatenate two mp3 files

Usually, cat first.mp3 second.mp3 > out.mp3 should just work. You didn't say what goes wrong when you try it. Alternatively, you can use mp3wrap: mp3wrap out.mp3 first.mp3 second.mp3 third.mp3 ....
dirkt's user avatar
  • 17k
8 votes

How can I completely remove PHPStorm, and all associated files on Ubuntu 13.04?

Please remove the main folder and ~/.PhpStorm* folders. That should be enough. sudo rm -R ~/.PhpStorm*
martin sun's user avatar
8 votes

How to manually install Apache, PHP and MySQL on Windows?

PHP 7 The instructions in the above answer work perfectly as of July 2017, however, if you wish to use PHP 7, you must add the following lines to C:\Apache24\conf\httpd.conf, instead of the ones in ...
undo's user avatar
  • 6,101
7 votes

How can I remove Apache2 that I have installed in Mac OS X?

sudo apachectl start to make sure it is running go to http://localhost:80 to ensure you see "It Works!" or something comes up to confirm it is running. sudo launchctl unload -w /System/Library/...
Puneet Lamba's user avatar
7 votes
Accepted

How to get the client sidecomputer bios serial number

There's really good reasons you don't want to run arbitrary code on a client side system - if you can run wmic bios get serialnumber you could also run a virus, ransomware or other nasty stuff. Being ...
Journeyman Geek's user avatar
  • 130k
7 votes

Malicious request in log

The first attempt (?a=fetch&content=die(@md5(HelloThinkCMF))) is an old WordPress exploit. If you are running WordPress and haven't updated it in years, do so. Otherwise, that won't do anything. ...
sherrane's user avatar
6 votes

How to install PHP, Pear, PECL, and APC with Homebrew on Mac OS X?

pecl and pear are provided with Homebrew's version of PHP: brew install php pecl install apcu If you're weary that pecl and pear are provided by php, try this: ls -al $(which pecl) ls -al $(which ...
tresf's user avatar
  • 301
6 votes

How to uninstall php70 or suppress homebrew error messages

I'm using ZSH and I had the same problem. Every time I open a new terminal I had: Error: No available formula with the name "homebrew/php/php70" Please tap it and then try again: brew tap homebrew/...
Roberto's user avatar
  • 61
6 votes

What security can cookies give to my website?

Cookies are not a security measure Judging from your description, you are both new to security and the inner workings of the web, so I will try to explain both concepts as beginner-friendly as ...
MechMK1's user avatar
  • 1,744
6 votes

Downgrade PHP Version

Since Mint is a Debian/Ubuntu derivative, the following should work: sudo update-alternatives --config php Your system should then display a list of the PHP versions that are installed on your system ...
StarCat's user avatar
  • 1,240

Only top scored, non community-wiki answers of a minimum length are eligible