36

There is a very simple solution because PulseAudio already has all the necessary tools. Get your source device name with command pactl list | grep Name Create the following script named pashare: #!/bin/sh case "$1" in start) $0 stop pactl load-module module-simple-protocol-tcp rate=48000 format=s16le channels=2 source=<source_name_here> ...


36

Actually, yes, there is a way to do so without restarting Pulseaudio: pacmd unload-module module-udev-detect && pacmd load-module module-udev-detect I use it everytime I plug in my external-soundcard or after waking up my laptop. Pulseaudio cleans up his room and bring back my Spotify music on my external soundcard automatically (as it is my ...


25

You can use VLC to serve a MP3 stream of pulseaudio's output via HTTP. The main advantage is that you don't need to install any special software on your remote device, a web browser (or music player) is all you need to play the stream. The downside is that it's audio only, a few seconds lag make it useless for videos Find pulseaudio's output name with: ...


19

Here is how I was able to resolve this: sudo vim /etc/default/grub Find GRUB_CMDLINE_LINUX_DEFAULT and add snd_hda_intel.dmic_detect=0 to the end of it. (ex: GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 snd_hda_intel.dmic_detect=0") sudo grub-mkconfig -o /boot/grub/grub.cfg Reboot the system.


15

To stop user services it's necessary to use the parameter --user: systemctl --user stop pulseaudio.socket systemctl --user stop pulseaudio.service


12

You can try using apulse: it is minimalistic pulseaudio emulator made specifically to run Skype 4.3 with ALSA. You need 32-bit build even on 64-bit machine. I personally had troubles with microphone on Ubuntu 14.04, but for most people it works fine. To build apulse on Ubuntu (and related distros), you must install following packages: pkg-config build-...


12

Running pulseaudio -k && pactl load-module module-detect worked for me. This will restart pulseaudio and therefore forget existing devices. Afterwards it will rescan for devices. The difference here is not to use udev, maybe there is an issue with the setup that prevents udev support. This was necessary for me, as I'm using external devices at my ...


11

Open up alsamixer. Then press F6 to select your sound card, most likely ending with PCH. Scroll right till you find the Auto-Mute option. Press up or down arrow to disable it. Press Esc to quit alsamixer. Use the following script to automate it. #!/bin/sh NAME=$(basename -- "$0") command -v amixer >/dev/null 2>&1 || { echo >&2 "amixer ...


10

This Gentoo wiki article might apply here : PulseAudio per-application volume control : PulseAudio supports per-application volume control, but by default this doesn't do much as you can only control these volumes from the pulseaudio volume control utility. Meaning that in an application like Audacious, when the output device is set to PulseAudio, ...


10

To stream audio output over wifi to your android phone you need to install server software, that sends audio, on PC and client software on Android device. Available options are WiFi Audio Wireless Speaker Run WiFi Audio Android App and Press start, you will see IP address of mobile device in the bottom after that run Windows/Linux application and put mobile ...


10

You may have to install pavucontrol. XFCE is minimalist, so is expected that some settings are not found. To install it just type: sudo apt-get install pavucontrol


10

Short answer : There is no solution as long as you are using Linux and a Bluetooth headset. Long answer: For music playback only A2DP is suitable, but it does not have an INPUT mode so use of the headset for VoiP isn't possible. The HSP/HFP mode uses the CVSD codec which is sampled at 8 kHz, same as used in telephony systems (so sounds like an old telephone, ...


9

I have a headset (combined stereo headphones and mic) jack on my Dell PC with Ubuntu 16.04 and experienced the same problem. First use hdajackretask check that the problem is not related to the jack: Press Ctrl+Alt+T to access the terminal. Type sudo apt-get install alsa-tools-gui Once installation is complete, launch HDAJackRetask app from the dash and it ...


7

After some more searching I found a post that told me to create /etc/modprobe.d/alsa-base.conf with following contents: options snd-hda-intel model=dell-headset-multi After reboot the headset microphone showed up again and works.


7

I made the following changes in ~/.config/pulse but you can also put them in ~/.pulse if it doesn't already exist. At least on this system, pulseaudio runs as the user. No system configurations were being applied from /etc/pulse, so editing them made no difference. ~/.config/pulse/daemon.conf resample-method = speex-fixed-7 default-sample-rate = 48000 ...


6

Telling that PulseAudio won't be very useful. It can already detect hotplugged devices just fine on its own; however, due to --disallow-module-loading it is no longer able to use the devices, since it's forbidden from loading module-alsa-card after a device is detected. (Arguably module-udev-detect should be exempt from this restriction…) You can tell ...


6

The option snd_hda_intel.dmic_detect=0 is deprecated on newer kernels, you may use snd-intel-dspcfg.dsp_driver=1 instead. But be aware, it's slightly different meaning.


5

I managed to have skype 4.3. running on my (otherwise pure ALSA) system. I'm running openSuSE 13.1, so, I can only describe what I did here. The general idea was to have skype running in a sort of 'pulseaudio jail'. I installed pulseaudio but did not activate it. The most important thing about NOT activating pulseaudio seems to be a line autospawn = no in ...


5

This answer builds on @dirkt's answer, so thanks are due to him. You can edit ~/.config/pulse/default.pa. It's listed under FILES in the "pulseaudio(1)" manual page. If it is present, the global default.pa is not used. For me, I can get a working setup with the following minimal configuration: load-module module-alsa-sink device=default load-module module-...


4

Similar situation with an EMU 0202 USB audio card. Alsa shows a "PCM" mixer control that doesn't actually do anything except mute the device. $ amixer -c USB Simple mixer control 'PCM',0 Capabilities: pvolume pswitch pswitch-joined Playback channels: Front Left - Front Right Limits: Playback 0 - 200 Mono: Front Left: Playback 200 [100%] [0.00dB]...


4

The correct syntax for setting the Pulseaudio server as an IPv6 address is PULSE_SERVER="[2001:470:ca90:4:ba27:ebff:fee2:ada9]" - with both "" and [] ! Problem solved - let the music flow across the IPv6 !


4

How do I make them quieter? Use the inline volume control. Note One customer review reports "volume control is faulty". See below. A workaround is to install http://sourceforge.net/projects/equalizerapo/ to an audio device and adjust the device's master volume. Intuitive in-line controls Making adjustments is a breeze with the convenient in-...


4

paprefs currently uses GConf, the GNOME 2 settings storage system (via module-gconf). Its backend storage, while technically "just XML", is not meant to be edited directly – instead you can use gconftool-2 or gconf-editor to access the settings under /system/pulseaudio. Note however that GConf is deprecated; nearly no other apps use it anymore. For ...


4

You don't configure PulseAudio to use the ALSA default device. Instead, you configure ALSA to use pulse as the default device: pcm.!default pulse ctl.!default pulse In that way, ALSA applications that are not aware of PulseAudio will use PulseAudio via that indirection layer. The reason you need to do this is that PulseAudio always uses ALSA as backend, ...


4

To fix this, one can re-bind the volume control keys to use the ao-volume and ao-mute properties instead of the built-in softvol filter controls (see also the corresponding ArchWiki entry). For this we need to modify ~/.config/mpv/input.conf (create it if it doesn’t exist) and add the following entries: 0 add ao-volume 2 9 add ao-volume -2 m cycle ao-mute ...


4

Pulseaudio can create various sinks (what you call "virtual soundcards", but sinks are for output, sources are for input, and they also get associated to real sound hardware). Have a look at the module list which includes the sinks, and syntax examples. You have the choice between using RTP/SDP, ROAP. You can also access a pulseaudio server on the host ...


4

The automatic monitor that is created is not recognized by a lot of programs as a source. Try remapping the source: pactl load-module module-remap-source master=alsa_output.pci-0000_00_1b.0.analog-stereo.monitor source_name=virt_mic source_properties=device.description=VirtualMic That should show up in Discords list


4

First of all thanks a lot for your starting point, as i was looking to do the same by joining a conference as virtual user and playing audio. I got it working with the following changes to your Dockerfile and entrypoint.sh: Dockerfile FROM buildkite/puppeteer:latest # Install pulse audio RUN apt-get -qq update && apt-get install -y pulseaudio # ...


3

I had the same-ish problem. There's no workaround, I've already wasted two days to fix the problem. You can install pulseaudio and make it work with an older version of alsa. Because pulseaudio works smoothly with old versions of alsa. I'm using 1.0.16. Here's a script to install this version. I've experienced just one issue so far with pulseaudio and ...


3

So in short, it looks like the problem is up at the alsa level and not at the pulseaudio level? If you want to see the alsa devices try. aplay -l (but aplay -L which you've already mentioned is similar). pulseaudio sits on top of alsa. So looking at pactl brings in another layer of software... see here troubleshooters.com/linux/sound/sound_troubleshooting....


Only top voted, non community-wiki answers of a minimum length are eligible