13

apt-cache policy gdb Sample output: gdb: Installed: 7.7.1-0ubuntu5~14.04.2 Candidate: 7.7.1-0ubuntu5~14.04.2 Version table: *** 7.7.1-0ubuntu5~14.04.2 0 500 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages 100 /var/lib/dpkg/status 7.7-0ubuntu3 0 500 http://fr.archive.ubuntu.com/ubuntu/ trusty/main ...


12

Enable a repository: dnf config-manager --set-enabled <repo> Disable a repository: dnf config-manager --set-disabled <repo> Show help: dnf config-manager --help-cmd The first two should be run with superuser rights. DNF config-manager Plugin documentation.


7

Create a HTTP server and copy all the content from http://repo.continuum.io/pkgs/. Point to this new server with a .condarc file. Choose a web server, and put the files referred to in the public repository (above) in there, with identical directory structure (but you don't need the /pkgs/free/ part). Use the respository file (eg. http://repo.continuum.io/...


6

I would like to add: yum -v repolist all in case the server is using Spacewalk or part of RedHat this can be very useful to find the Repository URL. NOTE: If the server is registered to Spacewalk there will be no entries under /etc/yum.repos.d/ At least using the command to register like : rhnreg_ks --activationkey=<key> --serverUrl=http://<...


6

Is it offline? Short Answer - Yes. You can use Is It Down Right Now? to check the status of any website. "Is It Down Right Now" monitors the status of your favorite web sites and checks whether they are down or not. Check a website status easily by using the below test tool. Just enter the url and a fresh site status test will be performed on the domain ...


6

Yes, Windows 10 PowerShell has PackageManagement. For python, I believe you need to install chocolatey as a package provider first. Here is how I was able to install python using PackageManagement. Run PowerShell as administrator Install-PackageProvider chocolatey Find-Package python This shows python 3.7.2, if you want python 2.7.x, use python2. ...


5

Follow these steps to install Terminator on a fresh install of CentOS 7. First install the Extra Packages for Enterprise Linux (EPEL) repository: yum install epel-release Then update the newly installed repo: yum update The Terminator package is contained in the nux-desktop repository. You need to download the rpm file first before you can then add it ...


5

Man page for yum says this under List Options - name.arch [epoch:]version-release repo or @installed-from-repo So I would say you installed jdk.x86_64 from puppmst-repo


5

Welcome to SuperUser. Cloning a repository is grabbing all the source files and copying them to your computer so you can work with them. It looks like you're downloading the source files and not a compiled library. You can compile the library yourself if there isn't a download link for it on the GitHub page or in the readme file.


4

Are you sure this is a good idea? It is true that Ubuntu is based on Debian, but not everything in the Ubuntu package repositories can work flawlessly in Debian (on which Kali is based). In general there are differences between the two, and you can end up paralyzing your system, and compromising it in so may places that it may turn out to be simpler to re-...


4

As @Chris mentioned, current versions of Git do support sparse checkout. To convert a local repo to contain only specified directories: cd <repo/location> git config core.sparsecheckout true echo desiredDir/ >> .git/info/sparse-checkout # repeat to add multiple subdirs (the rest will be removed) Now, to remove all, but the specified ...


4

I don't know of a repository for this version, but it is still possible to download an ISO. The name of the ISO is SLES-10-SP4-DVD-i386-GM-DVD1.iso for the i386 version, or SLES-10-SP4-DVD-x86_64-GM-DVD1.iso for the x86_64 version. Here are a couple of download links that I found using Google : SLES-10-SP4-DVD-i386-GM-DVD1.iso SLES-10-SP4-DVD-x86_64-GM-...


4

I ran into this problem, and it appears some others are as well. The common factor, is that our repository directories are mounted on a CIFS share with RW access. Per this RedHat BugZilla: https://bugzilla.redhat.com/show_bug.cgi?id=429201 What worked for me was modifying my /etc/fstab/ file to include nobrl in my CIFS declaration: # /etc/fstab # Created ...


4

Ok, turns out the repository is providing the correct version and it's a Firefox issue. One I had already noticed more than a year ago: Firefox incorrectly detects the Flash version based on the pluginreg.dat file on the Firefox profile folder.


4

One clarification on @Hewbot's answer. One can use personal access tokens instead of OAuth. The YOUR_TOKEN value in the "Authorization: token YOUR_TOKEN" section of the curl command can be obtained as follows. Upper right corner, click User Settings Personal Access Tokens For scopes, select Repos. Create New Token. For more details, click here and here.


4

As the key is not availaible on the debian key server but on the ubuntu one. Therefore you need to pass an option to query the ubuntu keyserver specifically, then it will work as expected. The command is : apt-key adv --keyserver keyserver.ubuntu.com --recv-keys C2518248EEA14886


4

There is no 'technical' answer to your main question. The only answer is "It's what the project's author decided to put in the README", and unless you go and ask them directly, you will only get answers that try to guess at some unknown person's thought process Why is this particular library special in that it requires some "git" stuff? The project's ...


3

Search for folders with .svn subfolder - it means that folder that has it is SVN repository.


3

[kubuntu 18.04] I could not work out why the suffixes .distUpgrade and .save were ignored when there did not appear to be anything that explicitly sets this. Then I discovered apt-config dump | grep -i ignore has entries for these and others: Dir::Ignore-Files-Silently ""; Dir::Ignore-Files-Silently:: "~$"; Dir::Ignore-Files-Silently:: "\.disabled$"; ...


3

Perhaps wget. There is even wget for Windows. And here is curby's wget-mirror which I use: # # # get prerequisites # don't get parent \ # \ \ wget -N -l inf -r -np -p $1 # / / / # / | / # | | recursive get # | infinite recursion #don't get unless newer than local


3

LMDE is debian based, so googling of "debian WARNING: The following packages cannot be authenticated!" immediately finds excellent https://wiki.debian.org/SecureApt#How_to_find_and_add_a_key page. Try so: wget https://ftp-master.debian.org/keys/archive-key-7.0.asc gpg --import archive-key-7.0.asc Then "apt-get update" and "apt-get install --no-install-...


3

AWS CodeCommit is a fully-managed source control service Which means it is intended for sources. Here are some reasons why a source control is a poor choice for binaries: First and foremost – a version control system (VCS) is not a Maven repository! It can’t calculate Maven indexes. Versioning mismatch. Source files are versioned by their content. VCSs ...


3

On the assumption you're trying to create a yum repo, you need to run: yum install createrepo and then the command is: createrepo WITHOUT a space between create and repo. See here for more information.


3

Use zypper lr to list repositories, ls lists services. Or, if you really want to remove the service, use rs instead of rr.


3

This might help someone out. If you use a restful client with a GUI, this is basically the configuration that you need to get your repo created: Make sure you add your token after the word token.


3

In think the answer is in the question. epel-release = 7 is needed by remi-release-7.2-1.el7.remi.noarch So you need to install EPEL repository. Tips, use the wizard.


3

They can often do different jobs: Travis supports Linux and macOS, but currently not Windows. Circle CI seems to support macOS more reliably than Travis. AppVeyor supports only Windows, and it can do additional tasks – e.g. generate the "installer" packages for releases.


3

TempleOS is not known to be officially hosted in any repository. However, every binary file is just source that's JIT-compiled when you run it. To edit code you can use Ed("~/file.HC.Z"), and to see it (the Linux equivalent of cat you can use Type("~/file.HC.Z") Further HTML docs generated from the TempleOS 5.03 source code can be found here: https://...


2

Thanks everybody for your helpful suggestions! when I got that by entering every command in Terminal the answer is a Parsing Error within the yum-fast-downloader.repo so I delete the file from the etc/yum.repos.d directory. then I got that by entering the same commands I got an error suggesting another parsing error in the skype repo file, so i delete it too....


2

1) I don't think that PPAs may be preferred 'over' core repos; instead, they should used in addition to core repositories when you need something different (i.e. latest Apache) that distro doesn't provide PPA allows to install and upgrade software and track dependencies using same 'standard' discovery, installation and upgrade facilities as apt-get, ...


Only top voted, non community-wiki answers of a minimum length are eligible