51

For temporary solution or for someone like me permanent solution: go to "File / Settings / Packages" search "spell-check" click to button "Disable"


43

Maybe it is default checked in 2016, while it was not in previous versions. You can change it in File - options - proofing next to "writing style" click "settings" in "style" group uncheck "contractions"


41

As far as I know contractions are still considered proper English. They are - but not in formal English. Note that this a Grammar setting not a Spelling setting. Please take a look at the Grammar and Writing Style options, in particular the section called "Formal Language": Contractions Targets contractions (e.g., let's, we've, can't) which ...


26

Disable the spell-check plugin Go to Settings > Packages > Spell Check. Click the Disable button. Toggle spell check for the current file Open up the Command Pallette (⌘+⇧+p). Type in Spell Check: Toggle. Hit enter. Create a shortcut to toggle spell checking Go to Atom > Keymap... Add those lines at the bottom of the keymap.cson file: 'atom-text-editor'...


24

I use French and English in almost all of my emails and this is a nightmare. There is a (quite simple) solution, but you need to hack one of your dictionaries: copy-paste the content of e.g. your English dictionary into your French one; it works! As simple as that! This is how I solved this issue on Mac OS X: Go to /Users/HERE_YOUR_USER/Library/...


24

Check the Control Panel. Which languages do you have installed? If you have only Norwegian, try adding English as well: You can then switch languages from the language icon in the taskbar. You can also press ⊞ Win+C to bring up the Charms bar, select Settings / Change PC settings / General and modify the Spelling and Language options as required: BTW, ...


20

Go to File > Options > Proofing and un-check the Check spelling as you type box


20

I found a better way to do this in Word 2010 after getting so frustrated with this. This is THE way to go if you ask me when working with multiple Styles, etc. Open your document File Options Proofing On the right pane, scroll down Check both checkboxes to enable an Exception for grammar and spelling for your document


19

To disable spelling correction in Internet Explorer 10 on Windows 7: Go to Tools → Manage add-ons Under Spelling Correction, uncheck "Enable spelling correction"


13

I found a new hidden preference that disables continuous spell checking in most text views: defaults write -g NSAllowContinuousSpellChecking -bool false It prevents you from checking Edit > Spelling and Grammar > Check Spelling While Typing, but you can still use ⌘: and ⌘; to check spelling manually. (I searched for potential preference keys with strings /...


13

There is no direct way of limiting the spell checking parser to only comments in Sublime Text 2 (but this is simple to do in Sublime Text 3). These programs are not written to differentiate text document and some code syntax. So most of the code syntax looks like spelling errors. The best solution is to toggle spell-check with F6 and right-click on the ...


13

I was going through the same issue and here is what I believe to be the most correct answer: You cannot turn off autocorrect in Windows 10 mail. It lives its own life independant of Windows 10's "typing" settings. You can, however, change the language for an ENTIRE mail, but it's not obvious how to do that - You might think selecting all and then choosing ...


12

With GNU grep: echo 'Hi! Hi, same word twice twice, as as here here! ! ,123 123 need' | grep -Eo '(\b.+) \1\b' Output: twice twice as as here here 123 123 Options: -E: Interpret (\b.+) \1\b as an extended regular expression. -o: Print only the matched (non-empty) parts of a matching line, with each such part on a separate output line. Regex: \b: Is ...


11

Update for Windows 8.1 as of 11/2014: Since I've been using StartIsBack and Glass8, I've been reconciled with Windows 8 and 8.1, in as much as it now looks as nice as Windows 7. (Note: Talking about real PCs here, not ARM devices faking to be PCs.) But every now and then, TIFKAM ("The Interface formerly known as Metro") rears its flat head, like when - and ...


10

Software in general is unfriendly to us bilingual users. No web browser offers this functionality built-in. Some operating systems do, however. For example, on the Mac, switching your keyboard layout will switch default-dictionary used in any input field implemented using the OS-provided methods. Similarly, if you enter a full sentence into a text field, it ...


9

You can enable the beta version of "simultaneous spellchecking in multiple languages". go to about:flags and enable Enable Multilingual Spellchecker:


9

File >> Options >> Proofing Should be an option to turn off grammar/spell-checking for your document. Reference


8

Thanks François; this was inspiring. The corresponding solution in Ubuntu/Linux does the same for the hunspell. I wanted to combine my English dictionary with Hebrew, and I did this: cd /usr/share/hunspell sudo cp he.dic he.dic.bak sudo cp he.aff he.aff.bak sudo sh -c 'cat en_US.dic >> he.dic' sudo sh -c 'cat en_US.aff >> he.aff' (The sh -c is ...


8

On OS X the checkbox is now under Edit -> Spelling and Grammar. Note that the browser must be focused on a text box for the menu entry to be enabled. On my system the checkbox appeared as set only after I restarted Chrome. The red lines disappeared immediately as I unchecked it.


8

:help 'spelllang' tells that the option can contain "A comma separated list of word list names." So, the following should work already: :set spelllang=en_us,de_de


7

The latest version of Chrome (26.0.1410.43) has experimental support for auto-correct. To enable it, navigate to chrome://flags, scroll down until you see "Enable Automatic Spelling Correction" and press Enable. This feature is not yet supported on OS X.


7

It's because the automatic language detection feature is turned on. To switch it off: Open a new e-mail message. On the Message tab, in the Proofing group, click the arrow under Spelling. Click Set Language Button image. Un-check the Detect language automatically check box.


7

Here is one method I found that suits my needs: You can modify the "Normal" style* for that document (which in turn modifies any styles based on Normal). From the Styles bar, r-click on Normal, select "Modify", click the "Format" button (bottom left), select "Language", and check the box labeled "Do not check spelling or grammar." (A more detailed set of ...


7

Clicking "Apply styles" again, and then "Modify" shows that the "Do not check spelling or grammar" checkbox is still filled-in-selected. In other words, the language setting didn't "take". This is what I remember that I used to be able to do with older versions of Word. For some reason, I can't get it to work now. OK, I figured it out on my own. ...


7

I've added language to my quick access toolbar, so in my case it's just pressing Alt+2 to change the language.


7

For Word 2013, if you want to ignore spelling errors for a particular document while still check spelling errors for other documents, you can go to the Exceptions for: section at the end of the File -> Options -> Proofing section. Your current document should be selected in the drop-down as default. Check the Hide spelling errors in this document only....


6

Seems like it is a bug see https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/980467. I think the only workaround is to mark the text on the slides individually and select "format" -> character and there select the language you want. Hope this is fixed soon.


6

This does not seem to be possible currently. See http://support.google.com/chrome/bin/answer.py?hl=en&answer=95604 at the very bottom. It suggests what you did...


6

Currently Vim provides no "native" mechanism to do this, although I think it is a good idea. The only thing I can think of is an :autocmd that calls a function that searches for a special section in the file and then moves the cursor over the words in that section and triggers zG with :normal commands. This would be messy and I would be reluctant to bother ...


6

From How to Disable Built-in Spell Checker Feature : Move your mouse cursor to top-right or bottom-right corner of screen to access Charms Bar and click on Settings option. Now click on Change PC settings option given at the bottom. It'll open Metro Control Panel or PC Settings page. Click on General section given in left-hand side in Windows 8. If you are ...


Only top voted, non community-wiki answers of a minimum length are eligible