New answers tagged

0

download cd ~ git clone https://github.com/Homebrew/brew homebrew mkdir ~/usr/local # installed packaged directory echo "export HOMEBREW_PREFIX=~/usr/local" >> ~/.zshrc echo "export PATH=$PATH:~/homebrew/bin:HOMEBREW_PREFIX/bin" >> ~/.zshrc update brew brew update # if error brew update-reset


0

This can happen if sudoers files are included twice, which can happen if /etc/sudoers contains two lines with same meaning, such as: @includedir /etc/sudoers.d #includedir /etc/sudoers.d Now, all files in /etc/sudoers.d/ will be read twice and will cause warning above.


1

If you are not in the /etc/sudoers file, then you cannot run commands as sudo. That said, if you are a software developer and not in the /etc/sudoers file, just let the server admin install the packages you need installed. Your question is really an XY problem; you seem to not need sudo access as much as you want to install redhat-lsb-core. Knowing that, it ...


0

The owner of the system (the one that has access to root) must give you permission to do tasks as root. sudo is a root-delegation tool. The root can delegate specific tasks to a user, or give general root access to a user (or group for that matter). If a normal user would be able to give himself root permissions, that would be a huge security issue. That is ...


1

This is a symptom that sssd is not reachable. If you aren't using sssd, the accepted answer is good, and you should follow it and remove sssd from /etc/nsswitch. But if you are using freeipa, or redhat ipa, or similar, then you need sssd, so don't touch /etc/nsswitch. Instead, make sure that sssd is running and is happy. Start with: systemctl status sssd ...


0

sudo su - admin will let you become root. In AWS pfSense 21.05.2, you login with the username admin and automatically are root after choosing option 8: ssh -i ~/.ssh/your_key.pem admin@<your_ip> *** Welcome to Netgate pfSense Plus 21.05.2-RELEASE (amd64) on pfsense *** WAN (wan) -> ena0 -> v4/DHCP4: <your_ip>/<bits> 0)...


0

Issue was there in /etc/login.confs , in Debian System 2, UMASK was set to 077 after updating /etc/login.confs with UMASK to 022, reboot the system it is giving expected output. $ sudo install -m 0755 -d folder/kumar $ echo "something" | sudo tee -a folder/dict/file something $ ls -lcrt folder/dict/ total 4 -rw-r--r-- 1 root root 6 Oct 25 13:25 ...


Top 50 recent answers are included